cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1162
Views
0
Helpful
2
Replies

Backup Links with BGP

faresn
Level 1
Level 1

Greetings all,

We currently have two DS3 links to two differents providers, one of links is going away and a new OC3 is being installed from a new provider. We're planing on making the OC3 as the primary internet link and the DS3 as the backup, can you guys provide some feedback and perhaps some configuration examples?

Thanks

Fares

2 Replies 2

liviu.gheorghe
Spotlight
Spotlight

One way to do this is to define BGP peering between loopback interfaces on the routers, and configure a static route to the remote loopback via the OC3 interface and another static route to the remote loopback interface via the DS3 with administrative distance greater than 1:

interface loopback 1

ip address 1.1.1.1 255.255.255.255

!

router bgp 65500

neighbor 2.2.2.2 remote-as 65200

neighbor 2.2.2.2 update-source Loopback0

!

ip route 2.2.2.2 255.255.255.255 Serial5/0/0 <---- route through OC3 interface

ip route 2.2.2.2 255.255.255.255 Serial5/0/1 250 ---- route through DS3 interface

The other side is configured similar.

Cheers

Liviu

Regards, LG
*** Please Rate All Helpful Responses ***

ruwhite
Level 7
Level 7

Are you planning on load sharing at all over the two links, or not? It sounds like you're not. Are both links coming in to one router, or two? I'll assume two, and rework things if you reply with one. :-)

There are a couple of different things you can do here. You have to deal with inbound traffic, and outbound traffic.

For outbound traffic, you can just advertise a default towards both routers all the time, but make the metric on the router with the backup link such that it will only be used if the default off the primary router is gone. One sort of easy way to do this is to accept just a default, and set its local preference on the primary router high. Accept just a default on the secondary router, as well, and set its local preference to something lower. Since you'll be running iBGP between the routers, the backup router won't ever prefer the locally generated default unless the primary link has failed. This would look something like this:

router1

!

route-map setlocalpref permit 10

set local-preference 110

!

router bgp 65000

neighbor x.x.x.x remote-as

neighbor x.x.x.x route-map setlocalpref in

neighbor y.y.y.y remote-as 65000

router2

!

router bgp 65000

neighbor x.x.x.x remote-as

neighbor y.y.y.y remote-as 65000

Note this will work, as well, if both ISPs are connected to one router, just using the route map on one of the two neighbor statements on the same router. Now, if you generate a default route from both routers into your IGP, things should work, outbound, as you are expecting. The inbound side has a few more options.

You can advertise your routes to the backup ISP with really long as path prepends, and that might work--but only if both ISPs are advertising the same prefixes you're advertising to them. If the primary ISP is aggregating your address space, then adding to the as path towards the backup isn't going to help.

You can also often advertise your routes with a community that the receiving ISP will use to set their local preference. Thus, you could find out what communities your backup ISP will listen to, and advertise a community that causes them to set their local preference on routes you advertise to 50 or so, which would make them prefer the routes through your primary provider. Again, this won't work if your primary provider is aggregating your address space.

Finally, you could use conditional advertisement to advertise routes to your backup ISP only when the primary ISP is down (or rather, your link to the primary ISP is down). For conditional advertisement, see:

http://www.cisco.com/en/US/tech/tk365/tk80/technologies_configuration_example09186a0080094309.shtml

Russ.W

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: