Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Bandwidth control in LAN

Dear all,

How can I control bandwidth on my LAN users? Here I am describing my scenario;

Number of total LAN users are 200. All the users are using same gateway (Cisco 2600 router). The main internet bandwidth is 10Mb/s. Now The problem is, my LAN users are peaking the full bandwidth (10Mb/s). But I want to limit it during day time to 5 Mb/s or 50Kb/s per users.

How can I be able to do it? Please advise any Cisco or non Cisco base solutions.

Many thanks.

7 REPLIES
Silver

Re: Bandwidth control in LAN

Bandwidth control can only be use on routers.what you can do is to setup the speed on the interface either in 10mbps or in 100mbps.

You can check on the following link that there is no bandwidth command like in the router:

http://www.cisco.com/en/US/products/hw/switches/ps637/products_command_reference_chapter09186a008007eed6.html

Also just for you to know there is another thing that you can control on the ports.That would be storm control, this command is for a lot of broadcast or multicast traffic that you want to control on the interface.

Here is a useful link of storm control:

;http://www.cisco.com/en/US/products/hw/switches/ps637/products_configuration_guide_chapter09186a008007f242.html#xtocid57416

Bronze

Re: Bandwidth control in LAN

What kind of switches do you have deployed in your lan environment? Some support port-based rate-limiting.

New Member

Re: Bandwidth control in LAN

Hi Sean,

I am using CAT2950 with Enhanced image support. As cost is a constraint for me to buy CAT4K, will you please suggest me any other CAT switch that is below CAT4K and that support rate-Limiting?

Many thanks.

Bronze

Re: Bandwidth control in LAN

You should be able to do rate-limiting with the enhanced image on your 2950. 2960, 3550, 3560, 3750, etc. all have support for this with QoS. An example on a 3550 would be:

mls qos

class-map match-all rate-limit

match ip dscp 0

policy-map 2meg

class rate-limit

police 2048000 384000 exceed-action drop

interface FastEthernet0/7

description [Example-Customer]

switchport access vlan 999

switchport mode access

switchport nonegotiate

service-policy input 2meg

service-policy output 2meg

no cdp enable

spanning-tree portfast

spanning-tree bpduguard enable

spanning-tree guard root

end

New Member

Re: Bandwidth control in LAN

Hi Sean,

Thank you very much.

Cat 2950 can ony shape bandwidth on ingress queue. it cannot do the shaping on egree queue and that is why service-policy output command is not available in the interface config mode even with the enhanced image. Perhapes rate-limit option also do not available on Cat 2950 series.

I already have tried with this (service-policy input)option and failed.

Many thanks.

Bronze

Re: Bandwidth control in LAN

can you rate-limit straight on the port?

New Member

Re: Bandwidth control in LAN

No I cannot rate-limit straight on the port. Do you know any way on Cat2950 platform?

266
Views
0
Helpful
7
Replies