Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

basic eigrp question

Please see the config below. (I changed the ASN and the IP addresses so please don't get hung up on that) My goal is to load balance between FA2/0 and FA2/1, and have my default route (network) be both FA2/0 and FA2/1. If either link goes down, (which happens from time to time) will my eigrp traffic still flow through the other available link without issue, taking into account "variance" and "traffic-share"?

interface FastEthernet2/0

description 100 Mb connection to xxx

bandwidth 100000

ip address 10.1.1.6 255.255.255.252

ip access-group 103 in

ip access-group 104 out

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no keepalive

duplex full

speed 100

no cdp enable

!

interface FastEthernet2/1

description 100 Mb connection to xxx

bandwidth 100000

ip address 10.1.1.14 255.255.255.252

ip access-group 103 in

ip access-group 104 out

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no keepalive

duplex full

speed 100

no cdp enable

!

autonomous-system ???

!

router eigrp ???

redistribute connected

redistribute static

network 192.168.0.0

network 10.1.0.0

distance eigrp 9 10

variance 2

traffic-share balanced

no auto-summary

eigrp log-neighbor-changes

!

ip default-network 10.1.0.0

2 REPLIES
Bronze

Re: basic eigrp question

The configuration seems fine. The load balancing should work in this case.

However, I guess the ip default-network works in a classful manner.

So the command given should be ip default-network 10.0.0.0. Refer to this doc for the details.

http://www.cisco.com/en/US/tech/tk648/tk365/technologies_tech_note09186a0080094374.shtml#ipnetwork

In the scenario given by you, load balancing would work without the variance command also, since both the links have the same bandwidth.

New Member

Re: basic eigrp question

Thanks for your reply. I was beginning to wonder if was that basic of a question that no one wanted to give a reply ... haha.

You are right about the ip default-network command. My default network is actually a class "B" address. As I stated, I changed the IP address for security issues. So I would have xxx.xxx.0.0 for my default route. That is a very good catch. Thanks for the info on the variance command as well.

Regards

81
Views
5
Helpful
2
Replies