Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Basic Frame-Relay Setup

Hi,

Can some one tell me how I should configure my router using frame to pass traffic transparently... I will be using a Cisco 1720 with a dedicated 128k frame on s0/0 connected to a NetScreen (for firewall and VPN) via e0/0. I built the bridge-group and corresponding PVC in our MAIN ROUTER just like I would for a DSL PVC. This is what is on the main router sub-interface to connect to the 1720 (CPE).

interface Serial0/0.47 point-to-point

description Bla Bla Bla

bandwidth 128

no ip route-cache

no ip mroute-cache

frame-relay interface-dlci 78

bridge-group 3

interface BVI3

description NON-DSL Frame-Relay Connectivity

ip address 4.x.x.x 255.x.x.x

This is my main Serial Interface for these subs:

interface Serial0/0

description connected to Frame-Relay Cloud

no ip address

encapsulation frame-relay IETF

no ip route-cache

no ip mroute-cache

keepalive 12

no frame-relay inverse-arp

frame-relay lmi-type ansi

This is the current 1720 (CPE) config (not completed I assume for this scenerio to work...):

interface Serial0

description Bla Bla Bla

ip address 4.x.x.x 255.x.x.x

no ip proxy-arp

encapsulation frame-relay IETF

no ip route-cache

keepalive 12

no fair-queue

service-module t1 timeslots 1-24

service-module t1 remote-alarm-enable

frame-relay lmi-type ansi

interface FastEthernet0

description IPS Gateway

ip address 10.x.x.x 255.x.x.x

speed auto

ip classless

ip route 0.0.0.0 0.0.0.0 4.x.x.x

What should the 1720 config look like for the it to be nothing more than a terminator for the Frame-Relay coming in, as if it were a DSL modem.

Thanks,

Josh

3 REPLIES
Bronze

Re: Basic Frame-Relay Setup

The config should not be similar to DSL, where you would be bridging the data over the ethernet. Instead, you should be able to route all IP on the 1720. Add an IP address to the sub-interface, confirm that the PVC is up and active (sh fr pvc), and you should also consider enabling fast-switching. Packets should then be able to pass from the ethernet interface to the FR network, and vice versa.

New Member

Re: Basic Frame-Relay Setup

Hi,

Thanks for your reply. However, the frame relay connection at the remote site is mapped via DLCI to a PVC in the main router. The main router already takes care of 47 DSL clients. The 1720 is to terminate a dedicated Frame Relay (point-to-point) back to the same serial interface that is "subbed out" for DSL. I would like a suggestion as to how to make the 1720 as transparent as possible in this configuration so that the firewall/VPN device behind it will not be NATed. Thanks again.

Josh

New Member

Re: Basic Frame-Relay Setup

Just need to get back to the top of the posts, at least the first page. Got pushed back 3 pages. Need help... Thanks.

256
Views
0
Helpful
3
Replies