Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

basic network configure

i am new to networking and have the following question .

It a serial interface (int s0) of cisco router in a company is used for both internet connection and Frame Relay links (says, total 2 FR links) that used for communication with its branch offices, then how to config this interface??

does it look like as follow:

(interface ethernet 0 is for LAN users that have to surf internet . Some statements for NAT are ignored)

interface ethernet 0

description to lan

ip address 192.168.0.1

interface Serial 0

no ip address

encapsulation frame-relay

interface serial 0.1

no shutdown description to internet

!

!internet ip

!

ip address a.b.c.d w.x.y.z

!total 2 Frame-relay Links

interface serial 0.2 point-to-point

no shutdown

description to branch office a

ip address 192.168.1.1 255.255.255.254

frame-relay interface-dlci 16

interface serial 0.3 point-to-point

no shutdown

description to branch office b

ip address 192.168.2.1 255.255.255.254

frame-relay interface-dlci 17

ip route 0.0.0.0 0.0.0.0 serial 0.1¡@

!end

does the above config works fine for my case ?

or any advice on it ?

many thanks

Regards.

Loko

1 REPLY
VIP Purple

Re: basic network configure

Hello Loko,

apart from the NAT configuration which is incomplete (you need to define the addresses that need to get translated, and a pool of to-be-assigned addresses, or an overload statement), you also need to put two more static routes in your config, one for each branch office, because with the default route that is in there, everything will be routed to the Internet. If you are using network 192.168.0.0 on your network, you have to include the statement ´ip subnet-zero´ in your router configuration. Also, the IP addresses on your Frame Relay subinterfaces have a 31-bit mask, this needs to be 30-bit mask. Here is what your config should look like, according to me :)

interface ethernet 0

ip nat inside

description to lan

ip address 192.168.0.1

interface Serial 0

no ip address

encapsulation frame-relay

interface serial 0.1

no shutdown description to internet

!internet ip

ip nat outside

ip address a.b.c.d w.x.y.z

!total 2 Frame-relay Links

interface serial 0.2 point-to-point

no shutdown

description to branch office a

ip address 192.168.1.1 255.255.255.252

frame-relay interface-dlci 16

interface serial 0.3 point-to-point

no shutdown

description to branch office b

ip address 192.168.2.1 255.255.255.252

frame-relay interface-dlci 17

ip subnet-zero

!

ip route 0.0.0.0 0.0.0.0 serial 0.1

ip route 192.168.1.0 0.0.0.255 interface serial 0.2

ip route 192.168.2.0 0.0.0.255 interface serial 0.3

!end

access-list 1 permit 192.168.0.0 0.0.0.255

ip nat inside source list 1 interface serial 0.1 overload

Let me know if this is not working...

Regards,

Georg

96
Views
0
Helpful
1
Replies
CreatePlease to create content