cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
545
Views
0
Helpful
5
Replies

Best method for BGP

mitchel
Level 1
Level 1

I need some advice on the best method for BGP routing. Currently I think I am receiving the full table from both my upstream providers and I think this is causing my 3640 to reboot for lack of memory. It has 128megs. I inherited a real messy config and would like to clean it up. I want to advertise two more routes also. I currently have 8 class c's that I am advertising. Is there an alternative to this? Just receive upstream providers routes?

Thanks for any help.

5 Replies 5

sirisak.c
Level 1
Level 1

You should send your routing to service provider and

service provider should block all routing to send to you.

router bgp A

no synchronization

network 172.16.10.0

neighbor 192.168.2.3 remote-as B

neighbor 192.168.2.3 ebgp-multihop 10

neighbor 192.168.2.3 update-source FastEthernet0/0

neighbor 192.168.2.3 distribute-list 40 out

neighbor 192.168.2.3 filter-list 1 in

neighbor 192.168.20.3 remote-as C

neighbor 192.168.20.3 distribute-list 40 out

neighbor 192.168.20.3 filter-list 1 in

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial2/0

ip route 0.0.0.0 0.0.0.0 Serial2/1

ip route 172.16.10.0 255.255.255.0 Null0 200

no ip http server

ip as-path access-list 1 deny .*

!

access-list 1 permit any

access-list 40 permit 172.16.10.0 0.0.0.255

access-list 40 deny any

This configuration block all routing ...

and should use the same at service provider site

mmoscoso
Level 1
Level 1

Try looking this paper, it shows how to Receive Full Internet Routing Table, Receive Directly-Connected Routes and Receive Default Routes Only from your providers.

http://www.cisco.com/warp/public/459/27.html

Mauricio

kanwaljeet
Level 1
Level 1

Hi,

you can implement ip aspath access-list using which you can restrict updates to your router from your upstream provider.All you need to do is associate a route-map for incoming advertisements with the ip-aspath access-list.

Best Regrads

kanwal

ashok_boin
Level 5
Level 5

Hi,

If you are having two different Upstream Providers, then there is an option from both service providers to send not FULL but PARTIAL routing tables to you. I suggest you to try atmost to not implement routing restricting policies at your end, because that will cause some increase in overhead of your router to see every route and comparing.

And also dependent upon Bandwidth capacities of both carriers, you can take FULL from one BIG and PARTIAL from another provider.

Regards...

--Ashok.


With best regards...
Ashok

mitchel
Level 1
Level 1

Thanks for all your suggestions. Here is a config I came up with. If anyone would care to review and let me know how it looks that would be great. Load sharing and default routes only are my goals for this config.

interface Serial0/0

description Provider A

ip address 10.10.10.10 255.255.255.252

no ip directed-broadcast

(add no ip route-cache?)

interface Serial0/1

description Povider B

no ip address

no ip directed-broadcast

encapsulation frame-relay

frame-relay lmi-type ansi

(add no ip route-cache?)

interface Serial0/1.16 point-to-point

description Povider B

ip address 20.20.20.20 255.255.255.252

no ip directed-broadcast

frame-relay interface-dlci 16 IETF

router bgp 12345

no synchronization

network 64.240.108.0

network 64.240.109.0

network 199.217.73.0

network 207.138.224.0

network 206.129.32.0

network 207.138.233.0

network 207.149.12.0

network 209.102.32.0

network 209.102.33.0

neighbor 10.10.10.20 remote-as 1234

neighbor 10.10.10.20 description Provider A

neighbor 10.10.10.20 route-map localonly out

neighbor 10.10.10.20 route-map UPDATES-1 in

neighbor 10.10.10.20 prefix-list ABC in

neighbor 20.20.20.20 remote-as 2678

neighbor 10.10.10.20 description Provider B

neighbor 10.10.10.20 route-map UPDATES-2 in

neighbor 10.10.10.20 route-map localonly out

neighbor 10.10.10.20 prefix-list ABC in

ip prefix-list ABC seq 5 permit 0.0.0.0/0

route-map UPDATES-1 permit 10

match ip address 1

set weight 100

route-map UPDATES-1 permit 20

match ip address 2

route-map UPDATES-2 permit 10

match ip address 1

route-map UPDATES-2 permit 20

match ip address 2

set weight 100

access-list 1 permit 0.0.0.0 127.255.255.255

access-list 2 deny 0.0.0.0 127.255.255.255

access-list 2 permit any

end

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: