Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

BGP 7204VXR 3550 Failure Routing to NULL0?

Hi,

We have a pair of VXR7204's connected to seperate peers. They are both linked to each other and also trunked to a pair of cat 3550's. One of the 3550 switches had a psu failure and caused hsrp to failover the internal VLAN trunked (802.1q) ip's onto the second VXR. Now here is the strange bit.

The primary VXR on our main internet pipe showed that the bgp routing table was instructing packets for the local network to be routed via VXR2 on their private link, but the ip routing table on VXR1 was routing all traffic for our network range to NULL0. It was as tho it was ignoring the bgp routes from VXR2 for some reason. Even admin shutdown on the interfaces 0/1 and 0/1.1-1.5 had no effect on this.

Sorry for the ramble but if anyone requires more info then just let me know.

Thanks,

Richard

6 REPLIES
New Member

Re: BGP 7204VXR 3550 Failure Routing to NULL0?

Are you running CEF on your VXRs? on each interface or a subset perhaps? What version of IOS code are you running? Perhaps a search in the Bug DB might yield something there. I'm also assuming that the 3500's are trunked together and passing all the appropriate VLANs. Are the VXR's connected to each other via dedicated links? Can you share some sanitized configs?

My guess is a CEF inconsistency but that's just a guess at this point. CEF is on by default in later versions of IOS but earlier version you needed to manually enable it globally and on each interface. If you enable it on one interface but not another you might end up with some inconsistencies.

Gold

Re: BGP 7204VXR 3550 Failure Routing to NULL0?

When you say the BGP routing table was directing the traffic a specific direction, do you mean the routes in the BGP table (from show ip bgp) give a specific next hop? And when you say the router is actually directing the packets to null0, are you saying the output of show ip route shows a route to null0 being the best route?

Could you post a show ip bgp x.x.x.x and a show ip route x.x.x.x to show a specific instance of what you are talking about?

:-)

Russ.W

New Member

Re: BGP 7204VXR 3550 Failure Routing to NULL0?

Hi please find attached outputs. I think the aggregate is the problem but if I remove this the router stops publishing routes out.

Hope this helps........

scocore1>sh ip route 62.128.196.1

Routing entry for 62.128.192.0/20

Known via "bgp 20860", distance 200, metric 0, type locally generated

Routing Descriptor Blocks:

* directly connected, via Null0

Route metric is 0, traffic share count is 1

AS Hops 0

scocore1>sh ip bgp 62.128.196.1

BGP routing table entry for 62.128.192.0/20, version 134444

Paths: (2 available, best #1, table Default-IP-Routing-Table)

Advertised to non peer-group peers:

62.128.192.162 195.97.229.205

Local, (aggregated by 20860 195.97.229.206)

0.0.0.0 from 0.0.0.0 (195.97.229.206)

Origin IGP, localpref 100, weight 32768, valid, aggregated, local, atomic-aggregate, best

Local, (aggregated by 20860 217.205.95.22)

62.128.192.162 from 62.128.192.162 (217.205.95.22)

Origin IGP, metric 0, localpref 100, valid, internal, atomic-aggregate

Attached bgp section

router bgp 20860

no synchronization

no bgp fast-external-fallover

bgp log-neighbor-changes

network 62.128.192.0 mask 255.255.255.128

network 62.128.192.128 mask 255.255.255.240

network 62.128.192.144 mask 255.255.255.240

network 62.128.192.160 mask 255.255.255.240

network 62.128.193.0 mask 255.255.255.0

network 62.128.194.0 mask 255.255.255.0

network 62.128.195.0 mask 255.255.255.192

network 62.128.195.64 mask 255.255.255.192

network 62.128.195.128 mask 255.255.255.128

aggregate-address 62.128.192.0 255.255.240.0 summary-only

timers bgp 2 6

neighbor 62.128.192.162 remote-as 20860

neighbor 62.128.192.162 next-hop-self

neighbor 195.97.229.205 remote-as 6067

neighbor 195.97.229.205 description Link To ONYX

neighbor 195.97.229.205 version 4

neighbor 195.97.229.205 timers 2 6

no auto-summary

Gold

Re: BGP 7204VXR 3550 Failure Routing to NULL0?

The aggregate is the only route that shows up when you do a show ip route 62.128.196.1 or a show ip bgp 62.128.196.1, so, yes, your packets are being /dev/nul'd. You need a more specific route--I see you have network statements covering more specific routes, but those routes aren't in your local routing table, it doesn't look like.

Where would you normally learn those more specific routes from? Do they normally exist, but drop out of the table when you HSRP fail over?

:-)

Russ.W

New Member

Re: BGP 7204VXR 3550 Failure Routing to NULL0?

Hi Russ,

They do exist as they are directly connect networks or static routes. Initially when I set this up I did not have the aggregate command in place and I found the the router did not publish either the static routes or the directly connected ones unless I used the commands

redistribute static

redistribute connected

The aggregate was suggested by the cisco partner who provides our support.

To answer your question about the hsrp failure. Yes they do exist while the router is in normal operation but when the internal switch failed and droped the interface everything went to null. Even although another router had taken over the routing for those subnets and was connected using a cross-over on a different interface.

If you need any other info/clarification then let me know

Thanks,

Richard

Quick net diagram

Peer1 Peer2

| |

VXR1------------VXR2

| |

3550------------3550

Output from a different HSRP subnet (the 196 range was only available on VXR2)

scocore1#sh ip route 62.128.192.1

Routing entry for 62.128.192.0/25

Known via "connected", distance 0, metric 0 (connected, via interface)

Advertised by bgp 20860

Routing Descriptor Blocks:

* directly connected, via GigabitEthernet0/1.1

Route metric is 0, traffic share count is 1

scocore1#sh ip bgp 62.128.192.1

BGP routing table entry for 62.128.192.0/25, version 252880

Paths: (1 available, best #1, table Default-IP-Routing-Table, Advertisements suppressed by an aggregate.)

Not advertised to any peer

Local

0.0.0.0 from 0.0.0.0 (195.97.229.206)

Origin IGP, metric 0, localpref 100, weight 32768, valid, sourced, local, best

scocore1#

Gold

Re: BGP 7204VXR 3550 Failure Routing to NULL0?

That makes sense, then.... If BGP still peering with the other router when the interfaces are down? I would guess not.... If it is, then you probably aren't seeing the routes from the iBGP peer correctly, and you might want to try turning off synchronization, to see if that helps. Normally, you'd solve this problem by making certain the two border routers are running iBGP with each other over some link that doesn't fail all that often, or isn't involved in HSRP/etc. If they are in the same room, then just putting a serial or ethernet link between them....

If it doesn't, then you need to get this router to stop advertising the aggregate when the interfaces are down. You propably have some other route in the routing table that's making the router advertise the aggregate (?) even when the interfaces in question are down. The aggregate is normally a good thing, but you might not want to run it in this case, and let your upstream aggregate for you, since it's causing you problems.

:-)

Russ.W

128
Views
0
Helpful
6
Replies
CreatePlease to create content