Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BGP Advertise Route

I am having some difficulty with a bgp config. I am trying to advertise my Class-C network address to my bgp peers. I have tried the following config:

ip prefix-list bwout seq 5 permit 10.10.10.0/24

with

neighbor 11.11.11.11 prefix-list bwout out

inserted in the router bgp ASN config

Then I tried using route maps:

ip as-path access-list 10 permit ^$

route-map localonly permit 10

match as-path 10

neighbor 11.11.11.11 route-map localonly out

The problem is that when I type "sh ip bgp neigh 11.11.11.11 advertise-routes" I get nothing. The ISP has confirmed that they are not receiving any routes from me, which is obvious, since I'm not advertising any.

I am testing this config with one ISP so far - the same ISP from whom I received the 10.10.10.0/24 network address. I will expand it to include a second ISP once I have it working.

Any assistance or guidance would be greatly appreciated.

Regards,

Dan

12 REPLIES
Gold

Re: BGP Advertise Route

Either one of those configurations should work fine, I would think, as long as you also have a network statement and a route in the local routing table (?). Can you do a show ip bgp 10.10.10.0/24, and see if it's in your local table?

What you should also have is:

network 10.10.10.0 mask 255.255.255.0

in your config, and a show ip route should show the 10.10.10.0/24 as a reachable network.

Now, there's another piece to this. I assume the address space you've been given is real ip address space, and not really 10.10.10.0/24. If it's really 10.10.10.0/24, I doubt the second isp will accept it, since this is RFC1918 unroutable ip address space.

:-)

Russ.W

New Member

Re: BGP Advertise Route

Thanks for your response, Russ. The IP address I'm trying to advertise is really a public Class-A address space that the ISP has subnetted to a Class-C. The actual address is not really 10.10.10.0.

Anyway, when I do show ip bgp 10.10.10.0/24, a get a message stating that the network is not in the table. Below is a summary of my bgp config:

router bgp 1234

no synchronization

bgp log-neighbor-changes

network 10.10.10.0

timers bgp 30 90

neighbor 12.12.12.12 remote-as 7018

neighbor 12.12.12.12 description ATT Peering

neighbor 12.12.12.12 route-map ATT_only in

neighbor 12.12.12.12 route-map localonly out

neighbor 13.13.13.13 remote-as 19262

neighbor 13.13.13.13 Description Verizon Peering

neighbor 13.13.13.13 route-map Verizon_only in

neighbor 13.13.13.13 route-map localonly out

no auto-summary

I seem to receiving the customer routes from ATT, but they are not receiving my route advertisement.

The show ip route command lists my network as directly connected, Looback0. I removed the address from the loopback interface and set in on one of the fast ethernet interfaces, but that didn't seem to change the situation.

Any suggestions would be greatly appreciated.

Regards,

Dan

Cisco Employee

Re: BGP Advertise Route

Dan,

Before the route is injected in BGP, the network statement has to match a route in the RIB. If you don't specify a mask on the network statement the natural network mask is used (8, 16 or 24). You might want to check if your network statement matches a route in the RIB.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: BGP Advertise Route

I sincerely appreciate your input.

I added the mask (255.255.255.0) to the network statement in my bgp config, but the route still doesn't appear in the routing table . . .

I am working on this router remotely. Since it is not currently not in use on a network (only the serial interface is connected), the Ethernet interface that is on the network I am trying to advertise is up-down (interface up, line protocol down). I assume the route will not be placed in the bgp routing table until the interface is up-up?

Dan

Cisco Employee

Re: BGP Advertise Route

You are correct. As soon as this interface becomes up/up the subnet should be installed in the RIB as a connected route and it will then be injected in BGP.

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Gold

Re: BGP Advertise Route

You could try making the static route point to the null0 interface, to see if it's advertised then, and then moving the route over to the ethernet when you go into production. You stated earlier that you had the route on a loopback--if the loopback is up/up, this should have the same effect.

:-)

Russ.W

Cisco Employee

Re: BGP Advertise Route

Since the subnet he wants to advertise is attached to the Ethetnet interface, he could also just configure "no keepalive" under the interface so it can come up/up and the route can be installed in the RIB. That would be an easy way to test your BGP setup.

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: BGP Advertise Route

Thank you, hritter.

Gold

Re: BGP Advertise Route

Could you post a show ip bgp 10.10.10.0? I know you'll have to edit the output to take out the real address, but we need to know if it's in the local table before we can work on the policy configurations....

:-)

Russ.W

New Member

Re: BGP Advertise Route

Thanks again for your assistance. Bringing up the interface made all the difference.

When the address was attached to the loopback, and the loopback was up/up, the route was still not being advertised. Once I unapplied it from the loopback and applied it to the Fast-E interface it showed up in the routing table.

Regards,

Dan

Cisco Employee

Re: BGP Advertise Route

How do you originate 10.10.10.0/24 in BGP. I do not see any network or redistribute statement in your configuration.

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: BGP Advertise Route

I attached my bgp configuration in the prior response. In there I list the network, 10.10.10.0.

278
Views
5
Helpful
12
Replies