Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

BGP neighbors

Is it possible connect 2 non-directly-connected BGP routers ( from different AS) in order to exchange BGP routing information?

I tryed next scenario-

router A

!

router bgp 1

no synchronization

network 192.168.19.0

neighbor A.B.C.2 remote-as 2

neighbor A.B.C.2 ebgp-multihop 255

!

router B

!

router bgp 2

no synchronization

network A.B.C.225 mask 255.255.255.224

neighbor B.C.D.1 remote-as 1

neighbor B.C.D.1 ebgp-multihop 255

!

At each router in debug log i see next-

BGP: scanning routing tables

BGP: B.C.D.1 multihop open delayed 15024ms (no route)

BGP: B.C.D.1 multihop open delayed 14816ms (no route)

BGP: B.C.D.1 multihop open delayed 10800ms (no route)

BGP: B.C.D.1 multihop open delayed 16816ms (no route)

BGP: scanning routing tables

#sh ip bgp sum

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

A.B.C.2 4 2 0 0 0 0 0 never Active

10 REPLIES
Bronze

Re: BGP neighbors

Hi

You debug already says the problem, there is no route. So what yo need to

do is route the addresses which you are using for the peer either statically or

with some routing protocol.

Be aware that a "flapping" situation could be created.

Regards

Roger

Community Member

Re: BGP neighbors

But why they don't have route - i can ping both routers from each other?

Bronze

Re: BGP neighbors

Hi

When you do the ping are you using the right source ip?

Do you use Loopback Interfaces for the peering?

So you should be able to ping from from the peer source to the peer . If you

have the ip connectivity the bgp peer should be established. But now you can

run into a flapping situation....is that maybe the situation you got?

Regards

Roger

Community Member

Re: BGP neighbors

i'm a little misunderstood!

Here my scenario

Routers R1 and R2 connected to ISP.

---------------R1-----------------

s0-a.b.c.2

l0-172.22.1.1

-----

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S* 0.0.0.0/0 is directly connected, Serial0

ip route b.c.d.0 255.255.255.0 a.b.c.1

-------

!

router bgp 2

no synchronization

network 172.22.0.0

neighbor b.c.d.1 remote-as 1

neighbor b.c.d.1 ebgp-multihop 255

neighbor b.c.d.1 update-source Loopback0

!

-------

FROM DEBUG-

TCP0: Connection to b.c.d.1:179, advertising MSS 536

TCP0: state was CLOSED -> SYNSENT [11008 -> b.c.d.1(179)]

TCP: sending RST, seq 0, ack 3894683580

TCP0: timeout #3 - timeout is 16000 ms, seq 2416127265

TCP: (11008) -> b.c.d.1(179)

BGP: scanning routing tables

BGP: nettable_walker 172.22.0.0/255.255.0.0 route sourced locally

TCP: sending RST, seq 0, ack 3894683580

TCP0: timeout #4 - timeout is 32000 ms, seq 2416127265

TCP: (11008) -> b.c.d.1(179)

TCP0: state was SYNSENT -> CLOSED [11008 -> b.c.d.1(179)]

TCB00145F94 destroyed

BGP: b.c.d.1 open failed: Connection timed out; remote host not responding

BGP: scanning routing tables

-------------R2-------------------

s0/0.1-b.c.d.1 ( !!!!!!! a.b.c.(from R1) not equal b.c.d.(from R2) !!!!!)

l0-192.168.19.1

--------

!

router bgp 1

no synchronization

bgp log-neighbor-changes

network 192.168.19.0

neighbor a.b.c.2 remote-as 2

neighbor a.b.c.2 ebgp-multihop 255

neighbor a.b.c.2 update-source Loopback1

!

------------

Gateway of last resort is b.c.d.21 to network 0.0.0.0

ip route a.b.c.0 255.255.255.0 b.c.d.21

------------------------------------------

------------------------------------------

Where i was wrong?

Bronze

Re: BGP neighbors

Hi

What you need to do is also to route the Loopback Interfaces from R1 and R2.

On R1:

ip route 192.168.19.1 255.255.255.255 a.b.c.1

On R2:

ip route 172.22.1.1 255.255.255.255 b.c.d.21

Regards

Roger

Community Member

Re: BGP neighbors

why i must add private address with link to my ISP -they don't know what to do with that address?

traceroute 192.168.19.1

Type escape sequence to abort.

Tracing the route to 192.168.19.1

1 a.b.c.1 20 msec 12 msec 20 msec

2 fe0-0-bcg1.gdn.net 128 msec 12 msec 16 msec

3 * * *

4 * * *

5 * * *

6 * * *

7 * * *

8 * * *

Bronze

Re: BGP neighbors

Hi

Becaus in the sample config you posted you also have the command update source loopback 0 in place.

With this command you define which bgp source to use...in your case the

Loopbacks.

The update source should be the same address as you peer on the other router.

So either remove it or take the loopbacks into you routing.

Regards

Roger

Community Member

Re: BGP neighbors

Well, thank you for your help - i found my mistake-i used at R1 wrong ip-address of neighboor.

I'm appologize!

i also removed

update-source l0.

R1

#sh ip bgp sum

BGP table version is 5, main routing table version 5

4 network entries (4/12 paths) using 816 bytes of memory

3 BGP path attribute entries using 344 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

b.c.d.22 4 1 15 9 5 0 0 00:01:13 3

#sh ip route bgp

B 192.168.19.0/24 [20/0] via b.c.d.22, 00:00:46

R2

# sh ip bgp sum

BGP router identifier 192.168.19.1, local AS number 1

BGP table version is 5, main routing table version 5

4 network entries using 388 bytes of memory

4 path entries using 144 bytes of memory

4 BGP path attribute entries using 240 bytes of memory

2 BGP AS-PATH entries using 48 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 820 total bytes of memory

BGP activity 34/30 prefixes, 37/33 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

a.b.c.2 4 2 9 15 5 0 0 00:01:03 1

2610#sh ip route bgp

B 172.22.0.0/16 [20/0] via a.b.c.2, 00:00:55

But i still can't ping 172.22.1.1 or 192.168.19.1

Bronze

Re: BGP neighbors

Hi

I am glad that i could help you.

Regards

Roger

Silver

Re: BGP neighbors

When you ping are you sourcing your ping from the Ip address in your neigbor statement , If not try it if it fails then you need to do a sh ip route to the neighbor and use the update-source command in your neighbor statement .

neighbor x.x.x.x update-source interface x ( the interface x is the interface that you ping is successful from)

282
Views
0
Helpful
10
Replies
CreatePlease to create content