cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
343
Views
0
Helpful
3
Replies

BGP problem

rmv72
Level 1
Level 1

i've 2 routers:

----------------------------A------------------------

!

interface Ethernet0

ip address A.B.C.202 255.255.255.248

!

interface Serial0

description INTERNET

bandwidth 64

no ip address

encapsulation frame-relay

frame-relay lmi-type cisco

!

interface Serial0.1 point-to-point

bandwidth 64

ip address 192.168.1.77 255.255.255.252

frame-relay interface-dlci xxx

!

......

!

router bgp 1

bgp log-neighbor-changes

network A.B.C.200 mask 255.255.255.248

neighbor B.C.D.22 remote-as 2

neighbor B.C.D.22 ebgp-multihop 255

neighbor B.C.D.22 update-source Ethernet0

!

#sh ip bgp sum

BGP router identifier A.B.C.202, local AS number 1

BGP table version is 2, main routing table version 2

1 network entries and 1 paths using 133 bytes of memory

1 BGP path attribute entries using 60 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP activity 2/9 prefixes, 2/1 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

B.C.D..22 4 2 0 0 0 0 0 never Active

--------------------------B-----------------------

!

interface Serial0/0.1 multipoint

ip address B.C.D.22 255.255.255.252

frame-relay map ip B.C.D.21 xxx CISCO

!

!

interface Ethernet0/0

ip address X.Y.Z.1 255.255.255.0

.....

!

router bgp 2

bgp log-neighbor-changes

network X.Y.Z.0

neighbor A.B.C.202 remote-as 1

neighbor A.B.C.202 ebgp-multihop 255

neighbor A.B.C.202 update-source Ethernet0/0

!

It's from debug-

Jul 14 18:19:10: BGP: reset all neighbors due to User reset

Jul 14 18:19:10: BGP:A.B.C.202 went from Active to Idle

Jul 14 18:19:20: BGP: Import timer expired. Walking from 1 to 1

Jul 14 18:19:30: BGP: A.B.C.202 went from Idle to Active

Jul 14 18:19:30: BGP: A.B.C.202 open active, delay 16575ms

Jul 14 18:19:35: BGP: Performing BGP general scanning

Jul 14 18:19:35: BGP(0): scanning IPv4 Unicast routing tables

Jul 14 18:19:35: BGP: Applying map to find origin for X.Y.Z.0/24

Jul 14 18:19:35: BGP(1): scanning VPNv4 Unicast routing tables

Jul 14 18:19:35: BGP(2): scanning IPv4 Multicast routing tables

Jul 14 18:19:46: BGP: A.B.C.202 open active, local address X.Y.Z.1

Jul 14 18:19:47: BGP: A.B.C.202 open failed: Connection refused by remote host

Where i'm wrong?

3 Replies 3

deilert
Level 6
Level 6

DO you have an ACL applied to any of these interfaces ?

On rtrb you said update source E0/0. rtra should use that address for the neighbor statements like you did on rtrb.

Thank's all-i found my mistake - i added next at router A-

ip route B.C.D.0 255.255.255.0 serial 0.1 permanent