Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BGP question

i've 3 routers: 2610,1603,1601.

Why i don't have at 2610 and 1603 (#sh ip route bgp) bgp records about network 138.108.0.0 from 1601?

-----2610--------------

!

router bgp 1

bgp log-neighbor-changes

network 192.168.19.0

neighbor 192.168.100.2 remote-as 3

neighbor A.B.C.111 remote-as 1

!

2610#sh ip int brief

Interface IP-Address OK? Method Status Protocol

Ethernet0/0 A.B.C.1 YES NVRAM up up

Serial0/0 unassigned YES NVRAM up up

Serial0/0.1 A.B.C.22 YES NVRAM up up

Serial0/0.2 192.168.100.1 YES NVRAM up up

Loopback0 192.168.18.1 YES manual up up

Loopback1 192.168.19.1 YES manual up up

2610#sh ip bgp

BGP table version is 9, local router ID is 192.168.18.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*> 192.168.19.0 0.0.0.0 0 32768 i

*>i192.168.20.0 A.B.C.111 0 100 0 i

2610#sh ip route bgp

--EMPTY

2610#sh ip bgp sum

BGP router identifier 192.168.18.1, local AS number 1

BGP table version is 9, main routing table version 9

2 network entries using 194 bytes of memory

2 path entries using 72 bytes of memory

2 BGP path attribute entries using 120 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 386 total bytes of memory

BGP activity 5/3 prefixes, 6/4 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

192.168.100.2 4 3 66 68 9 0 0 00:59:48 0

A.B.C.111 4 1 119 122 9 0 0 01:53:33 1

2610#

-------------------------1603-------------------------------

!

router bgp 1

network 192.168.20.0

neighbor A.B.C.1 remote-as 1

!

c1603#sh ip bgp

BGP table version is 6, local router ID is 192.168.16.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

* i192.168.19.0 A.B.C..1 0 100 0 i

*> 192.168.20.0 0.0.0.0 0 32768 i

c1603#sh ip route bgp

c1603#

c1603#sh ip bgp sum

BGP router identifier 192.168.16.1, local AS number 1

BGP table version is 6, main routing table version 6

2 network entries and 2 paths using 242 bytes of memory

2 BGP path attribute entries using 184 bytes of memory

BGP activity 5/3 prefixes, 5/3 paths

0 prefixes revised.

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

A.B.C.1 4 1 123 120 6 0 0 01:55:18 1

c1603#sh ip int brief

Interface IP-Address OK? Method Status Protocol

Ethernet0 A.B.C.111 YES NVRAM up up

Loopback0 192.168.20.1 YES manual up up

Loopback3 192.168.16.1 YES manual up up

c1603#

----------------------------------1601------------------------------

!

router bgp 3

bgp log-neighbor-changes

network 138.108.0.0

neighbor 192.168.100.1 remote-as 1

!

Cisco1601#sh ip bgp

BGP table version is 7, local router ID is 131.108.15.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*> 192.168.19.0 192.168.100.1 0 0 1 i

*> 192.168.20.0 192.168.100.1 0 1 i

Cisco1601#sh ip bgp sum

BGP router identifier 131.108.15.1, local AS number 3

BGP table version is 7, main routing table version 7

2 network entries and 2 paths using 266 bytes of memory

2 BGP path attribute entries using 120 bytes of memory

1 BGP AS-PATH entries using 24 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP activity 4/45 prefixes, 5/3 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

192.168.100.1 4 1 72 70 7 0 0 01:04:07 2

Cisco1601#sh ip route bgp

B 192.168.20.0/24 [20/0] via 192.168.100.1, 01:04:16

B 192.168.19.0/24 [20/0] via 192.168.100.1, 01:04:17

Cisco1601#sh ip int brief

Interface IP-Address OK? Method Status Protocol

Ethernet0 A.B.C..202 YES NVRAM up up

Serial1.1 192.168.100.2 YES NVRAM up up

Cisco1601#

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: BGP question

use this config

1603

router bgp 1

no synchronization

network 192.168.20.0

neighbor a.b.c.1 remote-as 1

neighbor a.b.c.1 next-hop-self

2610

router bgp 1

no synchronization

network 192.168.19.0

neighbor a.b.c.111 remote-as 1

neighbor a.b.c.111 next-hop-self

neighbor 192.168.100.2 remote-as 3

neighbor 192.168.100.2 update-source Loopback1

neighbor 192.168.100.2 next-hop-self

1601

router bgp 3

network 131.108.9.0 mask 255.255.255.0

network 131.108.10.1 mask 255.255.255.255

neighbor 192.168.100.1 remote-as 1

neighbor 192.168.100.1 next-hop-self

10 REPLIES
Silver

Re: BGP question

You do not even have this netwok 138.108.0.0 on the 1601 . does the 1601 have this network configured ?

New Member

Re: BGP question

Oh,sorry! Yes,i wrote wrong info - i have that network configured - here right output

Cisco1601#sh ip int brief

Interface IP-Address OK? Method Status Protocol

Ethernet0 A.B.C..202 YES NVRAM up up

Loopback0 131.108.2.1 YES manual up up

Loopback1 131.108.3.1 YES manual up up

Loopback2 131.108.4.1 YES manual up up

Loopback3 131.108.5.1 YES manual up up

Loopback4 131.108.6.1 YES manual up up

Loopback5 131.108.7.1 YES manual up up

Loopback6 131.108.8.1 YES manual up up

Loopback7 131.108.9.1 YES manual up up

Loopback8 131.108.10.1 YES manual up up

Loopback9 131.108.11.1 YES manual up up

Loopback10 131.108.12.1 YES manual up up

Loopback11 131.108.13.1 YES manual up up

Loopback12 131.108.14.1 YES manual up up

Loopback13 131.108.15.1 YES manual up up

Serial0 unassigned YES NVRAM up up

Serial0.1 192.168.1.77 YES NVRAM up up

Serial1 unassigned YES NVRAM up up

Serial1.1 192.168.100.2 YES NVRAM up up

Cisco1601#

Silver

Re: BGP question

You actually do not have this network configured on theis router , you have 131.108.2-15.1 255.255.255.255 try this

router bgp 3

bgp log-neighbor-changes

network 138.108.2.1 255.255.255.255

network 138.108.3.1 255.255.255.255

.....

.....

network 138.108.15.1 255.255.255.255

Since these are loopbacks you want to be specific using a /32 you do not want to advertise networks that you can't route to .

New Member

Re: BGP question

After added next

#network 131.108.9.0 mask 255.255.255.0

#network 131.108.10.1 mask 255.255.255.255

i can see next-

-----------------------------------

2610#sh ip bgp

BGP table version is 10, local router ID is 192.168.18.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*> 131.108.9.0/24 192.168.100.2 0 0 3 i

*> 192.168.19.0 0.0.0.0 0 32768 i

*>i192.168.20.0 A.B.C.111 0 100 0 i

2610#sh ip route bgp

131.108.0.0/24 is subnetted, 1 subnets

B 131.108.9.0 [20/0] via 192.168.100.2, 00:09:55

2610#

-------------------

c1603#sh ip bgp

BGP table version is 6, local router ID is 192.168.16.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

* i131.108.9.0/24 192.168.100.2 0 100 0 3 i

* i192.168.19.0 A.B.C.1 0 100 0 i

*> 192.168.20.0 0.0.0.0 0 32768 i

c1603#sh ip route bgp

c1603#

---------------------

But is't right that i still can't see route 131.108.9.0/24 (c1603#sh ip route bgp ) from 1601 at the c1603?

Silver

Re: BGP question

On the 1603 the next hop 192.168.100.2 is not reachable , you must have a valid route in your routing table for BGP to insert the route in the routing table,

Can you ping this address from the 1603 ? If you can not add this to your BGP config on all your routers

neighbor x.x.x.x next hop-self

New Member

Re: BGP question

No, i can't ping 192.168.100.2

i made next:

-----1603--------------

!

router bgp 1

neighbor A.B.C.1 remote-as 1

neighbor A.B.C.1 next-hop-self!

-----2610--------------

!

router bgp 1

bgp log-neighbor-changes

network 192.168.19.0

neighbor 192.168.100.2 remote-as 3

neighbor 192.168.100.2 next-hop-self

neighbor A.B.C.111 remote-as 1

neighbor A.B.C.111 next-hop-self

!

-------------1601------------------------

!

router bgp 3

bgp log-neighbor-changes

network 131.108.9.0 mask 255.255.255.0

network 131.108.10.1 mask 255.255.255.255

neighbor 192.168.100.1 remote-as 1

neighbor 192.168.100.1 next-hop-self

!

------------

Is't right?

But

c1603#sh ip route bgp

c1603#

still empty.

Silver

Re: BGP question

did you clear the peers ?

New Member

Re: BGP question

No, but after #clear ip bgp *

i have next-

-----------------------1601---------------------

Cisco1601#sh ip bgp

BGP table version is 4, local router ID is 131.108.15.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*> 131.108.9.0/24 0.0.0.0 0 32768 i

*> 192.168.19.0 192.168.100.1 0 0 1 i

*> 192.168.20.0 192.168.100.1 0 1 i

Cisco1601#sh ip bgp sum

BGP router identifier 131.108.15.1, local AS number 3

BGP table version is 4, main routing table version 4

3 network entries and 3 paths using 399 bytes of memory

3 BGP path attribute entries using 180 bytes of memory

1 BGP AS-PATH entries using 24 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP activity 10/179 prefixes, 11/8 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

192.168.100.1 4 1 1299 1303 4 0 0 00:08:09 2

Cisco1601#sh ip route bgp

B 192.168.20.0/24 [20/0] via 192.168.100.1, 00:06:21

B 192.168.19.0/24 [20/0] via 192.168.100.1, 00:06:21

Cisco1601#

------------------2610---------------

2610#sh ip bgp

BGP table version is 4, local router ID is 192.168.19.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*> 131.108.9.0/24 192.168.100.2 0 0 3 i

*> 192.168.19.0 0.0.0.0 0 32768 i

*>i192.168.20.0 A.B.C.111 0 100 0 i

2610#sh ip bgp sum

BGP router identifier 192.168.19.1, local AS number 1

BGP table version is 4, main routing table version 4

3 network entries using 291 bytes of memory

3 path entries using 108 bytes of memory

3 BGP path attribute entries using 180 bytes of memory

1 BGP AS-PATH entries using 24 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 603 total bytes of memory

BGP activity 11/8 prefixes, 13/10 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

192.168.100.2 4 3 1304 1304 4 0 0 00:09:27 1

A.B.C.111 4 1 1388 1391 4 0 0 00:09:24 1

2610#sh ip route bgp

131.108.0.0/24 is subnetted, 1 subnets

B 131.108.9.0 [20/0] via 192.168.100.2, 00:07:34

2610#

---------------1603-----------------------

c1603#sh ip bgp

BGP table version is 2, local router ID is 192.168.20.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

* i131.108.9.0/24 A.B.C.1 0 100 0 3 i

* i192.168.19.0 A.B.C.1 0 100 0 i

*> 192.168.20.0 0.0.0.0 0 32768 i

c1603#sh ip bgp sum

BGP router identifier 192.168.20.1, local AS number 1

BGP table version is 2, main routing table version 2

3 network entries and 3 paths using 363 bytes of memory

3 BGP path attribute entries using 280 bytes of memory

BGP activity 10/7 prefixes, 10/7 paths

0 prefixes revised.

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

A.B.C.1 4 1 1392 1389 2 0 0 00:10:39 2

c1603#sh ip route bgp

c1603#

I can ping from c1603 addreess 131.108.9.1.

Where i've made mistake?May be i'll send you my full configs?

Silver

Re: BGP question

use this config

1603

router bgp 1

no synchronization

network 192.168.20.0

neighbor a.b.c.1 remote-as 1

neighbor a.b.c.1 next-hop-self

2610

router bgp 1

no synchronization

network 192.168.19.0

neighbor a.b.c.111 remote-as 1

neighbor a.b.c.111 next-hop-self

neighbor 192.168.100.2 remote-as 3

neighbor 192.168.100.2 update-source Loopback1

neighbor 192.168.100.2 next-hop-self

1601

router bgp 3

network 131.108.9.0 mask 255.255.255.0

network 131.108.10.1 mask 255.255.255.255

neighbor 192.168.100.1 remote-as 1

neighbor 192.168.100.1 next-hop-self

New Member

Re: BGP question

YES!

c1603#sh ip route bgp

131.108.0.0/24 is subnetted, 1 subnets

B 131.108.9.0 [200/0] via 192.168.100.2, 00:00:24

B 192.168.19.0/24 [200/0] via A.B.C.1, 00:00:29

c1603#

----------

Thank's a lot!

Is't because :

---------------------

"You only have to use the update-source command when someone is peering to your loopback address. This is true for an iBGP peer and an eBGP peer."

---------------------

and

---------------------

"Disabling Synchronization

In some cases you do not need synchronization. If you will not be passing traffic from a different autonomous system through your AS, or if all routers in your AS will be running BGP, you can disable synchronization. Disabling this feature can allow you to carry fewer routes in your IGP and allow BGP to converge more quickly.

Disabling synchronization is not automatic, if you have all your routers in the AS running BGP and you are not running any IGP, the router has no way of knowing that, and your router will be waiting forever for an IGP update about a certain route before sending it to external peers. You have to disable synchronization manually in this case for routing to work correctly:

router bgp 100

no synchronization" ?

--------------------------------

134
Views
5
Helpful
10
Replies
CreatePlease login to create content