Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BGP Question

Hi,

I got help from my ISP's to setup BGP routing into my 2620XM router. Here is the config file:

version 12.2

> service timestamps debug uptime

> service timestamps log uptime

> no service password-encryption

> !

> hostname Whitmont_Router

> !

> !

> ip subnet-zero

> !

> !

> ip name-server 63.140.240.35

> ip name-server 63.140.240.36

> !

> ip prefix-list WINSTARANNOUNCE seq 5 permit 67.155.67.0/24

> ip prefix-list WINSTARANNOUNCE seq 10 permit 216.172.116.0/24

> !

> !

> interface FastEthernet0/0

> ip address 216.172.116.1 255.255.255.248 secondary

> ip address 67.155.67.1 255.255.255.0 secondary

> ip address 67.94.197.89 255.255.255.248

> speed auto

> half-duplex

> !

> interface Serial0/0

> ip address 67.94.197.78 255.255.255.252

> encapsulation ppp

> no ip mroute-cache

> no fair-queue

> service-module t1 timeslots 1-24

> !

> interface Serial0/1 (WINSTAR)

> ip address 63.140.19.62 255.255.255.252

> encapsulation ppp

> no ip mroute-cache

> no fair-queue

> service-module t1 timeslots 1-24

> !

> router bgp 31755

> no synchronization

> bgp router-id 67.94.197.78

> bgp cluster-id 3221752065

> bgp log-neighbor-changes

> network 67.94.197.88 mask 255.255.255.248

> network 67.155.67.0 mask 255.255.255.0

> neighbor 67.94.197.77 remote-as 2548

> neighbor 67.94.197.77 version 4

> neighbor 67.94.197.77 next-hop-self

> neighbor 67.94.197.77 soft-reconfiguration inbound

> neighbor 67.94.197.77 prefix-list egrress-filter out

> neighbor 63.140.19.61 remote-asn 5696

> neighbor 63.140.19.61 soft-reconfiguration inbound

> neighbor 63.140.19.61 prefix-list WINSTARANNOUNCE out

> no auto-summary

> !

> ip classless

> ip http server

> ip pim bidir-enable

> !

> !

> !

> line con 0

> line aux 0

> line vty 0 4

2 questions.. one how to i remove one of the secondary IP addresses.. the 216 in FastEthernet0/0 isn't needed anymore.

second question is what do I do with my firewall when it comes to routing to this network.. If I unplug one T1 line, the other takes over on the router, but not within our network. i belive it is something to do with my firewall, but i'm not sure. Is there a particular route I should have in the firewall?

ip address 67.94.197.89 should route to either T1 line right?

Please help!

Thanks..

Paul

3 REPLIES

Re: BGP Question

no ip address 216.172.116.1 255.255.255.248 secondary

Yes. If you tell your firewall to send traffic to 67.94.197.89 (the ethernet interface) then the router should then know what to do. It should send it out the t1 (either t1 if bgp is proper and working).

New Member

Re: BGP Question

Hey.. thanks! that worked great.. here is another question though.. It seems that all my traffic is going through one T1 provider.. how do i spread it out, or control where it goes?

Bronze

Re: BGP Question

I'd suggest searching for "BGP load balancing" here and on Google. You'll find a lot of information as this issue comes up regularly.

98
Views
0
Helpful
3
Replies