Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BGP route-appear and disappear

Hello!I've next problem - after 1 min BGP route disaooeared from route table.Why it's so?

2610#sh ip route bgp

A.B.C.0/29 is subnetted, 1 subnets

B A.B.C.200 [20/0] via A.B.C.202, 00:00:59

2610#sh ip route bgp

2610#

------------------------

Jul 15 14:51:08: BGP: Performing BGP general scanning

Jul 15 14:51:08: BGP(0): scanning IPv4 Unicast routing tables

Jul 15 14:51:08: BGP: Applying map to find origin for B.C.D.0/24

Jul 15 14:51:08: BGP(IPv4 Unicast): Performing BGP Nexthop scanning for general scan

Jul 15 14:51:08: BGP(1): scanning VPNv4 Unicast routing tables

Jul 15 14:51:08: BGP(VPNv4 Unicast): Performing BGP Nexthop scanning for general scan

Jul 15 14:51:08: BGP(2): scanning IPv4 Multicast routing tables

Jul 15 14:51:09: BGP(IPv4 Multicast): Performing BGP Nexthop scanning for general scan

Jul 15 14:51:09: BGP(0): Revise route installing A.B.C.200/29 -> A.B.C.202 to main IP table

Jul 15 14:51:09: BGP(0): A.B.C.202 computing updates, afi 0, neighbor version 22, table version 23, starting at 0.0.0.0

Jul 15 14:51:09: BGP(0): A.B.C.202 update run completed, afi 0, ran for 0ms, neighbor version 22, start version 23, throttled to 23

--------------------------

2610#sh ip bgp sum

BGP router identifier X.Y.Z.22, local AS number 2

BGP table version is 23, main routing table version 23

2 network entries using 194 bytes of memory

2 path entries using 72 bytes of memory

2 BGP path attribute entries using 120 bytes of memory

1 BGP AS-PATH entries using 24 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 410 total bytes of memory

BGP activity 40/38 prefixes, 40/38 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

A.B.C.202 4 1 214 222 23 0 0 00:16:17 1

2610#

------------------

2610#sh ip route

Gateway of last resort is X.Y.Z.21 to network 0.0.0.0

X.Y.Z.0/30 is subnetted, 1 subnets

C X.Y.Z.20 is directly connected, Serial0/0.1

C B.C.D.0/24 is directly connected, Ethernet0/0

S 192.168.10.0/24 is directly connected, Serial0/0.2

S 172.20.0.0/16 [1/0] via 192.168.11.2

C 192.168.11.0/24 is directly connected, Ethernet0/0

10.0.0.0/21 is subnetted, 1 subnets

S 10.10.0.0 is directly connected, Serial0/0.2

C 192.168.100.0/24 is directly connected, Serial0/0.2

S* 0.0.0.0/0 [1/0] via X.Y.Z.21

-------------

!

router bgp 2

bgp log-neighbor-changes

network B.C.D.0

neighbor A.B.C.202 remote-as 1

neighbor A.B.C.202 ebgp-multihop 255

neighbor A.D.C.202 update-source Ethernet0/0

!

-------------

7 REPLIES
Gold

Re: BGP route-appear and disappear

It sounds like the next hop for the route is reachable through the route itself. The BGP scanner checks the next hop for each route in the routing table every 60 seconds, and if the next hop is reachable through the route itself, or the nexthop resolves through the route itself, it removes the route.

For instance, if you have 10.1.1.0/24 reachable via 10.2.2.2, and 10.2.2.0/24 is reachable via 10.1.1.1, the scanner would catch this and remove both routes from the routing table. From the output you've provided above, it's hard for me to tell if this is the case, but it does look possible. Of course, some forms of recursion the scanner catches are a little bot subtle than this, and you have to look harder to see them. :-)

Russ.W

New Member

Re: BGP route-appear and disappear

i can't find my mistake

It's my configs-

--------------2610--------

!

interface Ethernet0/0

ip address B.C.D.1 255.255.255.0

!

interface Serial0/0.1 multipoint

description Internet access

ip address X.Y.Z.22 255.255.255.252

frame-relay map ip X.Y.Z.21 100 CISCO

!

---------------1601----------------

!

interface Serial0.1

ip address 192.168.1.77 255.255.255.0

!

interface Ethernet0

ip address A.B.C.202 255.255.255.248

!

router bgp 1

network A.B.C.200 mask 255.255.255.248

neighbor X.Y.Z.22 remote-as 2

neighbor X.Y.Z.22 update-source Ethernet0

neighbor X.Y.Z.22 ebgp-multihop

!

ip route X.Y.Z.22 255.255.255.255 serial0.1 permanent

!

At router 1601 i don't have BGP flapping! Only at router 2610.

Silver

Re: BGP route-appear and disappear

try to change your static to

ip route X.Y.Z.22 255.255.255.255 X.Y.Z.21 permanent

From the 2610 can you ping A.D.C.202 sourcing it from e0/0 ?

from the 1601 can you ping X.Y.Z.22 sourcing from e0 ?

also on the 1601 in your ebgp multihop command you did not specify the number of hops .

Gold

Re: BGP route-appear and disappear

This is what you see on the 2610, right? From your earlier post?

2610#sh ip route bgp

A.B.C.0/29 is subnetted, 1 subnets

B A.B.C.200 [20/0] via A.B.C.202, 00:00:59

2610#sh ip route bgp

It appears that the only way you know about the A.B.C.200 address is through A.B.C.202, which you only know about because of a BGP route to A.B.C.0/29, correct? There's the recursion....

On the 2610, try configuring:

ip route A.B.C.202 255.255.255.255 serial0.1 permanent

to see if that fixes the flapping problem, since that would, I think, based on what I have so far, break the recursion. I'm not positive, though, since I've not seen the BGP configuration or static routes on the 2610 yet.

Russ.W

New Member

Re: BGP route-appear and disappear

Yes,it's from 2610.

After add

2610(config)#ip route A.B.C.202 255.255.255.255 serial 0/0.1 permanent

i've next-

Jul 16 10:55:45: BGP: Import timer expired. Walking from 1 to 1

Jul 16 10:55:48: BGP: reset all neighbors due to User reset

Jul 16 10:55:48: BGP: A.B.C.202 went from Active to Idle

Jul 16 10:56:00: BGP: Import timer expired. Walking from 1 to 1

Jul 16 10:56:08: BGP: A.B.C.202 went from Idle to Active

Jul 16 10:56:08: BGP: A.B.C.202 open active, delay 22574ms

Jul 16 10:56:15: BGP: Import timer expired. Walking from 1 to 1

Jul 16 10:56:30: BGP: Performing BGP general scanning

Jul 16 10:56:30: BGP(0): scanning IPv4 Unicast routing tables

Jul 16 10:56:30: BGP: Applying map to find origin for B.C.D.0/24

Jul 16 10:56:30: BGP(1): scanning VPNv4 Unicast routing tables

Jul 16 10:56:30: BGP(2): scanning IPv4 Multicast routing tables

Jul 16 10:56:30: BGP: A.B.C.202 open active, local address B.C.D.1

Jul 16 10:56:45: BGP: Import timer expired. Walking from 1 to 1

Jul 16 10:56:48: BGP: compute bestpath

Jul 16 10:56:48: BGP(0): nettable_walker B.C.D.0/24 route sourced locally

Jul 16 10:57:00: BGP: Import timer expired. Walking from 1 to 1

Jul 16 10:57:00: BGP: A.B.C.202 open failed: Connection timed out; remote host not responding

AND I CAN'T PING A.B.C.202

2610# sh ip bgp sum

BGP router identifier X.Y.Z.22, local AS number 2

BGP table version is 2, main routing table version 2

1 network entries using 97 bytes of memory

1 path entries using 36 bytes of memory

1 BGP path attribute entries using 60 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 193 total bytes of memory

BGP activity 67/66 prefixes, 68/67 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

A.B.C.202 4 1 1414 1413 0 0 0 00:06:30 Active

2610#

-----------------------

2610(config)#no ip route A.B.C.202 255.255.255.255 serial 0/0.1 permanent

After it i can ping A.B.C.202 ( i think because used

Gateway of last resort is X.Y.Z.21 to network 0.0.0.0

Jul 16 10:59:58: BGP(0): A.B.C.202 computing updates, afi 0, neighbor version 2, table version 3, starting at 0.0.0.0

Jul 16 10:59:58: BGP(0): A.B.C.202 update run completed, afi 0, ran for 0ms, neighbor version 2, start version 3, throttled to 3

Jul 16 11:00:00: BGP: Import timer expired. Walking from 1 to 1

Jul 16 11:00:15: BGP: Import timer expired. Walking from 1 to 1

Jul 16 11:00:30: BGP: Performing BGP general scanning

Jul 16 11:00:30: BGP(0): scanning IPv4 Unicast routing tables

Jul 16 11:00:30: BGP: Applying map to find origin for B.C.D.0/24

Jul 16 11:00:30: BGP(IPv4 Unicast): Performing BGP Nexthop scanning for general scan

Jul 16 11:00:30: BGP(0): no valid path for A.B.C.200/29

Jul 16 11:00:30: BGP(1): scanning VPNv4 Unicast routing tables

Jul 16 11:00:30: BGP(VPNv4 Unicast): Performing BGP Nexthop scanning for general scan

Jul 16 11:00:30: BGP(2): scanning IPv4 Multicast routing tables

Jul 16 11:00:30: BGP(IPv4 Multicast): Performing BGP Nexthop scanning for general scan

Jul 16 11:00:31: BGP(0): nettable_walker A.B.C.200/29 no best path

Jul 16 11:00:31: BGP(0): A.B.C.202 computing updates, afi 0, neighbor version 3, table version 4, starting at 0.0.0.0

Jul 16 11:00:31: BGP(0): A.B.C.202 update run completed, afi 0, ran for 0ms, neighbor version 3, start version 4, throttled to 4

Jul 16 11:00:45: BGP: Import timer expired. Walking from 1 to 1

2610# sh ip bgp sum

BGP router identifier X.Y.Z.22, local AS number 2

BGP table version is 4, main routing table version 4

2 network entries using 194 bytes of memory

2 path entries using 72 bytes of memory

2 BGP path attribute entries using 120 bytes of memory

1 BGP AS-PATH entries using 24 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 410 total bytes of memory

BGP activity 68/66 prefixes, 69/67 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

A.B.C.202 4 1 1420 1419 4 0 0 00:01:33 1

2610#

Also i can ping from A.B.C.202 to B.C.D.1

New Member

Re: BGP route-appear and disappear

YES! helped that route-

ip route A.B.C.202 255.255.255.255 X.Y.Z.21 permanent

But why exactly that route resolved it?

Thank's to all!

Silver

Re: BGP route-appear and disappear

912
Views
0
Helpful
7
Replies
CreatePlease login to create content