Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

BGP RR and OSPF

Hi,

Here is what I have setup in the lab and for some reason I don't get BGP reflected routes as best route in the route-reflector-client's routing table. I know it has to do with OSPF. If I use RIP the same routes appear as the best routes. Any ideas as to what am I doing wrong here.

Router#1 (Acts as RR)

router ospf 1

log-adjacency-changes

network 172.16.0.0 0.0.255.255 area 0

!

router bgp 3

bgp log-neighbor-changes

redistribute ospf 1 match internal external 1 external 2

neighbor 172.16.1.2 remote-as 3 (To Router#1)

neighbor 172.16.1.2 route-reflector-client

neighbor 172.16.10.2 remote-as 3 (To Router#2)

neighbor 172.16.10.2 route-reflector-client

Router#2 (RR-client#1)

interface Loopback100

ip address 172.16.65.1 255.255.255.0

router ospf 1

log-adjacency-changes

network 172.16.0.0 0.0.255.255 area 0

router bgp 3

bgp log-neighbor-changes

neighbor 172.16.1.1 remote-as 3 (To RR)

Router#3 (RR-Client#2)

router ospf 1

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

!

router bgp 3

bgp log-neighbor-changes

neighbor 172.16.10.1 remote-as 3 (To RR)

Here is my BGP routing table on RR-Client#2

RR-Client#2 show ip bgp

BGP table version is 31, local router ID is 172.16.10.2

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*>i172.16.1.0/24 172.16.220.1 0 100 0 ?

*>i172.16.2.254/32 172.16.220.1 0 100 0 ?

*>i172.16.10.0/24 172.16.220.1 0 100 0 ?

*>i172.16.20.0/24 172.16.220.1 0 100 0 ?

--------- * i172.16.65.0/24 172.16.1.2 65 100 0 ?---------------

*>i172.16.100.0/24 172.16.220.1 7 100 0 ?

*>i172.16.220.0/24 172.16.220.1 0 100 0 ?

Everything else is fine but 172.16.65.0/24 route is not selected as the best route when I use OSPF as IGP. This route is originated from RR-Client#1.

I checked the RouterID for BGP and OSPF both matches I am not sure what else to check.

Thanks

4 REPLIES
Cisco Employee

Re: BGP RR and OSPF

could you give a 'sh ip os da x.x.x.x' and a 'sh ip bgp x.x.x.x'

Community Member

Re: BGP RR and OSPF

I thank the route 172.16.65.0/24 appear on RR-Client#2 learned from BGP and ospf has different router id

Community Member

Re: BGP RR and OSPF

I think it depends on the administrative distance because the routing table is dependent of the adm. distance.

ex.

eBGP 20

iBGP 200

OSPF 110

a.s.o

A link to it.

http://www.cisco.com/warp/public/105/21.html

Cisco Employee

Re: BGP RR and OSPF

I'm sorry to say that it has nothing to do with admi distance.

This could be a synchronization issue due to some router-id issue but we need more info to be sure.

237
Views
0
Helpful
4
Replies
CreatePlease to create content