Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

BGP using 2ISPs

Hi all

Currently we are using one ISP for our site. We are planning to add the 2nd ISP for redunancy, so that if ISP#1 fails than ISP #2 takes over.

I have attached the pre-define configuration, please help me if there is any configuration that its not correct.

Thanks.

Router #2 ISP #2 side

interface Fastethernet 2/0

ip address 203.1.254.52. 255.255.255.252

interface Fastethernet 1/0

ip address 66.28.166.3 255.255.255.0

router bgp 26000

no synchronization

bgp log-neighbor-changes

network 66.28.166.0 mask 255.255.255.0

neighbor 66.28.166.1 remote-as 26000

neighbor 203.1.254.52 remote-as 2914

neighbor 203.1.254.52 route-map AS 2200 in

neighbor 203.1.254.52 route-map AS 2200 out

no auto-summary

ip as-path access-list 1 permit ^2200$

access-list 10 permit 66.28.166.0

route-map AS permit 2200

match as-path 1

set local-preference 150

set as-path prepend 26000

Router #1 ISP #1 side

interface Fastethernet 2/0

ip address 66.166.26.12 255.255.255.252

interface Fastetherne 1/0

ip address 66.166.26.11 255.255.255.0

router bgp 26000

no synchronization

bgp log-neighbor-changes

network 66.166.26.0 mask 255.255.255.0

neighbor 66.28.189.3 remote-as 26000

neighbor 66.166.26.13 remote-as 16000

neighbor 66.166.26.13 route-map AS 16000 in

neighbor 66.166.26.13 route-map AS 16000 out

no auto-summary

ip as-path access-list 1 permit 16000

access-list 10 permit 66.166.26.0

route-map AS permit 16000

match as-path 1

set local-preference 200

match ip address 10

2 REPLIES

Re: BGP using 2ISPs

interface Fastethernet 2/0

ip address 203.1.254.52. 255.255.255.252 - First of all .52 is a bad ip address to be assigned to an interface.........52 is a network address for the mask u have used.....53 and 54 are the only ip address u can assign to router interfaces...

and under BGP configs on router 2

neighbor 203.1.254.52 remote-as 2914

I guess u r trying to peer with AS 2914, which is ur ISP 2. So it should be 203.1.254.53 or 54 (according to your mask /30)

Again, on router 2 "neighbor 66.28.166.1 remote-as 26000 " .....What is 66.28.166.1 ??? Is it ip address of router 1 ??? Looking at the peer statement, it looks like u r trying to peer to an internal neighbor ( IBGP).

There are more similar errors...in both the routers....Again there is a ip address over lap on router 1.

Also 66.166.26.12 /30 assigned to fa2/0 of router 1 is a network address again...

Overall, the configuration looks erroneous....

New Member

Re: BGP using 2ISPs

Thank you for your comment. I guess I pasted the wrong config.

Please review this one. Thanks again.

The purpose of this is to have redunancy only (no load sharing etc.) Either one ISP or another.

Router #2 ISP #2 side

interface Fastethernet 2/0

ip address 204.1.254.82 255.255.255.252

interface Fastethernet 1/0

ip address 66.28.189.3 255.255.255.0

router bgp 26254

no synchronization

bgp log-neighbor-changes

network 66.28.189.0 mask 255.255.255.0

neighbor 66.28.189.1 remote-as 26254

neighbor 204.1.254.82 remote-as 2914

neighbor 204.1.254.82 route-map AS 2914 in

neighbor 204.1.254.82 route-map AS 2914 out

no auto-summary

ip as-path access-list 1 permit ^2914$

access-list 10 permit 66.28.189.0

route-map AS permit 2914

match as-path 1

set local-preference 150

match ip address 10

set as-path prepend 26254

Router #1 ISP #1 side

interface Fastethernet 2/0

ip address 66.28.21.114 255.255.255.252

interface Fastetherne 1/0

ip address 66.28.189.1 255.255.255.0

router bgp 26254

no synchronization

bgp log-neighbor-changes

network 66.28.189.0 mask 255.255.255.0

neighbor 66.28.189.3 remote-as 26254

neighbor 66.28.21.113 remote-as 16631

neighbor 66.28.21.113 route-map AS 16631 in

neighbor 66.28.21.113 route-map AS 16631 out

no auto-summary

ip as-path access-list 1 permit 16631

access-list 10 permit 66.28.189.0

route-map AS permit 16631

match as-path 1

set local-preference 200

match ip address 10

ISP#1-AS 16631

ISP#2-AS 2914

Me-AS 26254

118
Views
0
Helpful
2
Replies