Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

BGP WAN Routing

I am still having some difficulty with a bgp configuration. I have a single router with two SPs. The SPs want to ping their respective interfaces. Echoes appear to work from some Internet locations to one interface, and from other locations to the other interface. For instance, Verizon can ping my router (their interface) from the directly connected router, but not from anywhere else. I can ping the Verizon interface on my router from my Comcast account (on the Internet), but I can't ping my other serial interface (ATT).

I have two default routes (0.0.0.0 0.0.0.0) configured on my router and they both show up in the output of sh ip bgp with an "r" (RIB-failure). I'm wondering if this is causing me an issue. When I removed the Verizon default route statement we lost Internet connectivity.

Here is a partial config:

interface Serial0/0

description ATT

bandwidth 1536

ip address 12.12.12.2 255.255.255.252

no ip unreachables

encapsulation ppp

service-module t1 timeslots 1-24

interface Serial0/1.100 point-to-point

description Verizon

bandwidth 1536

ip address 20.20.20.2 255.255.255.252

no ip unreachables

no cdp enable

frame-relay interface-dlci 100 IETF

router bgp 31818

no synchronization

bgp log-neighbor-changes

network 12.12.248.0 mask 255.255.255.0

timers bgp 30 90

neighbor 12.12.12.1 remote-as 7018

neighbor 12.12.12.1 description ATT Peering

neighbor 12.12.12.1 soft-reconfiguration inbound

neighbor 12.12.12.1 route-map ATT_only in

neighbor 12.12.12.1 route-map localonly out

neighbor 20.20.20.1 remote-as 6995

neighbor 20.20.20.1 description Verizon Peering

neighbor 20.20.20.1 soft-reconfiguration inbound

neighbor 20.20.20.1 route-map Verizon_only in

neighbor 20.20.20.1 route-map localonly out

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 12.12.12.1

ip route 0.0.0.0 0.0.0.0 20.20.20.1

!

ip as-path access-list 10 permit ^$

ip as-path access-list 20 permit ^1010$

ip as-path access-list 30 permit ^2020$

route-map ATT_only permit 10

match as-path 20

!

route-map Verizon_only permit 10

match as-path 30

!

route-map localonly permit 10

match as-path 10

Any suggestions would be appreciated.

Regards,

dk

1 REPLY
Cisco Employee

Re: BGP WAN Routing

Most providers will include a default route in their BGP advertisement if you request partial routing table. You shouldn't need to have default static routes configured on your side. This is the reason you are seeing the RIB-Failure message, BGP being unable to install the 0/0 in the RIB given that the static routes ares already installed with a lesser AD.

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
153
Views
0
Helpful
1
Replies