Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Bridge loadshare

Our network bridge is using a two (2) E1 lines provided by different carriers to connect head office and remote branches.

Within the configuration I use the bridge-group 1 circuit-group 1 parameters in interface to be able to connect the two lines at the same time. Although both interfaces are working well under normal condition I have several concern with the lines behavior in bridge connectivity.

1. The Two (2) E1 lines running at 2mbps each does not aggregate their speed to get a total of 4mbps, the links are independent to each other at 2mbps (load sharing is also not working)

2. In a fault condition affecting the E1 line (ex. E1 link #1 line is down) the network connection will take about 30 seconds before re connecting to the remaining active E1 (in this case E1#2..Ex. E1 link #2 is up the workstation will reconnect to this links after but only after several timeout, affecting application).

3. The workstation bridge network connection could not be define to either manual or automatic in selecting the connection path to remote bridge where the servers are connected the work station or bridge will determine its path to the server then established its links when I use the sh bridge command from the router, Workstation can be seen forwarding its data through E1 #1 links however if you intend to establish the links using E1 links #2 and you want the workstation to switch to the other carrier connection there’s no command supporting the option The trouble in this process as a result is the first E1 links will utilize its links to about 89% because of heavy loads meanwhile the second E1 (E1#2) is only using about 3% percent of the Load, You could not move the other load of E1#1 to E1#2.

Running Config:

Router#sh ru

Building configuration...

!

hostname BCC

!

!

ip subnet-zero

no ip routing

!

process-max-time 200

!

interface FastEthernet0/0

no ip address

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

full-duplex

bridge-group 1

!

interface Serial1/0

description E1_LINK

ip address nnn.nnn.nnn.nnn nnn.nnn.nnn.nnn

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

bridge-group 1

bridge-group 1 circuit-group 1

!

interface Serial1/1

description E1_Link

ip address nnn.nnn.nnn.nnn nnn.nnn.nnn.nnn

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

bridge-group 1

bridge-group 1 circuit-group 1

!

interface Serial1/2

no ip address

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

shutdown

!

interface Serial1/3

no ip address

no ip directed-broadcast

encapsulation ppp

no ip route-cache

no ip mroute-cache

shutdown

!

ip classless

no ip http server

!

end

Bridge_HO#sh ru

Building configuration...

!

hostname Bridge_HO

!

memory-size iomem 30

ip subnet-zero

no ip routing

!

process-max-time 200

!

interface Ethernet0/0

ip address nnn.nnn.nnn.nnn nnn.nnn.nnn.nnn

no ip route-cache

no ip mroute-cache

bridge-group 1

!

interface Serial0/0

description E1_LINK

ip address nnn.nnn.nnn.nnn nnn.nnn.nnn.nnn

no ip route-cache

no ip mroute-cache

bandwidth 2000000

serial restart-delay 0

bridge-group 1

bridge-group 1 circuit-group 1

!

interface Serial0/1

description E1_LINK

ip address nnn.nnn.nnn.nnn nnn.nnn.nnn.nnn

no ip route-cache

no ip mroute-cache

bandwidth 2000000

serial restart-delay 0

bridge-group 1

bridge-group 1 circuit-group 1

!

ip http server

ip classless

!

bridge 1 protocol ieee

!

line con 0

line aux 0

end

.

1 REPLY
Bronze

Re: Bridge loadshare

This doc might help http://www.cisco.com/en/US/customer/products/sw/iosswrel/ps1831/products_configuration_guide_chapter09186a00800ca65a.html#39513. It provides some valuable tips on what could go wrong while configuring the same.

77
Views
0
Helpful
1
Replies
CreatePlease login to create content