Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Bridging solution ???

at present, i'm using Cisco Catlyst 4006, i want to bridging two VLAN, unfortunately this fuction can not supported, everyone can help me to solve this problem.

Thank you very much

Nguyen Manh Hung.

12 REPLIES
Community Member

Re: Bridging solution ???

I would try using an external router for this.

Regards

John

Community Member

Re: Bridging solution ???

thank very much for your reply, can your tell me detail configuration of external router.

regards.

Manh Hung.

Re: Bridging solution ???

Configure a trunk between 4006 and external router, to trunk both the vlans. Configure two subinterfaces on the fast ethernet int. of router one each for each vlan. I assume the vlans in your case as 10 and 20.

The router configurations would look somewhat like this....

int fa0/1.10

encapsulation isl 10

description vlan 10

bridge-group 1

int fa0/1.20

encapsulation isl 20

description vlan 20

bridge-group 1

bridge 1 protocol ieee.

On the port on catalyst connecting to router, configure a trunk using command "set trunk"

Hope that helps!

Community Member

Re: Bridging solution ???

Hi Sankar Nair,

Thank very much for your support me, and now I have proplem on catalyst 4006 and AT 8324SX Allied Telesyn:

Configuring port on catalyst 4006 using trunk mode and 802.1q encapsulation as below:

interface FastEthernet2/35

switchport trunk encapsulation dot1q

switchport mode trunk

duplex full

no snmp trap link-status

Configuring fastethernet port on AT8324 switch using trunk mode (configure by user graphic interface mode).

But i don't understand, the trunk line didn’t work

Can you check configuration on catalyst 4006?

Best regards

Manh Hung

Re: Bridging solution ???

The configs on the cat do look fine.

See if you did give a "no shutdown" on the port fa2/35. (this might not be needed, as "shutdown" is not there under the interface in your configs)

CHeck the trunking status.... Try "show interfaces fastethernet 2/35 switchport" or "show interfaces fastethernet 2/35 trunk "

It could also be a problem with the AT 8324 external router configuration.

Community Member

Re: Bridging solution ???

Thank you very much, i will try follow your recommend.

Hung.

Community Member

Re: Bridging solution ???

If memory serves me right, the AT switch automatically tags all traffic on the trunk link. The 4006 does not tag the native vlan, which is vlan 1 (by default) in your configuration. Therefore I would not expect vlan 1 to operate between the router and switch as configured. If this is your problem, the solution is to set another unused vlan as the native vlan on the 4006, so that vlan 1 becomes tagged...

interface FastEthernet2/35

switchport trunk encapsulation dot1q

switchport mode trunk

switchport access vlan 999 !!!! vlan 999 is unused

duplex full

no snmp trap link-status

This should provide continuity in vlan 1 between Cisco and AT switches.

HTH

Community Member

Re: Bridging solution ???

Thank you very much for your help me,

Best wishes to you all

Hung

Community Member

Re: Bridging solution ???

--begin ciscomoderator note-- The following post has been edited to remove potentially confidential information. Further, due to recent implimentation of posting size restrictions, the post has been cut in half and the remaining post is in a new message below by ciscomoderator. Please refrain from posting confidential information on the site to reduce security risks to your network. -- end ciscomoderator note --

To day I go to my factory and configuring Catalyst 4006 and AT8324 follow

your instruction but the trunking line still doesn't work.I changed

configuration as access mode the system work propely.

Pls help me checking my configuration.

--------------------------------------

AT8324 switch confiruration

System Information

==================

System Description : AT-8324SX, version 1.402

System Object ID : 1.3.6.1.4.1.207.1.4.42

System Up Time : 247523 (0 day 0 hr 41 min 15 sec)

System Name : CentreCOM AT-8324SX

System Contact : DEFAULT SYSTEM CONTACT

System Location : DEFAULT SYSTEM LOCATION

Switch Information : Unit 1

==================

Main Board

Hardware Version : V4.0

Firmware Version : V1.11

Serial Number : 00-30-84-03-73-E0

Port Number : 26

Internal Power Status : Active

Redundant Power Status : Inactive

Expansion Slot 1 : 2Port 100Base-FX(MMF)

Expansion Slot 2 : Stacking

Agent Module

Hardware Version : V2.0 (801 CPU)

POST ROM Version : V1.11

Firmware Version : V1.402

SNMP Agent : Master

Port Configuration : Unit 1 Port 1 - 12

==================

Flow Control on all ports : [Enable] [Disable]

Port Type Admin Flow Control Speed and Duplex

-------------------------------------------------------------------

1 10/100TX ENABLED DISABLED AUTO

2 10/100TX ENABLED DISABLED AUTO

3 10/100TX ENABLED DISABLED AUTO

4 10/100TX ENABLED DISABLED AUTO

5 10/100TX ENABLED DISABLED AUTO

6 10/100TX ENABLED DISABLED AUTO

7 10/100TX ENABLED DISABLED AUTO

8 10/100TX ENABLED DISABLED AUTO

9 10/100TX ENABLED DISABLED AUTO

10 10/100TX ENABLED DISABLED AUTO

11 10/100TX ENABLED DISABLED

Port Configuration :Unit 1 Port 25 - 32

==================

Flow Control on all ports : [Enable] [Disable]

Port Type Admin Flow Control Speed and Duplex

-------------------------------------------------------------------

25 100FX ENABLED DISABLED 100_FULL

26 100FX ENABLED DISABLED 100_FULL

27 -------- --------- ------------- ---------

28 -------- --------- ------------- ---------

29 -------- --------- ------------- ---------

30 -------- --------- ------------- ---------

31 -------- --------- ------------- ---------

32 -------- --------- ------------- ---------

Port Information : Unit 1 Port 1 - 12

================

Port Type Operational Link FlowControl Speed and

InUse Duplex InUse

------------------------------------------------------------------

1 10/100TX YES UP NONE 100_FULL

2 10/100TX YES DOWN -------------- ----------

3 10/100TX YES DOWN -------------- ----------

4 10/100TX YES DOWN -------------- ----------

5 10/100TX YES DOWN -------------- ----------

6 10/100TX YES DOWN -------------- ----------

Port Information : Unit 1 Port 25 - 32

================

Port Type Operational Link FlowControl Speed and

InUse Duplex InUse

------------------------------------------------------------------

25 100FX YES DOWN -------------- ----------

26 100FX YES UP NONE 100_FULL

27 -------- --- ----- -------------- ----------

28 -------- --- ----- -------------- ----------

29 -------- --- ----- -------------- ----------

30 -------- --- ----- -------------- ----------

31 -------- --- ----- -------------- ----------

32 -------- --- ----- -------------- ----------

802.1Q VLAN Base Information

============================

VLAN Version Number : 1

MAX VLAN ID : 2048

MAX Supported VLANs : 256

Current Number of 802.1Q VLANs Configured : 3

802.1Q VLAN Current Table Information

=====================================

Deleted VLAN Entry Counts : 0

VID Creation Time Status

----------------------------------------------------------------

1 0 (0 day 0 hr 0 min 0 sec) Permanent

Unit Current Egress Ports Current Untagged Ports

1. 001111111111 111111111111 11-- 001111111111 111111111111 11--

2. ------------ ------------ ---- ------------ ------------ ----

3. ------------ ------------ ---- ------------ ------------ ----

4. ------------ ------------ ---- ------------ ------------ ----

Sorted by VID : 1

[Show] [More]

802.1Q VLAN Static Table Configuration

======================================

VID VLAN Name Status

------------------------------

1 Active

Unit Egress Ports Forbidden Egress Ports

1. 001111111111 111111111111 11-- 000000000000 000000000000 00--

2. ------------ ------------ ---- ------------ ------------ ----

3. ------------ ------------ ---- ------------ ------------ ----

4. ------------ ------------ ---- ------------ ------------ ----

Unit Untagged Ports

1. 001111111111 111111111111 11-- VID : 1

2. ------------ ------------ ---- [Show]

3. ------------ ------------ ---- [More]

4. ------------ ------------ ---- [New]

The name of the VLAN. | R

Port Trunking Configuration

===========================

Trunk ID Status Member List

1 2 3 4

--------- -------- ----------- ----------- ----------- -----------

1 ENABLED Unit : 1 Unit : - Unit : - Unit : -

Port : 26 Port : -- Port : -- Port : --

-- -------- Unit : - Unit : - Unit : - Unit : -

Port : -- Port : -- Port : -- Port : --

-- -------- Unit : - Unit : - Unit : - Unit : -

Port : -- Port : -- Port : -- Port : --

Trunk ID : 1 Trunk ID : 1 Member Unit : 1

Member Port : 1

[Show] [More]

802.1Q VLAN Port Configuration : Unit 1 Port 1 - 12

===============================

Port PVID Acceptable Ingress GVRP GVRP Failed GVRP Last

Frame Type Filtering Status Registrations PDU Origin

------------------------------------------------------------------------------

1 2 All TRUE DISABLED 0 00-00-00-00-00-00

2 2 All TRUE DISABLED 0 00-00-00-00-00-00

3 1 All TRUE DISABLED 0 00-00-00-00-00-00

4 1 All TRUE DISABLED 0 00-00-00-00-00-00

5 1 All TRUE DISABLED 0 00-00-00-00-00-00

6 1 All TRUE DISABLED 0 00-00-00-00-00-00

[Enable] [Disable] [Add] [Delete]

802.1Q VLAN Port Configuration : Unit 1 Port 25 - 32

===============================

Port PVID Acceptable Ingress GVRP GVRP Failed GVRP Last

Frame Type Filtering Status Registrations PDU Origin

------------------------------------------------------------------------------

25 1 All TRUE DISABLED 0 00-00-00-00-00-00

26 1 All TRUE DISABLED 0 00-00-00-00-00-00

27 ---- --- ----- -------- ---- ---------------

-----------------------------------------------------------------------------------------------------

Cisco Cattalyst 4006 configuration

urrent configuration : 5460 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

service compress-config

!

hostname FAPV4006

!

boot system bootflash:cat4000-is-mz.121-8a.EW1.bin

no logging console

enable secret 5 $1$t69v$VZHoZRl48Wb5xLRKxb20G/

!

ip subnet-zero

no ip domain-lookup

!

!

!

interface GigabitEthernet1/1

no snmp trap link-status

!

interface GigabitEthernet1/2

no snmp trap link-status

!

interface FastEthernet2/1

switchport access vlan 3

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

interface FastEthernet2/2

switchport access vlan 3

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

interface FastEthernet2/3

switchport access vlan 3

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

interface FastEthernet2/4

switchport access vlan 3

switchport mode access

duplex full

no snmp trap link-status

!

interface FastEthernet2/5

switchport access vlan 3

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

interface FastEthernet2/6

switchport access vlan 3

switchport mode access

duplex full

no snmp trap link-status

!

interface FastEthernet2/7

switchport access vlan 3

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

interface FastEthernet2/8

switchport access vlan 3

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

interface FastEthernet2/9

switchport access vlan 3

switchport mode access

duplex full

no snmp trap link-status

!

interface FastEthernet2/10

switchport access vlan 3

switchport mode access

duplex full

no snmp trap link-status

!

interface FastEthernet2/11

switchport access vlan 3

switchport mode access

duplex full

no snmp trap link-status

!

interface FastEthernet2/12

switchport access vlan 3

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

interface FastEthernet2/13

switchport access vlan 3

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

-- continued in post by ciscomoderator below --

Re: Bridging solution ???

--begin ciscomoderator note-- The following post has been edited to remove potentially confidential information. Please refrain from posting confidential information on the site to reduce security risks to your network. -- end ciscomoderator note --

interface FastEthernet2/14

switchport access vlan 3

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

interface FastEthernet2/15

switchport access vlan 3

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

interface FastEthernet2/16

switchport access vlan 3

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

interface FastEthernet2/17

switchport access vlan 3

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

interface FastEthernet2/18

switchport access vlan 3

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

interface FastEthernet2/19

switchport access vlan 3

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

interface FastEthernet2/20

switchport access vlan 3

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

interface FastEthernet2/21

switchport access vlan 3

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

interface FastEthernet2/22

switchport access vlan 3

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

interface FastEthernet2/23

switchport access vlan 3

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

interface FastEthernet2/24

switchport access vlan 4

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

interface FastEthernet2/25

switchport access vlan 4

switchport mode access

duplex half

no snmp trap link-status

!

interface FastEthernet2/26

switchport access vlan 4

switchport mode access

duplex half

no snmp trap link-status

!

interface FastEthernet2/27

switchport access vlan 4

switchport mode access

duplex half

no snmp trap link-status

!

interface FastEthernet2/28

switchport access vlan 4

switchport mode access

duplex half

no snmp trap link-status

!

interface FastEthernet2/29

switchport access vlan 2

switchport mode access

duplex half

no snmp trap link-status

!

interface FastEthernet2/30

switchport access vlan 2

switchport mode access

duplex half

no snmp trap link-status

!

interface FastEthernet2/31

switchport access vlan 2

switchport mode access

duplex half

no snmp trap link-status

!

interface FastEthernet2/32

switchport access vlan 7

switchport mode access

duplex full

speed 100

no snmp trap link-status

!

interface FastEthernet2/33

switchport trunk encapsulation dot1q

switchport mode trunk

duplex full

no snmp trap link-status

!

interface FastEthernet2/34

switchport trunk encapsulation dot1q

switchport mode trunk

switchport access vlan 999

duplex full

no snmp trap link-status

!

interface FastEthernet2/35

switchport access vlan 2

switchport mode access

duplex full

no snmp trap link-status

!

interface FastEthernet2/36

switchport access vlan 4

switchport mode access

duplex full

no snmp trap link-status

!

interface Vlan1

ip address 10.190.1.1 255.255.255.0

!

interface Vlan2

ip address 10.190.11.1 255.255.255.0

!

interface Vlan3

ip address 10.190.12.1 255.255.255.0

!

interface Vlan4

ip address 10.190.13.1 255.255.255.0

!

interface Vlan7

ip address 10.190.10.1 255.255.255.0

!

router rip

network 10.0.0.0

!

ip classless

ip route 10.192.11.0 255.255.255.0 10.190.11.5

no ip http server

!

!

line con 0

password 7 --moderator edit--

login

stopbits 1

line vty 0 4

password 7 --moderator edit--

login

line vty 5 15

password 7 --moderator edit--

login

!

end

FAPV4006#e

-----------------------------------------------------

sh command

FAPV4006#sh int trunk

Port Mode Encapsulation Status Native vlan

Fa2/34 on 802.1q trunking 1

Port Vlans allowed on trunk

Fa2/34 1-1005

Port Vlans allowed and active in management domain

Fa2/34 1-4,7,1002-1005

Port Vlans in spanning tree forwarding state and not pruned

Fa2/34 1-4,7,1002-1005

FAPV4006#sh int fa2/34 switchport

Name: Fa2/34

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

FAPV4006#sh vlan

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Gi1/1, Gi1/2, Fa2/33

2 VLAN2 active Fa2/29, Fa2/30, Fa2/31, Fa2/35

3 VLAN3 active Fa2/1, Fa2/2, Fa2/3, Fa2/4

Fa2/5, Fa2/6, Fa2/7, Fa2/8

Fa2/9, Fa2/10, Fa2/11, Fa2/12

Fa2/13, Fa2/14, Fa2/15, Fa2/16

Fa2/17, Fa2/18, Fa2/19, Fa2/20

Fa2/21, Fa2/22, Fa2/23

4 VLAN4 active Fa2/24, Fa2/25, Fa2/26, Fa2/27

Fa2/28, Fa2/36

7 VLAN7 active Fa2/32

1002 fddi-default active

1003 token-ring-default active

1004 fddinet-default active

1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1 enet 100001 1500 - - - - - 0 0

2 enet 100002 1500 - - - - - 0 0

3 enet 100003 1500 - - - - - 0 0

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

4 enet 100004 1500 - - - - - 0 0

7 enet 100007 1500 - - - - - 0 0

1002 fddi 101002 1500 - - - - - 0 0

1003 tr 101003 1500 - - - - - 0 0

1004 fdnet 101004 1500 - - - ieee - 0 0

1005 trnet 101005 1500 - - - ibm - 0 0

Primary Secondary Type Ports

------- --------- ----------------- ------------------------------------------

Thank you very much

Hung

Community Member

Re: Bridging solution ???

Hi there

i am not an expert in networking

but i gusse the problem is the encap mismatch

set both the switch and router to ISL encap

that may aolve the problem

good luck

Community Member

Re: Bridging solution ???

you just need adding a cross-over ethernet cable to one port belonging to both vlans.....

134
Views
0
Helpful
12
Replies
CreatePlease to create content