Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

broadcast IP.

Our Core (6509) switch is configured for a VLAN network...At present there are about 15 VLANs configured...My particular interest is in the broadcast ip (ex. 172.x.x.255) everytime I Ping these Ip address using ms dos prompt from the P.C., it is replying. the next interesting thing to happened is when you telnet the broadcast ip (172.x.x.255) the core switch (6509) answer...

Any idea

11 REPLIES

Re: broadcast IP.

Hi,

AFAIK,

1) if you ping to a broadcast address (172.x.x.255) each station in the subnet has to respond. Some ping implementations do show the real IP address of the responder, some (MS Windows, e.g.) don't.

2) Just guessing: Are you connected directly to the core switch which has it's IP address in 172.x.x.0/24 subnet? If yes, try to connect to through another switch which also fulfills this address condition and maybe it will catch the telnet session now.

Regards,

Milan

New Member

Re: broadcast IP.

yes I am directly connected to the core switch I tried to use a switch in between the core switch and my vlan network which had the address of 172.16.vlan.x/24 the problem still the same, "whenever I telnet the broadcast IP which is 172.16.vlan.255" the core switch answer to my telnet request.

Re: broadcast IP.

Hi,

additional questions:

1) Is the core switch configured as pure L2 switch or does it provide some L3 functionality?

2) Is the PC you are Telnetting from also in the 172.16.vlan.255 subnet?

3) Is the core switch address configured as the default gateway on the PC?

I can't imagine PC Telnetting to the broadcast address in it's subnet. But if the PC is in another subnet it might send the Telnet frame to the default gateway.

My idea is the core switch is providing some proxy functions on L3.

Regards,

Milan

New Member

Re: broadcast IP.

Hello,

Yes the core switch provide L3 functionality,

The PC where im telnetting is from VLAN6,(its add. 172.x.VLAN6.x).

The core switch is the default gateway of for the PC.

Yes you are right, The PC could not telnet the broadcast address from its own Vlan. if the PC belong to vlan 6 and its ip address is 172.x.vlan6.x, it could not telnet the broadcast ip on vlan 6 which is 172.x.vlan6.255, However it can telnet the broadcast ip from other vlan (ex. 172.x.vlan3.255).

if the Core switch is providing some proxy functions on L3. Do you have any idea or work around on this?

Re: broadcast IP.

Hi,

it's difficult without knowing the core switch config. Is it running IOS or CatOS?

Can you provide the L3 config part? Especially the VLAN interfaces or subinterfaces config?

Just one blind shot:

If running IOS, is no ip directed-broadcast command used?

Regards,

Milan

New Member

Re: broadcast IP.

Hi,

Im attaching the L3 config for you to see,

The statement no ip directed is already added to the interface however, I notice that there's no effect and does not resolve the issue.

hostname MSFC2_Core

!

boot system bootflash:c6msfc2-dsv-mz.121-11b.E.bin

boot bootldr bootflash:c6msfc2-boot-mz.121-11b.E.bin

ip subnet-zero

!

ipx routing 00d0.005e.4bfc

mls rp nde-address 172.xx.xx.xxx

mls rp ip

no mls ip multicast aggregate

!

!

!

interface Vlan1

ip address 172.xx.xx.xxx 255.255.240.0

mls rp management-interface

mls rp ip

!

interface Vlan2

ip address 172.xx.Vlan2.xx 255.255.255.0

ip helper-address 172.xx.xx.xxx

mls rp vtp-domain

mls rp ip

!

interface Vlan3

ip address 172.xx.Vlan3.xx 255.255.255.0

ip helper-address 172.xx.xx.xxx

mls rp vtp-domain

mls rp ip

!

interface Vlan4

ip address 172.xx.Vlan4.xx 255.255.255.0

ip helper-address 172.xx.xx.xxx

mls rp vtp-domain

mls rp ip

!

interface Vlan5

ip address 172.xx.Vlan5.xx 255.255.255.0

mls rp vtp-domain

mls rp ip

!

interface Vlan6

ip address 172.xx.Vlan6.xx 255.255.255.0

ip helper-address 172.xx.xx.xxx

mls rp vtp-domain

mls rp ip

!

interface Vlan7

ip address 172.xx.Vlan7.xx 255.255.255.0

ip helper-address 172.xx.xx.xxx

mls rp vtp-domain

mls rp ip

!

interface Vlan8

ip address 172.xx.VLAN8.xx 255.255.255.0

ip helper-address 172.xx.xx.xxx

mls rp vtp-domain

mls rp ip

!

interface Vlan9

ip address 172.xx.Vlan9.xx 255.255.255.0

ip helper-address 172.xx.xx.xxx

mls rp vtp-domain

mls rp ip

!

interface Vlan10

ip address 172.xx.Vlan10.xx 255.255.255.0

ip helper-address 172.xx.xx.xxx

mls rp vtp-domain

mls rp ip

!

!

interface Vlan14

ip address 172.xx.Vlan14.xx 255.255.255.0

ip helper-address 172.xx.xx.xxx

mls rp vtp-domain

mls rp ip

!

interface Vlan15

ip address 172.xx.Vlan15.xx 255.255.255.0

ip helper-address 172.xx.xx.xxx

mls rp vtp-domain

mls rp ip

!

interface Vlan32

ip address 172.xx.Vlan32.xx 255.255.255.0

ip helper-address 172.xx.xx.xxx

mls rp vtp-domain

mls rp ip

!

interface Vlan33

ip address 172.xx.Vlan33.xx 255.255.255.0

ip helper-address 172.xx.xx.xxx

mls rp vtp-domain

mls rp ip

!

interface Vlan34

ip address 172.xx.Vlan34.xx 255.255.255.0

ip helper-address 172.xx.xx.xxx

mls rp vtp-domain

mls rp ip

!

interface Vlan40

ip address 172.xx.Vlan40.xx 255.255.255.0

ip helper-address 172.xx.xx.xxx

mls rp ip

!

interface Vlan41

ip address 172.xx.xx.xx 255.255.255.0

ip helper-address 172.xx.xx.xxx

mls rp vtp-domain

mls rp ip

!

router ospf 1

log-adjacency-changes

network 172.xx.Vlan2.0 0.0.0.255 area 0

network 172.xx.Vlan3.0 0.0.0.255 area 0

network 172.xx.Vlan4.0 0.0.0.255 area 0

network 172.xx.Vlan5.0 0.0.0.255 area 0

network 172.xx.Vlan6.0 0.0.0.255 area 0

network 172.xx.Vlan7.0 0.0.0.255 area 0

network 172.xx.Vlan8.0 0.0.0.255 area 0

network 172.xx.Vlan9.0 0.0.0.255 area 0

network 172.xx.Vlan10.0 0.0.0.255 area 0

network 172.xx.Vlan11.0 0.0.0.255 area 0

network 172.xx.Vlan12.0 0.0.0.255 area 0

network 172.xx.Vlan13.0 0.0.0.255 area 0

network 172.xx.Vlan14.0 0.0.0.255 area 0

network 172.xx.Vlan15.0 0.0.0.255 area 0

network 172.xx.Vlan16.0 0.0.15.255 area 0

network 172.xx.Vlan32.0 0.0.0.255 area 0

network 172.xx.Vlan33.0 0.0.0.255 area 0

network 172.xx.Vlan34.0 0.0.0.255 area 0

network 172.xx.Vlan40.0 0.0.0.255 area 0

network 172.xx.Vlan41.0 0.0.0.255 area 0

!

line con 0

line vty 0 4

password

login

!

end

Re: broadcast IP.

Hi,

I don't see anything wrong in the config.

To clarify:

IP helper-address specifies your DHCP server address in VLAN5?

What is the source and target VLAN when you are Telnetting?

Regards,

Milan

New Member

Re: broadcast IP.

Yes I also add Ip helper address in Vlan5...

The source Vlan is in Vlan6 where my pc is connected the target Vlan when telnetting is any other vlan (i can telnet 172.xx.Vlan3.255 or 172.xx.Vlan4.255) and so on...

Re: broadcast IP.

Well, I've got no new ideas.

Last low-chance try:

Remove ip helper-address from int VLAN6 (or try to connect from VLAN5 without adding ip helper-address).

(There might be something incorrect in it.)

Regards,

Milan

New Member

Re: broadcast IP.

Thanks Milan,

I remove the ip helper address statement but still didn't work.

Regards,

Leo

Re: broadcast IP.

Leo,

I really don't know what to try next. Maybe the mls commands...

Or try to open a TAC case.

If you provide them the complete config and IOS version, they should know.

Regards,

Milan

288
Views
0
Helpful
11
Replies
CreatePlease login to create content