Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Broadcast not getting forwarded from one vlan to another

Hi

I have the follwoing network

ATM SW1---ATM SW2---ATM SW3---6509--3550

there are 3 ATM switches connected in triangle fashion and 6509 is connected to one of the ATM switch through a gigabit port on ATM switch. These ATM switches are not cisco switches. These ATM switches are connected to each other by using ELANs and using a single flat subnet of 140.140.x.x/16 and hence using a single vlan 1. The port on 6509 which is connected to one of the ATM switch is also in vlan 1 and having subnet 140.140.x.x/16. Rest of the config of 6509 is default. There is already a DHCP server on one of the ATM switch. Now when i move this DHCP server to a port on 6509 which is on vlan1 then the pcs connected in ATM network are able to get ips, it means broadcasts are reaching 6509 from ATM network. But when i create a new vlan on 6509 and give ip-helper acommand on vlan 1 and put DHCP in vlan2 then the pcs on ATM network not getting ips.

What can be the expected issue? Can anyone help ?

Thanx and Regards

  • Other Network Infrastructure Subjects
8 REPLIES

Re: Broadcast not getting forwarded from one vlan to another

The IP helper must be configured on the interface that is receiving the broadcast. Now I understand from the post that you configured the helper on vlan1. If this is correct, please change it. I am quite confident that this will resolve your problem.

Regards,

Leo

New Member

Re: Broadcast not getting forwarded from one vlan to another

Hi Leo

I have configured it on vlan 2 also, but still not working.

Regards

Re: Broadcast not getting forwarded from one vlan to another

Please verify your config with the aid of the attached example:

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080114aee.shtml

Regards,

Leo

Bronze

Re: Broadcast not getting forwarded from one vlan to another

Hello,

are the PC´s that are not getting IP addresses located behind the non-Cisco ATM switches ? What brand/type are the switches ?

Regards,

Nethelper

New Member

Re: Broadcast not getting forwarded from one vlan to another

Hi

The PCs are behind non-cisco(i.e. Marconi ASX 1000) switches, but when i put DHCP on vlan 1 on 6509 then pcs are able to get ips but when i change the vlan of DHCP to vlan 2 then pcs are not able to get ip frm DHCP.

Regards

New Member

Re: Broadcast not getting forwarded from one vlan to another

Hello Leo

I have done exactly the same configuration like shown in the document. I will go to customer site and try to run debug dhcp on the 6500 and see whether i am able to get broad cast on vlan2 or not.

Regards

Silver

Re: Broadcast not getting forwarded from one vlan to another

Hi,

just ensure whether the dhcp is reaching from 6509

and if so, try using this command on vlan 1

ip dhcp relay information trusted

or

ip dhcp snooping trust

Hope this help,

Rgs,

Balaji.V

New Member

Re: Broadcast not getting forwarded from one vlan to another

DHCP is very well reachable as when i put DHCP in vlan 2 on 6509 itself then pcs behin ATM network are able to get ip.

ATM switches are Marconi ASX 1000 series switches.

Regards

122
Views
0
Helpful
8
Replies
This widget could not be displayed.