Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

bz
New Member

c1700, 2 isp links, nat ?

Hello,

I have a router 1700 router. I configured 3 ethernet interfaces: 1 WAN main connection via ethernet, 1 WAN backup connection via ethernet and 1 LAN connection.

How to setup the router to use the backup link when the primary fails ? is it possible ?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: c1700, 2 isp links, nat ?

Hi Friend,

Try something like the following:

interface ethernet1

ip address

ip nat outside

!

interface ethernet2

ip address

ip nat outside

!

interface ethernet3

ip address

ip nat inside

!

ip route 0.0.0.0 0.0.0.0 ethernet1 200

ip route 0.0.0.0 0.0.0.0 ethernet2 210

!

ip nat inside source route-map ISP1-map interface ethernet1 overload

ip nat inside source route-map ISP2-map interface ethernet2 overload

!

route-map ISP11-map permit 10

match interface ethernet1

!

route-map ISP12-map permit 10

match interface ethernet2

HTH, if yes please rate the post.

Ankur

4 REPLIES

Re: c1700, 2 isp links, nat ?

Hi Friend,

Yes thats possible and just want to confirm that you waan a NAT traffic moving out from WAN connection and also if you want to use both the WAN connection at a same time or just one as primary and when primary fails you want then only the backup interface for WAN to work

Regards,

Ankur

bz
New Member

Re: c1700, 2 isp links, nat ?

I wan to use the backup only when the main fails.

On both WANs I have public IP. On Lan I have non public so nat is a must on both.

Re: c1700, 2 isp links, nat ?

Hi Friend,

Try something like the following:

interface ethernet1

ip address

ip nat outside

!

interface ethernet2

ip address

ip nat outside

!

interface ethernet3

ip address

ip nat inside

!

ip route 0.0.0.0 0.0.0.0 ethernet1 200

ip route 0.0.0.0 0.0.0.0 ethernet2 210

!

ip nat inside source route-map ISP1-map interface ethernet1 overload

ip nat inside source route-map ISP2-map interface ethernet2 overload

!

route-map ISP11-map permit 10

match interface ethernet1

!

route-map ISP12-map permit 10

match interface ethernet2

HTH, if yes please rate the post.

Ankur

bz
New Member

Re: c1700, 2 isp links, nat ?

thx friend that was what I was looking for !

139
Views
4
Helpful
4
Replies
CreatePlease login to create content