Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

C2948G-L3

Hi I have two problems with a installation that has many switches.

I have a C2948G-L3 to do the routing, a C4912G where came many C3524XL.

I have put 3 vlan's in the C4912G that are propagated by 802.1Q to the switches C3524XL.

The C2948G-L3 is attached to the C4912G too and has three subinterfaces with 802.1Q, each one for a different vlan.

The users in the vlan 1 in the C2948G-L3 have a very low conection with others vlan 1 users in others switches.

But they conect fast with vlan 2 or 3 users in others switches.

What can I do?

cpd_2948G-L3#sh run

Building configuration...

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 2948G-L3

!

boot system flash cat2948g-in-mz.120-25.W5.27

!

ip subnet-zero

bridge irb

!

!

!

interface FastEthernet1

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet2

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet47

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet48

no ip address

no ip directed-broadcast

bridge-group 1

!

interface GigabitEthernet49

no ip address

no ip directed-broadcast

!

interface GigabitEthernet49.1

encapsulation dot1Q 1 native

no ip directed-broadcast

bridge-group 1

!

interface GigabitEthernet49.2

encapsulation dot1Q 2

no ip directed-broadcast

bridge-group 2

!

interface GigabitEthernet49.3

encapsulation dot1Q 3

no ip directed-broadcast

bridge-group 3

!

interface GigabitEthernet50

no ip address

no ip directed-broadcast

!

interface BVI1

ip address 192.168.60.182 255.255.255.0

no ip directed-broadcast

no ip route-cache cef

!

interface BVI2

ip address 192.168.151.254 255.255.255.0

no ip directed-broadcast

no ip route-cache cef

!

interface BVI3

ip address 192.168.152.254 255.255.255.0

no ip directed-broadcast

no ip route-cache cef

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.60.3

!

bridge 1 protocol ieee

bridge 1 route ip

bridge 2 protocol ieee

bridge 2 route ip

bridge 3 protocol ieee

bridge 3 route ip

!

line con 0

transport input none

line aux 0

xxxxx

password xxx

login

!

end

And the C4912G is:

cpd_4912G> (enable)

begin

!

#version 4.5(3)

!

!

!

set interface sc0 up

set interface sl0 0.0.0.0 0.0.0.0

#vtp

set vtp domain sabadell

set vtp mode server

set vtp v2 enable

set vtp pruning disable

set vtp pruneeligible 2-1000

clear vtp pruneeligible 1001-1005

set vlan 1 name default type ethernet mtu 1500 said 100001 state active

set vlan 2 name red_151 type ethernet mtu 1500 said 100002 state active

set vlan 3 name red_152 type ethernet mtu 1500 said 100003 state active

set vlan 1005 name trbrf-default type trbrf mtu 4472 said 101005 state active bridge 0xf stp ibm

set vlan 1003 name trcrf-default type trcrf mtu 4472 said 101003 state active parent 1005 ring 0xccc mode srb aremaxhop 7 stemaxhop 7

!

#vlan 1

set spantree enable 1

set spantree fwddelay 15 1

set spantree hello 2 1

set spantree maxage 20 1

set spantree priority 32768 1

#vlan 2

set spantree enable 2

set spantree fwddelay 15 2

set spantree hello 2 2

set spantree maxage 20 2

set spantree priority 32768 2

#vlan 3

set spantree enable 3

set spantree fwddelay 15 3

set spantree hello 2 3

set spantree maxage 20 3

set spantree priority 32768 3

!

#set boot command

set boot config-register 0x2

set boot system flash bootflash:

#module 1 : 0-port Switching Supervisor

set module name 1

!

#module 2 : 12-port 1000BaseX Ethernet

set module name 2

set module enable 2

set vlan 1 2/1-12

set port channel 2/1-4 off

set port channel 2/5-8 off

set port channel 2/9-12 off

set port channel 2/1-2 on

set port channel 2/3-4 auto

set port channel 2/5-8 auto

set port channel 2/9-12 auto

set port enable 2/1-12

set port level 2/1-12 normal

set port duplex 2/1-12 full

set port trap 2/1-12 disable

set port name 2/1-12

set port security 2/1-12 disable

set port membership 2/1-12 static

set port protocol 2/1-12 ip on

set port protocol 2/1-12 ipx auto

set port negotiation 2/1-12 enable

set port flowcontrol send 2/1-12 desired

set port flowcontrol receive 2/1-12 off

set cdp enable 2/1-12

set cdp interval 2/1-12 60

set trunk 2/1 on dot1q 1-1005

set trunk 2/2 on dot1q 1-1005

set trunk 2/3 on dot1q 1-1005

set trunk 2/4 on dot1q 1-1005

set trunk 2/5 on dot1q 1-1005

set trunk 2/6 on dot1q 1-1005

set trunk 2/7 auto dot1q 1-1005

set trunk 2/8 on dot1q 1-1005

set trunk 2/9 on dot1q 1-1005

set trunk 2/10 on dot1q 1-1005

set trunk 2/11 auto dot1q 1-1005

set trunk 2/12 on dot1q 1-1005

end

1 REPLY

Re: C2948G-L3

Hi,

what about to try SDM tuning?

See http://www.cisco.com/univercd/cc/td/doc/product/l3sw/4908g_l3/ios_12/18w522a/config/sdm_cnfg.htm#10038 for details.

Another idea:

I remember several years ago someone recommended me not to use IRB on C2948G-L3 and configure CRB instead of it ("router on the stick" for interVLAN routing) with an external cable connecting the bridged ports to another switch. But I can't find any document right now.

Regards,

Milan

106
Views
0
Helpful
1
Replies
CreatePlease login to create content