Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

C857W proper bridging between vlan and radio interface

Could any one help me out here. I'm totally lost.

I can't get the dhcp server to work, infact I can't even ping the routers LAN IP. However I have a cabled PC on Fast0 and a laptop on the wireless, and they are infact able to ping each other.

Here is the config:

Router#sh run

Building configuration...

Current configuration : 1454 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

ip dhcp use vrf connected

!

ip dhcp pool LAN

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

!

!

ip cef

no ip domain lookup

!

!

!

!

!

!

bridge irb

!

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Dot11Radio0

no ip address

!

ssid SOMETHING

vlan 1

authentication open

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

channel 2462

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no snmp trap link-status

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

no ip address

bridge-group 1

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 192.168.1.1 255.255.255.0

!

!

ip http server

ip http access-class 10

no ip http secure-server

!

access-list 10 permit 192.168.1.0 0.0.0.255

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

!

scheduler max-task-time 5000

end

Router#

Show commands will follow in the next posting.

2 REPLIES
Bronze

Re: C857W proper bridging between vlan and radio interface

Router#sh dot11 ass

802.11 Client Stations on Dot11Radio0:

SSID [SOMETHING] :

MAC Address IP address Device Name Parent State

0013.ce86.ff7b 0.0.0.0 - - self Assoc

Others: (not related to any ssid)

Router#sh bridge 1

Total of 300 station blocks, 298 free

Codes: P - permanent, S - self

Bridge Group 1:

Address Action Interface Age RX count TX count

0013.ce86.ff7b forward Do0.1 P 101 1

0050.dad9.ff0a forward Vlan1 12 13 1

Router#sh mac-

Destination Address Address Type VLAN Destination Port

------------------- ------------ ---- --------------------

0013.ce86.ff7b Dynamic 1 Vlan1

0014.f2e2.61c7 Self 1 Vlan1

0050.dad9.ff0a Dynamic 1 FastEthernet0

Router#sh arp

Protocol Address Age (min) Hardware Addr Type Interface

Internet 192.168.1.1 - 0014.f2e2.61c7 ARPA BVI1

Router#sh vlan-s

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0, Fa1, Fa2, Fa3

1002 fddi-default active

1003 token-ring-default active

1004 fddinet-default active

1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1 enet 100001 1500 - - - - - 1002 1003

1002 fddi 101002 1500 - - - - - 1 1003

1003 tr 101003 1500 1005 0 - - srb 1 1002

1004 fdnet 101004 1500 - - 1 ibm - 0 0

1005 trnet 101005 1500 - - 1 ibm - 0 0

Router#

If there is anything else you need to know, please tell me, because I'm stuck.

Bronze

Re: C857W proper bridging between vlan and radio interface

Well, well what do you know, apparantly this command "bridge 1 route ip" makes all the difference.

Everything is working as intended.

126
Views
0
Helpful
2
Replies
CreatePlease to create content