Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cable modem to Cisco 2500

Hello,

I am thinking of coming from a cable modem and going to a Cisco 2500, I beleive this should be possible? I am thinking that the 2500 will give out IP addresses since the network I will connect will NOT have a DHCP server.

Does anyone have any advise or experience such as this.

Thanx in advance!

2 REPLIES
Bronze

Re: Cable modem to Cisco 2500

The 2500 will act as a DHCP server for you and should be able to handle your upgrade from DSL without a problem.

Community Member

Re: Cable modem to Cisco 2500

I have this setup at my house. With the exception of the router, I am using a 2600.

I have two Ethernet interfaces faste 0/0 is connected to the cable modem via a cross over cable and faste 0/1 connects up to my home network.

You may want to do a search on NAT on Cisco’s CCO web site.

I believe I have it setup like this.

ip dhcp exclude-address 192.168.101.1 192.168.101.4

!address 1 - 4 reserved for network equipment

ip dhcp pool 101pool

network 192.168.101.0 255.255.255.0

default-router 192.168.101.1

dns-server 208.44.70.1

!Default-router is the ip address of router

!interface connected to home network.

!dns-server is the dns server that you ISP as

!Provided. Get this info from your PC "winipcfg"

Ip address-pool local

!I forget why this is here

Interface FastEthernet0/0

ip address DHCP

ip nat outside

no ip mroute-cache

!FastE 0/0 pulls its address from the ISP

!IP nat inside makes this the interface that does

!the NAT for outgoing data.

interface FastEthernet0/1

ip address 192.168.101.1 255.255.255.0

ip nat inside

!ip nat insides causes the 101 network to be NATed.

ip local pool 101pool 192.168.101.1 192.168.101.254

!sets up DHCP pool 101pool

ip nat pool ovrld 216.228.166.163 216.228.166.163 prefix-length 24

!After the first interface has been configured do a

!sho int to find the ip address.

!There may be another way to do this but this works

!for me. The 216.228.166.163 address is the address

!that was supplied by the ISP via DHCP.

ip nat inside source list 7 pool ovrld overload

!sets up an access list.

access-list 7 permit 192.168.0.0 0.0.255.255

!This is the access list.

223
Views
0
Helpful
2
Replies
CreatePlease to create content