Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cable modems and Routing

I am trying to figure out if I can use a cable modem with my Cisco 3600 series router? My cable modems IP address is dynamic so it can change on me. How can I configure my router to send traffic out a port that might change? I have 6 users on my network and want to implement this router to get practice with it. Any input would be helpful. Thank you.

6 REPLIES
New Member

Re: Cable modems and Routing

I would think that you could install a "default" route to that interface. Ex.- if you connect to the cable modem via EO or S0 then, 0.0.0.0 E0 or 0.0.0.0 S0. Let me know what you find out. I want to do the same config. @ home.

New Member

Re: Cable modems and Routing

You need to have an IOS with the DHCP client capability on it.

I use 12.2(6a) IP Plus feature set (c3620-ik9o3s-mz.122-6a.bin for VPN & firewall as well) and then configure my "internet" ethernet port with a MAC address that my cable company knows about and set it for DHCP.

I've enclosed a portion of my config so that you've got an idea. Good luck...

interface Ethernet0/1

mac-address xxxx.xxxx.xxxx

ip address dhcp

ip access-group 111 in

ip nat outside

no ip mroute-cache

half-duplex

no cdp enable

ip route 0.0.0.0 0.0.0.0 Ethernet0/1

New Member

Re: Cable modems and Routing

I'm using a 1710 Security Access Router but the config will be very similiar to the 3600. I'll assume you have a 3620 w/ 2 ethernet ports one for inside LAN interface and one for the outside cable modem interface. Most cable providers will have limitations of 10mb half duplex on their access so you will need to use either auto or hard code the port for 10mb half (outside interface). My inside interface is a fastethernet port so I use a static config of 100mb full. Since you have a dynamic ip address for your outside interface you need to use "ip address dhcp" command for your e0 or whatever is your outside interface. I have also included an extended access list for inbound entry which includes access for dhcp ports to past to the outside interface. Below is a sample config, just apply your ip addresses internally and you should be set. Good luck.... jw

interface Ethernet0

ip address dhcp

ip access-group 101 in

ip nat outside

half-duplex

!

interface FastEthernet0

ip address 192.168.254.11 255.255.255.0

ip nat inside

speed 100

full-duplex

access-list 1 permit 192.168.254.0 0.0.0.255

access-list 101 permit tcp any any established

access-list 101 permit udp any eq domain any

access-list 101 permit tcp any any eq ftp

access-list 101 permit udp any eq bootps any eq bootps

access-list 101 permit udp any eq bootpc any eq bootpc

access-list 101 permit tcp any any eq ftp-data

New Member

Re: Cable modems and Routing

Don't forget the access-list 101 deny any any statement at the end of your access list. Else all is for naught.

New Member

Re: Cable modems and Routing

I've been following your discussion. I'd really like to know if you tried the default route like ccsn-cnap has pointed out.

It's a really easy concept and I don't see why I should'nt work.

Tell me if you get a chance. Thanks

Dave

New Member

Re: Cable modems and Routing

Actually, both must be implemented.

For Layer 3 connectivity, the router needs an IOS image that supports DHCP (and any other features you require).

Set the public Fa0/0 to use DHCP (you may also need to use the physical-address command to modify your MAC address on that interface).

Be sure to modify any ACLs to permit BOOTP in and out (client and server).

Then for Layer 3 ROUTING purposes, set a default route out to the FA0/0 interface.

Copy run start, power it all off for 60s, and then bring up your DSL modem, then 60s later the router.

200
Views
0
Helpful
6
Replies
CreatePlease login to create content