Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Callback not working with W2K Client

Hi there,

We have a Cisco 3640 with ACS 2.6 running. When a remote user dials in with W95 / W98 the system asks for the number to be called back. After a few seconds the client is called back and the connection is made. So far so good. But when a W2K user is trying to make a connection he is called back, but when verifiyng Username and Password appears on his screen the session times out.

Do you have seen similar problems like this or does anyone know how to configure W2K for this situation?

See below the sw version and config of our router.

Thanks in advance for helping us.

Regards,

Onno Stapper

ECI Telecom BV, The Netherlands.

Cisco Internetwork Operating System Software

IOS (tm) 3600 Software (C3640-I-M), Version 12.1(5)T, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2000 by cisco Systems, Inc.

Compiled Sat 11-Nov-00 01:38 by ccai

Image text-base: 0x60008950, data-base: 0x60A26000

ROM: System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

paardenbloem uptime is 13 weeks, 6 days, 3 hours, 22 minutes

System returned to ROM by power-on

System image file is "flash:c3640-I-MZ.215-T.bin"

cisco 3640 (R4700) processor (revision 0x00) with 26624K/6144K bytes of memory.

Processor board ID 26434243

R4700 CPU at 100Mhz, Implementation 33, Rev 1.0

MICA-6DM Firmware: CP ver 2720 - 5/30/2000, SP ver 2720 - 5/30/2000.

Bridging software.

X.25 software, Version 3.0.0.

Basic Rate ISDN software, Version 1.1.

1 FastEthernet/IEEE 802.3 interface(s)

4 ISDN Basic Rate interface(s)

12 terminal line(s)

DRAM configuration is 64 bits wide with parity disabled.

125K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Current configuration : 3444 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname testrouter

!

logging rate-limit console 10 except errors

aaa new-model

aaa authentication login default group tacacs+

aaa authentication login no_tacacs enable

aaa authentication login admins group tacacs+ local

aaa authentication enable default group tacacs+ enable

aaa authentication ppp default group tacacs+

aaa authorization exec default group tacacs+

aaa authorization network default group tacacs+

aaa accounting exec default start-stop group tacacs+

aaa accounting network default start-stop group tacacs+

enable secret <truncated>

enable password <truncated>

!

username Woerden-2 password <truncated>

memory-size iomem 20

modem country mica netherlands

ip subnet-zero

!

!

no ip finger

ip domain-name <truncated>

ip name-server 192.4.172.21

!

ip dhcp-server 192.4.172.45

isdn switch-type basic-net3

isdn voice-call-failure 0

!

!

!

interface FastEthernet0/0

description connected to EthernetLAN_1

ip address 192.4.172.251 255.255.255.0

speed 100

full-duplex

!

interface BRI3/0

description Dial in

no ip address

encapsulation ppp

ip tcp header-compression passive

dialer rotary-group 1

isdn switch-type basic-net3

isdn incoming-voice modem

no cdp enable

ppp authentication chap callin

!

interface BRI3/1

description Dial in

no ip address

encapsulation ppp

ip tcp header-compression passive

dialer rotary-group 1

isdn switch-type basic-net3

isdn incoming-voice modem

no cdp enable

ppp authentication chap callin

!

interface BRI3/2

description Dial in

no ip address

encapsulation ppp

ip tcp header-compression passive

dialer rotary-group 1

isdn switch-type basic-net3

isdn incoming-voice modem

no cdp enable

ppp authentication chap callin

!

interface BRI3/3

description Dial in

no ip address

encapsulation ppp

ip tcp header-compression passive

dialer rotary-group 1

isdn switch-type basic-net3

isdn incoming-voice modem

no cdp enable

ppp authentication chap callin

!

interface Group-Async1

ip unnumbered FastEthernet0/0

encapsulation ppp

ip tcp header-compression passive

no ip mroute-cache

dialer in-band

dialer idle-timeout 3600

async mode interactive

peer default ip address dhcp

ppp callback accept

ppp authentication chap pap

group-range 65 76

!

interface Dialer1

description Dial in

ip unnumbered FastEthernet0/0

encapsulation ppp

no ip split-horizon

ip tcp header-compression passive

no ip mroute-cache

dialer in-band

dialer idle-timeout 600

dialer enable-timeout 10

dialer-group 1

autodetect encapsulation ppp

peer default ip address dhcp

no cdp enable

ppp callback accept

ppp authentication chap callin

ppp multilink

!

ip classless

ip route 192.168.0.0 255.255.255.0 192.4.172.254

ip route 192.168.4.0 255.255.255.0 192.4.172.254 2

no ip http server

!

access-list 1 permit 192.4.172.0 0.0.0.255

dialer-list 1 protocol ip permit

tacacs-server host 192.4.172.252 single-connection

tacacs-server key <truncated>

snmp-server community public RO

!

line con 0

exec-timeout 0 0

login authentication admins

transport input none

line 65 76

autoselect during-login

autoselect ppp

modem InOut

modem autoconfigure discovery

rotary 1

transport input all

line aux 0

line vty 0 4

login authentication admins

!

end

  • Other Network Infrastructure Subjects
5 REPLIES
Cisco Employee

Re: Callback not working with W2K Client

Callback with Win2K is little odd. Here is the place which discuss that in detail about the config of Access SErver along with the Win2K/NT client.

http://www.cisco.com/warp/public/793/access_dial/async_ppp.html

Thx..Tejal

New Member

Re: Callback not working with W2K Client

Thanks for your reply. We already have configured ththe w2k client this way. Still the authentication fails. I think it has something to do with MS-Chap2. I will try to sort it out the next few days. If anyone has Ideas...., they are welcome.

Onno

Cisco Employee

Re: Callback not working with W2K Client

Need to see ppp, aaa, modem and callback debugs.

~Zulfi

New Member

Re: Callback not working with W2K Client

Hi Zulfi,

Thanks for your response. I did some debugging. here it comes.

deb ppp authen

PPP authentication debugging is on

paardenbloem#deb ppp error

PPP protocol errors debugging is on

paardenbloem#deb ppp nego

PPP protocol negotiation debugging is on

paardenbloem#deb callback

Callback activity debugging is on

paardenbloem#deb aaa author

AAA Authorization debugging is on

paardenbloem#deb aaa authen

AAA Authentication debugging is on

paardenbloem#deb isdn q931

ISDN Q931 packets debugging is on

paardenbloem#

=========> dialin session starts here <===========

14w1d: ISDN Event: dsl 24 call_id 0x80E9 B channel assigned by switch 1

ISDN Event: dsl 24 call_id 0x8102 B channel assigned by switch 1

ISDN BR3/0: RX <- SETUP pd = 8 callref = 0x0F

14w1d: Sending Complete

14w1d: Bearer Capability i = 0x8890

14w1d: Channel ID i = 0x81

14w1d: Calling Party Number i = 0x2183, '348576611', Plan:ISDN, Type:National

14w1d: Called Party Number i = 0xA1, '725710177', Plan:ISDN, Type:National

14w1d: ISDN BR3/0: Event: Received a DATA call from 348576611 on B1 at 64 Kb/s

14w1d: ISDN BR3/0: Event: Accepting the call id 0x45D

14w1d: %LINK-3-UPDOWN: Interface BRI3/0:1, changed state to up

14w1d: ISDN BR3/0: TX -> CALL_PROC pd = 8 callref = 0x8F

14w1d: Channel ID i = 0x89

14w1d: ISDN BR3/0: TX -> CONNECT pd = 8 callref = 0x8F

14w1d: ISDN BR3/0: RX <- CONNECT_ACK pd = 8 callref = 0x0F

14w1d: BR3/0:1 PPP: Treating connection as a callin

14w1d: BR3/0:1 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 0 load]

14w1d: BR3/0:1 LCP: State is Listen

14w1d: BR3/0:1 LCP: I CONFREQ [Listen] id 0 len 44

14w1d: BR3/0:1 LCP: MagicNumber 0x46255735 (0x050646255735)

14w1d: BR3/0:1 LCP: PFC (0x0702)

14w1d: BR3/0:1 LCP: ACFC (0x0802)

14w1d: BR3/0:1 LCP: Callback 6 (0x0D0306)

14w1d: BR3/0:1 LCP: MRRU 1614 (0x1104064E)

14w1d: BR3/0:1 LCP: EndpointDisc 1 Local

14w1d: BR3/0:1 LCP: (0x13170160A145F4D24145F99494969AC3)

14w1d: BR3/0:1 LCP: (0x34C2CA00000000)

14w1d: BR3/0:1 AAA/AUTHOR/FSM: (0): LCP succeeds trivially

14w1d: BR3/0:1 LCP: O CONFREQ [Listen] id 190 len 34

14w1d: BR3/0:1 LCP: AuthProto CHAP (0x0305C22305)

14w1d: BR3/0:1 LCP: MagicNumber 0x0529FC72 (0x05060529FC72)

14w1d: BR3/0:1 LCP: MRRU 1524 (0x110405F4)

14w1d: BR3/0:1 LCP: EndpointDisc 1 Local (0x130F017061617264656E626C6F656D)

14w1d: BR3/0:1 LCP: O CONFACK [Listen] id 0 len 44

14w1d: BR3/0:1 LCP: MagicNumber 0x46255735 (0x050646255735)

14w1d: BR3/0:1 LCP: PFC (0x0702)

14w1d: BR3/0:1 LCP: ACFC (0x0802)

14w1d: BR3/0:1 LCP: Callback 6 (0x0D0306)

14w1d: BR3/0:1 LCP: MRRU 1614 (0x1104064E)

14w1d: BR3/0:1 LCP: EndpointDisc 1 Local

14w1d: BR3/0:1 LCP: (0x13170160A145F4D24145F99494969AC3)

14w1d: BR3/0:1 LCP: (0x34C2CA00000000)

14w1d: BR3/0:1 LCP: I CONFACK [ACKsent] id 190 len 34

14w1d: BR3/0:1 LCP: AuthProto CHAP (0x0305C22305)

14w1d: BR3/0:1 LCP: MagicNumber 0x0529FC72 (0x05060529FC72)

14w1d: BR3/0:1 LCP: MRRU 1524 (0x110405F4)

14w1d: BR3/0:1 LCP: EndpointDisc 1 Local (0x130F017061617264656E626C6F656D)

14w1d: BR3/0:1 LCP: State is Open

14w1d: BR3/0:1 PPP: Phase is AUTHENTICATING, by this end [0 sess, 1 load]

14w1d: BR3/0:1 CHAP: O CHALLENGE id 110 len 33 from "paardenbloem"

14w1d: BR3/0:1 LCP: I IDENTIFY [Open] id 1 len 18 magic 0x46255735 MSRASV5.00

14w1d: BR3/0:1 LCP: I IDENTIFY [Open] id 2 len 24 magic 0x46255735 MSRAS-1-NB-SJAAK

14w1d: BR3/0:1 CHAP: I RESPONSE id 110 len 32 from "ecitelecom1"

14w1d: AAA: parse name=BRI3/0:1 idb type=14 tty=-1

14w1d: AAA: name=BRI3/0:1 flags=0x55 type=2 shelf=0 slot=3 adapter=0 port=0 channel=1

14w1d: AAA: parse name= idb type=-1 tty=-1

14w1d: AAA/MEMORY: create_user (0x61687D10) user='ecitelecom1' ruser='' port='BRI3/0:1' rem_addr='348576611/725710177' authen_type=CHAP service=PPP priv=1

14w1d: AAA/AUTHEN/START (375551868): port='BRI3/0:1' list='' action=LOGIN service=PPP

14w1d: AAA/AUTHEN/START (375551868): using "default" list

14w1d: AAA/AUTHEN/START (375551868): Method=tacacs+ (tacacs+)

14w1d: TAC+: send AUTHEN/START packet ver=193 id=375551868

14w1d: TAC+: ver=193 id=375551868 received AUTHEN status = PASS

14w1d: AAA/AUTHEN (375551868): status = PASS

14w1d: BR3/0:1 AAA/AUTHOR/LCP: Authorize LCP

14w1d: BR3/0:1 AAA/AUTHOR/LCP (2335509153): Port='BRI3/0:1' list='' service=NET

14w1d: AAA/AUTHOR/LCP: BR3/0:1 (2335509153) user='ecitelecom1'

14w1d: BR3/0:1 AAA/AUTHOR/LCP (2335509153): send AV service=ppp

14w1d: BR3/0:1 AAA/AUTHOR/LCP (2335509153): send AV protocol=lcp

14w1d: BR3/0:1 AAA/AUTHOR/LCP (2335509153): found list "default"

14w1d: BR3/0:1 AAA/AUTHOR/LCP (2335509153): Method=tacacs+ (tacacs+)

14w1d: AAA/AUTHOR/TAC+: (2335509153): user=ecitelecom1

14w1d: AAA/AUTHOR/TAC+: (2335509153): send AV service=ppp

14w1d: AAA/AUTHOR/TAC+: (2335509153): send AV protocol=lcp

14w1d: TAC+: (2335509153): received author response status = PASS_ADD

14w1d: BR3/0:1 AAA/AUTHOR (2335509153): Post authorization status = PASS_ADD

14w1d: BR3/0:1 AAA/AUTHOR/LCP: Processing AV service=ppp

14w1d: BR3/0:1 AAA/AUTHOR/LCP: Processing AV protocol=lcp

14w1d: BR3/0:1 AAA/AUTHOR/LCP: Processing AV callback-dialstring=

14w1d: BR3/0:1 CHAP: O SUCCESS id 110 len 4

14w1d: BR3/0:1 MCB: User ecitelecom1 Callback Number - Client ANY

14w1d: BRI3/0:1 PPP: O MCB Request(1) id 64 len 9

14w1d: BRI3/0:1 MCB: O 1 40 0 9 2 5 0 1 0

14w1d: BR3/0:1 MCB: O Request Id 64 Callback Type Client-Num delay 0

14w1d: BR3/0:1 PPP: Phase is CBCP [0 sess, 1 load]

14w1d: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI3/0:1, changed state to up

14w1d: BR3/0:1 MCB: Timeout in state WAIT_RESPONSE

14w1d: BRI3/0:1 PPP: O MCB Request(1) id 65 len 9

14w1d: BRI3/0:1 MCB: O 1 41 0 9 2 5 0 1 0

14w1d: BR3/0:1 MCB: O Request Id 65 Callback Type Client-Num delay 0

14w1d: BR3/0:1 MCB: Timeout in state WAIT_RESPONSE

14w1d: BRI3/0:1 PPP: O MCB Request(1) id 66 len 9

14w1d: BRI3/0:1 MCB: O 1 42 0 9 2 5 0 1 0

14w1d: BR3/0:1 MCB: O Request Id 66 Callback Type Client-Num delay 0

14w1d: BRI3/0:1 PPP: I MCB Response(2) id 66 len 19

14w1d: BRI3/0:1 MCB: I 2 42 0 13 2 F A 1 30 33 34 38 35 37 36 37 36 32 0

14w1d: BR3/0:1 MCB: Received response

14w1d: BR3/0:1 MCB: Response CBK-Client-Num 2 15 10, addr 1-0348576762

14w1d: BRI3/0:1 PPP: O MCB Ack(3) id 67 len 19

14w1d: BRI3/0:1 MCB: O 3 43 0 13 2 F A 1 30 33 34 38 35 37 36 37 36 32 0

14w1d: BR3/0:1 MCB: O Ack Id 67 Callback Type Client-Num delay 10

14w1d: BR3/0:1 MCB: Negotiated MCB with peer

14w1d: BR3/0:1 LCP: I TERMREQ [Open] id 3 len 16 (0x46255735003CCD7400000000)

14w1d: BR3/0:1 LCP: O TERMACK [Open] id 3 len 4

14w1d: BR3/0:1 MCB: Peer terminating the link

14w1d: BR3/0:1 MCB: Link terminated by peer, Callback Needed

14w1d: BR3/0:1 MCB: Initiate Callback for ecitelecom1 at 0348576762 using ISDN DDR

14w1d: AAA/MEMORY: dup_user (0x6144D110) user='ecitelecom1' ruser='' port='BRI3/0:1' rem_addr='348576611/725710177' authen_type=CHAP service=PPP priv=1 source='create callback'

14w1d: BR3/0:1 PPP: Phase is TERMINATING [0 sess, 1 load]

14w1d: %ISDN-6-CONNECT: Interface BRI3/0:1 is now connected to 348576611 ecitelecom1

14w1d: ISDN BR3/0: RX <- DISCONNECT pd = 8 callref = 0x0F

14w1d: Cause i = 0x8090 - Normal call clearing

14w1d: %ISDN-6-DISCONNECT: Interface BRI3/0:1 disconnected from 348576611 ecitelecom1, call lasted 6 seconds

14w1d: %LINK-3-UPDOWN: Interface BRI3/0:1, changed state to down

14w1d: BR3/0:1 LCP: State is Closed

14w1d: BR3/0:1 PPP: Phase is DOWN [0 sess, 1 load]

14w1d: ISDN BR3/0: TX -> RELEASE pd = 8 callref = 0x8F

14w1d: Cause i = 0x8090 - Normal call clearing

14w1d: AAA/MEMORY: free_user (0x61687D10) user='ecitelecom1' ruser='' port='BRI3/0:1' rem_addr='348576611/725710177' authen_type=CHAP service=PPP priv=1

14w1d: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI3/0:1, changed state to down

14w1d: ISDN BR3/0: RX <- RELEASE_COMP pd = 8 callref = 0x0F

14w1d: Cause i = 0x8090 - Normal call clearing

14w1d: ISDN BR3/0: TX -> SETUP pd = 8 callref = 0x30

14w1d: Bearer Capability i = 0x8890

14w1d: Channel ID i = 0x83

14w1d: Called Party Number i = 0x80, '0348576762', Plan:Unknown, Type:Unknown

14w1d: ISDN BR3/0: RX <- CALL_PROC pd = 8 callref = 0xB0

14w1d: Channel ID i = 0x89

14w1d: ISDN BR3/0: RX <- ALERTING pd = 8 callref = 0xB0

14w1d: ISDN BR3/0: RX <- CONNECT pd = 8 callref = 0xB0

14w1d: Date/Time i = 0x0206050B1E14

14w1d: Connected Number i = 0x2183333438353736363131

14w1d: ISDN BR3/0: HOST_CONNECT: VOICE ERROR: NULL VDEV Common(0xFC): bchan 0, call id 0x8234

14w1d: ISDN BR3/0: TX -> CONNECT_ACK pd = 8 callref = 0x30

14w1d: AAA/MEMORY: free_user (0x6144D110) user='ecitelecom1' ruser='' port='BRI3/0:1' rem_addr='348576611/725710177' authen_type=CHAP service=PPP priv=1

14w1d: ISDN BR3/0: TX -> DISCONNECT pd = 8 callref = 0x30

14w1d: Cause i = 0x8090 - Normal call clearing

14w1d: ISDN BR3/0: RX <- RELEASE pd = 8 callref = 0xB0

14w1d: Cause i = 0x8090 - Normal call clearing

14w1d: ISDN BR3/0: TX -> RELEASE_COMP pd = 8 callref = 0x30

The W2K prof client is reporting after the RAS is calling back: :"Verifiying username and password." After a while the message :"error 629: The connection was closed by the remote computer". We have tried thsi with user specified callback number and with Alway call me back at this number in the w2k dialup advanced config.

Regards,

Onno

New Member

Re: Callback not working with W2K Client

Hi All out there,

I Have Asked Cisco TAC for assistance. If there is a solution I will add it here.

Regards,

Onno

192
Views
0
Helpful
5
Replies
This widget could not be displayed.