Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CallBack Problem: Message: Callback not authorized for this user

Hi,,, I have problems with de Callback process.

The debug ppp cbcp show the messages:

01:24:40: As70 MCB: Initialize

01:24:40: As70 MCB: Flush

01:24:40: As70 MCB: Start

01:24:40: As70 MCB: Callback not authorized for this user ale

01:24:40: As70 MCB: Newstate 0-INIT -> 2-WAIT_RESPONSE

01:24:40: As70 MCB: O Request Id 3 Callback Type None

01:24:40: Async70 PPP: I MCB Response(2) id 3 len 6

01:24:40: Async70 MCB: I 2 3 0 6 1 2

01:24:40: As70 MCB: Received response

01:24:40: As70 MCB: Response CBK-None 1 2

01:24:40: As70 MCB: O Ack Id 4 Callback Type None

01:24:40: As70 MCB: No Callback negotiated; Exit

01:24:40: As70 MCB: Flush

Any Idea ???

This is the config of the router :

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname kapucci

!

logging buffered 4096 debugging

aaa new-model

aaa authentication login default local group tacacs+

aaa authentication login consoleport none

aaa authentication ppp default if-needed local group tacacs+

aaa authorization network default if-authenticated local group tacacs+

aaa authorization network isdn none

aaa accounting nested

aaa accounting network default start-stop group tacacs+

aaa session-id common

!

username ale callback-dialstring 3463 password xxx

ip subnet-zero

no ip source-route

!

!

ip domain-name x.x.x.x

ip name-server x.x.x.x

!

async-bootp nbns-server x.x.x.x

isdn switch-type primary-net5

chat-script offhook "" "ATH1" OK

chat-script name ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 3

\c

modemcap entry mica1:MSC=&F&D2S34=18000S40=10S54=172S53=0

fax interface-type fax-mail

mta receive maximum-recipients 0

!

interface Loopback0

no ip address

!

interface FastEthernet0/0

ip address x.x.x.x 255.255.255.0

ip nat inside

duplex auto

interface Group-Async0

ip unnumbered FastEthernet0/0

ip access-group socios in

encapsulation ppp

no ip mroute-cache

no logging event link-status

async mode interactive

peer default ip address pool ippool

no fair-queue

ppp authentication chap pap

group-range 65 69

!

interface Group-Async1

ip unnumbered FastEthernet0/0

encapsulation ppp

ip tcp header-compression passive

no ip mroute-cache

no logging event link-status

async mode interactive

peer default ip address pool ippool2

no fair-queue

ppp callback accept

ppp authentication pap chap

group-range 70 80

!

ip local pool ippool2 z.z.z.z z.z.z.z

ip local pool ippool z.z.z.z z.z.z.z

call rsvp-sync

!

no mgcp timer receive-rtcp

!

mgcp profile default

!

dial-peer cor custom

line con 0

logging synchronous

transport output none

line 65 80

exec-timeout 5 0

script modem-off-hook offhook

script callback name

modem InOut

modem autoconfigure type mica1

transport input all

transport output lat pad v120 lapb-ta telnet rlogin udptn

autoselect during-login

autoselect ppp

stopbits 1

line aux 0

line vty 0 4

1 REPLY
New Member

Re: CallBack Problem: Message: Callback not authorized for this

OK,,, I found then problem:

the AAA config:

aaa authorization network default if-authenticated local group tacacs+

The problem is the word "if-authenticated" because this doesn't work with Callback.

I change the config for:

aaa authorization network default local group tacacs+ and the Callback work fine.

Thanks all.

Regards....

288
Views
5
Helpful
1
Replies
CreatePlease login to create content