Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Callback stopped working

I am facing typical problem with callback.On one of client callback was working fine but the day they asked telephone exchange (India) to enable Caller ID facility on their telephone line ,it stopped working .It is like this- first user get verified and then disconnects and then callback happens and will ask for callback number ,then router callback too .Uptill here everything is fine,but once handshaking is happening ,modem gets disconnected.

Do i need to set something extra on router?

Note: Same client works fine with telephone line without Called ID facility.

thanks

5 REPLIES

Re: Callback stopped working

Hope u can get the outputs of debug isdn q931 and debug ppp negotiation for further troubleshooting.

New Member

Re: Callback stopped working

module on router 2610 is NM-16AM. Its normal telephone line not an ISDN line.

Cisco Employee

Re: Callback stopped working

There will be no effect of callerID on a router 2610. I think 2610 may have been configured for Async PPP callback.

So we need to know running config from 2610 and with following debug when call comes in to that and 2610 callback

debug dialer

debug modem

debug callback

debug chat

Here is the url for sample config for async callback

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/dialns_c/dnsprt2/dcdascal.htm

New Member

Re: Callback stopped working

Running-config

******************************

rtr-2600#sh run

Building configuration...

Current configuration:

!

! Last configuration change at 13:34:20 UTC Sat Apr 5 2003 by

! NVRAM config last updated at 10:41:10 UTC Thu Apr 3 2003 by

!

version 12.0

service exec-callback

service timestamps debug datetime

service timestamps log datetime

service password-encryption

!

hostname rtr-2600

!

logging buffered 4096 debugging

aaa new-model

aaa authentication login default local

aaa authentication ppp default if-needed local

aaa authorization network default local

enable secret 5 xxxx

enable password 7 xxxxx

!

username min password 7 xxxx

username max callback-dialstring "" password xxxx

ip subnet-zero

ip domain-name

ip name-server 172.17.0.45

ip name-server 172.17.0.2

async-bootp dns-server 172.17.0.45 172.17.0.2

async-bootp nbns-server 172.17.0.2

chat-script mod ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 30 CONNECT \c

chat-script offhook "" "ATH1" OK \c

!

!

!

interface Ethernet0/0

description ######### THIS IS CONNECTED TO LAN #######

ip address 172.17.1.10 255.255.252.0

no ip directed-broadcast

!

interface Group-Async1

description ##### THIS IS FOR DIAL-UP ########

bandwidth 1024

ip unnumbered Ethernet0/0

no ip directed-broadcast

encapsulation ppp

async default routing

async mode interactive

peer default ip address pool addr-pool

no cdp enable

ppp callback accept

ppp authentication chap pap

group-range 33 48

!

ip local pool addr-pool 192.168.25.1 192.168.25.25

ip classless

ip route 0.0.0.0 0.0.0.0 172.17.1.110

ip route 172.17.4.0 255.255.252.0 172.17.3.254

ip http server

!

logging trap debugging

logging 172.17.0.10

access-list 1 permit any

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

snmp-server community xxxx RO

snmp-server community xxxx RW

!

line con 0

exec-timeout 0 0

transport input none

line 33 48

no flush-at-activation

autoselect during-login

autoselect ppp

script modem-off-hook offhook

script callback mod

modem InOut

transport input all

line aux 0

line vty 0 4

password 7 xxxxx

!

ntp master

end

rtr-2600#

****************************************************

Debug is

************************

Apr 5 13:53:11: Modem 1/0 Mcom: in modem state 'Dialing/Answering'

Apr 5 13:53:11: Modem 1/0 Mcom: in modem state 'Incoming ring'

Apr 5 13:53:12: Modem 1/0 Mcom: in modem state 'Incoming ring'

Apr 5 13:53:14: Modem 1/0 Mcom: in modem state 'Waiting for Carrier'

Apr 5 13:53:25: Modem 1/0 Mcom: Received unknown message 0x10, len=0

Apr 5 13:53:25: Modem 1/0 Mcom: in modem state 'Connected'

Apr 5 13:53:25: Modem 1/0 Mcom: CONNECT at 24000/26400(Tx/Rx), V34, LAPM, V42bis, Answer

Apr 5 13:53:25: TTY33: DSR came up

Apr 5 13:53:25: tty33: Modem: IDLE->READY

Apr 5 13:53:25: TTY33: EXEC creation

Apr 5 13:53:25: TTY33: set timer type 10, 30 seconds

Apr 5 13:53:26: TTY33: Autoselect(2) sample 7E

Apr 5 13:53:26: TTY33: Autoselect(2) sample 7EFF

Apr 5 13:53:26: TTY33: Autoselect(2) sample 7EFF7D

Apr 5 13:53:26: TTY33: Autoselect(2) sample 7EFF7D23

Apr 5 13:53:26: TTY33 Autoselect cmd: ppp negotiate

Apr 5 13:53:26: TTY33: EXEC creation

Apr 5 13:53:26: TTY33: create timer type 1, 600 seconds

Apr 5 13:53:26: TTY33: destroy timer type 1 (OK)

Apr 5 13:53:26: TTY33: destroy timer type 0

Apr 5 13:53:26: Modem 1/0 Mcom: switching to PPP mode

Apr 5 13:53:26: Modem 1/0 Mcom: PPP escape map: Tx map = FFFFFFFF, Rx map = 0

Apr 5 13:53:26: %LINK-3-UPDOWN: Interface Async33, changed state to up

Apr 5 13:53:28: Modem 1/0 Mcom: PPP escape map: Tx map = A0000, Rx map = 0

Apr 5 13:53:29: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async33, changed state to up

Apr 5 13:53:36: TTY33 Callback user dialstring 25784 from PPP negotiation

Apr 5 13:53:36: TTY33 Callback PPP process creation

Apr 5 13:53:36: As33 AAA/ACCT: Using PPP accounting list ""

Apr 5 13:53:36: TTY33 Callback process initiated, user: dialstring 25784

Apr 5 13:53:37: Modem 1/0 Mcom: in modem state 'Disconnecting'

Apr 5 13:53:37: Modem 1/0 Mcom: DISCONNECT, duration = 00:00:13, reason (0xE) Remote Link Disc

Apr 5 13:53:37: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async33, changed state to down

Apr 5 13:53:37: TTY33: Async Int reset: Dropping DTR

Apr 5 13:53:38: Modem 1/0 Mcom: in modem state 'Idle'

Apr 5 13:53:38: Modem 1/0 Mcom: PPP escape map: Tx map = FFFFFFFF, Rx map = 0

Apr 5 13:53:39: %LINK-5-CHANGED: Interface Async33, changed state to reset

Apr 5 13:53:42: Modem 1/0 Mcom: switching to character mode

Apr 5 13:53:42: TTY33 Callback forced wait = 4 seconds

Apr 5 13:53:44: %LINK-3-UPDOWN: Interface Async33, changed state to down

Apr 5 13:53:46: CHAT33: Matched chat script offhook to string offhook

Apr 5 13:53:46: CHAT33: Asserting DTR

Apr 5 13:53:46: CHAT33: Chat script offhook started

Apr 5 13:53:46: CHAT33: Sending string: ATH1

Apr 5 13:53:46: CHAT33: Expecting string: OK

Apr 5 13:53:47: CHAT33: Completed match for expect: OK

Apr 5 13:53:47: CHAT33: Sending string: \c

Apr 5 13:53:47: CHAT33: Chat script offhook finished, status = Success

Apr 5 13:53:47: CHAT33: Matched chat script mod to string mod

Apr 5 13:53:47: CHAT33: Asserting DTR

Apr 5 13:53:47: CHAT33: Chat script mod started

Apr 5 13:53:47: CHAT33: Sending string: AT

Apr 5 13:53:47: CHAT33: Expecting string: OK

Apr 5 13:53:47: CHAT33: Completed match for expect: OK

Apr 5 13:53:47: CHAT33: Sending string: ATDT \T<25784>

Apr 5 13:53:47: CHAT33: Expecting string: CONNECT

Apr 5 13:53:47: Modem 1/0 Mcom: in modem state 'Dialing/Answering'

Apr 5 13:54:04: Modem 1/0 Mcom: in modem state 'Waiting for Carrier'

Apr 5 13:54:17: CHAT33: Timeout expecting: CONNECT

Apr 5 13:54:17: CHAT33: Chat script mod finished, status = Connection timed out; remote host not responding

Apr 5 13:54:17: TTY33 Callback process chat script fail status=Connection timed out; remote host not responding

Apr 5 13:54:17: TTY33: Line reset by "Callback Process"

Apr 5 13:54:17: TTY33: Modem: READY->HANGUP

Apr 5 13:54:17: TTY33: destroy timer type 0

Apr 5 13:54:17: TTY33: destroy timer type 1

Apr 5 13:54:17: TTY33: destroy timer type 3

Apr 5 13:54:17: TTY33: destroy timer type 4

Apr 5 13:54:17: TTY33: destroy timer type 2

Apr 5 13:54:18: TTY33: dropping DTR, hanging up

Apr 5 13:54:18: tty33: Modem: HANGUP->IDLE

Apr 5 13:54:18: Modem 1/0 Mcom: in modem state 'Disconnecting'

Apr 5 13:54:18: Modem 1/0 Mcom: DISCONNECT, duration = 00:00:00, reason (0x9) DTR Drop

Apr 5 13:54:19: Modem 1/0 Mcom: in modem state 'Idle'

Apr 5 13:54:21: TTY33: restoring DTR

New Member

Re: Callback stopped working

if the router's modul can do that??

137
Views
0
Helpful
5
Replies
CreatePlease to create content