cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
483
Views
0
Helpful
8
Replies

Callback to MS client

hsprasetio
Level 1
Level 1

--begin ciscomoderator note-- The following post has been edited to remove potentially confidential information. Please refrain from posting confidential information on the site to reduce security risks to your network. -- end ciscomoderator note --

I have a callback configuration with MS as the client. The router config is as follow:

username cisco callback-dialstring "xxxxxxxxxx" password 0 xxxxxxxxxxx

username nocisco password xxxxxxxxxxxx

memory-size iomem 20

ip subnet-zero

!

!

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 60 CONNECT \c

chat-script offhook "" "ATH1" OK

!

!

!

interface Loopback0

ip address 172.16.1.254 255.255.255.0

!

interface Serial1/0

physical-layer async

ip unnumbered Loopback0

encapsulation ppp

ip tcp header-compression passive

no ip mroute-cache

dialer in-band

dialer-group 1

async mode dedicated

peer default ip address pool MYPOOL

no keepalive

ppp callback accept

ppp authentication chap pap

!

ip local pool MYPOOL 172.16.1.1 172.16.1.10

dialer-list 1 protocol ip permit

!

line 33

flush-at-activation

script modem-off-hook offhook

script callback callback

login local

modem InOut

modem autoconfigure type usr_courier

transport input all

autoselect during-login

autoselect ppp

callback forced-wait 10

stopbits 1

speed 115200

flowcontrol hardware

The IOS is c2600-i-mz.122-15.T5.bin

I also have followed the webpage:

http://www.cisco.com/en/US/partner/tech/tk801/tk36/technologies_configuration_example09186a0080094338.shtml

for MS client and the router configuration.

When I tried it, the client disconnected after the username I used is in the callback status (username cisco callback-dialstring "xxxxxxxx" password 0 xxxxxxxxxxxxx and so does the client wait for the router to dial back to the client, with callback popup notice(MS).

However, the router does not do anything.

Can someone help?

Thanks

2 Accepted Solutions

Accepted Solutions

Well, the router is trying to call back, it starts its chat, sends ATZ, receives OK, sends AT and then nothing...

What puzzles me is that it sends AT instead of ATDT , I don't see why it is doing so.

Can you reverse telnet to the modem and issue ATZ and AT commands? Does it respond OK on the AT?

Alternatively you can run "start-chat callback 34 101"

I'm also thinking that maybe the ATZ makes the modem unresponsive for a moment, so the AT is never received. This could be solved by inserting a pause right before the ATDT like this:

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "\dATDT \T" TIMEOUT 60 CONNECT \c

hth

Herbert

View solution in original post

Do you mean you replaced the modem with another modem from a different make? If so, then possibly your modem autoconfigure line was wrong.

Or do you mean you changed the modem script like I suggested, inserting the \d ?

In that case, you can use the same script for other modems as well, it will just take 2 seconds longer to dial back (\d = 2 sec. pause).

regards

Herbert

View solution in original post

8 Replies 8

hbaerten
Level 4
Level 4

Try:

debug callback

If that does not learn you anything, you can also activate:

debug ppp negotiation

debug modem

debug confmodem

hth

Herbert

Here is my new config and the debugs:

username user callback-dialstring "" password 7

aaa new-model

!

aaa authentication login default local enable

aaa authentication login use-local local

aaa authentication ppp default local

aaa authorization network default local none

aaa session-id common

ip subnet-zero

!

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 60 CONNECT \c

chat-script offhook "" "ATH1" OK

!

interface Loopback0

ip address 172.16.1.254 255.255.255.0

!

interface Serial1/0

physical-layer async

ip unnumbered Loopback0

encapsulation ppp

ip tcp header-compression passive

no ip mroute-cache

dialer in-band

dialer-group 1

async mode dedicated

peer default ip address pool MYPOOL

no keepalive

ppp callback accept

ppp authentication chap pap

!

interface Serial1/1

physical-layer async

no ip address

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer rotary-group 1

dialer-group 1

async mode dedicated

no keepalive

!

interface Dialer1

description connected to DIAL_IN_PCs(modem)

ip unnumbered Loopback0

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer enable-timeout 10

dialer-group 1

peer default ip address pool MYPOOL

no keepalive

no cdp enable

ppp max-bad-auth 3

ppp callback accept

ppp authentication chap pap

!

ip local pool MYPOOL 172.16.1.1 172.16.1.10

dialer-list 1 protocol ip permit

radius-server authorization permit missing Service-Type

!

line 33 34

flush-at-activation

script modem-off-hook offhook

script callback callback

login authentication use-local

modem InOut

modem autoconfigure type usr_courier

no exec

transport input all

autoselect during-login

autoselect ppp

callback forced-wait 10

stopbits 1

speed 115200

flowcontrol hardware

Dallas#debug confmodem

01:11:24: TTY33: detection speed (115200) response ---OK---

01:11:24: TTY33: Done with modem configuration

Dallas#debug dialer

Dallas#debug callback

Dallas#debug ppp cbcp

Dallas#debug ppp nego

Dallas#debug ppp auth

Dallas#debug aaa author

Se1/1 LCP: I CONFREQ [Closed] id 1 len 50

Se1/1 LCP: ACCM 0x00000000 (0x020600000000)

Se1/1 LCP: MagicNumber 0x1CFF7124 (0x05061CFF7124)

Se1/1 LCP: PFC (0x0702)

Se1/1 LCP: ACFC (0x0802)

Se1/1 LCP: Callback 6 (0x0D0306)

Se1/1 LCP: MRRU 1614 (0x1104064E)

Se1/1 LCP: EndpointDisc 1 Local

Se1/1 LCP: (0x1317015809F9D54750415792BF29B069)

Se1/1 LCP: (0x5E441700000000)

Se1/1 LCP: Lower layer not up, Fast Starting

AAA/BIND(00000005): Bind i/f Serial1/1

Se1/1 PPP: Using dialer call direction

Se1/1 PPP: Treating connection as a callin

Se1/1 PPP: Phase is ESTABLISHING, Passive Open

Se1/1 LCP: State is Listen

Se1/1 PPP: Authorization required

Se1/1 LCP: O CONFREQ [Listen] id 5 len 25

Se1/1 LCP: ACCM 0x000A0000 (0x0206000A0000)

Se1/1 LCP: AuthPro

to CHAP (0x0305C22305)

Se1/1 LCP: MagicNumber 0x0483AAD7 (0x05060483AAD7)

Se1/1 LCP: PFC (0x0702)

Se1/1 LCP: ACFC (0x0802)

Se1/1 LCP: O CONFREJ [Listen] id 1 len 8

Se1/1 LCP: MRRU 1614 (0x1104064E)

%LINK-3-UPDOWN: Interface Serial1/1, changed state to up

Se1/1 DDR: Dialer statechange to up

Se1/1 DDR: Dialer received incoming call from

Se1/1 LCP: I CONFACK [REQsent] id 5 len 25

Se1/1 LCP: ACCM 0x000A0000 (0x0206000A0000)

Se1/1 LCP: AuthProto CHAP (0x0305C22305)

Se1/1 LCP: MagicNumber 0x0483AAD7 (0x05060483AAD7)

Se1/1 LCP: PFC (0x0702)

Se1/1 LCP: ACFC (0x0802)

Se1/1 LCP: I CONFREQ [ACKrcvd] id 2 len 46

Se1/1 LCP: ACCM 0x00000000 (0x020600000000)

Se1/1 LCP: MagicNumber 0x1CFF7124 (0x05061CFF7124)

Se1/1 LCP: PFC (0x0702)

Se1/1 LCP: ACFC (0x0802)

Se1/1 LCP: Callback 6 (0x0D0306)

Se1/1 LCP: EndpointDisc 1 Local

Se1/1 LCP: (0x1317015809F9D54750415792BF29B069)

Se1/1 LCP: (0x5E441700000000)

Se1/1 LCP: O CONFACK [ACKrcvd] id 2 len 46

Se1/1 LCP: ACCM 0x00000000 (0x020600000000)

Se1/1 LCP: MagicNumber 0x1CFF7124 (0x05061CFF7124)

Se1/1 LCP: PFC (0x0702)

Se1/1 LCP: ACFC (0x0802)

Se1/1 LCP: Callback 6 (0x0D0306)

Se1/1 LCP: EndpointDisc 1 Local

Se1/1 LCP: (0x1317015809F9D54750415792BF29B069)

Se1/1 LCP: (0x5E441700000000)

Se1/1 LCP: State is Open

Se1/1 PPP: Phase is AUTHENTICATING, by this end

Se1/1 CHAP: O CHALLENGE id 1 len 27 from "Dallas"

Se1/1 LCP: I IDENTIFY [Open] id 3 len 18 magic 0x1CFF7124 MSRASV5.10

Se1/1 LCP: I IDENTIFY [Open] id 4 len 24 magic 0x1CFF7124 MSRAS-1-HENDARTO

Se1/1 CHAP: I RESPONSE id 1 len 25 from "user"

Se1/1 PPP: Phase is FORWARDING, Attempting Forward

Se1/1 PPP: Phase is AUTHENTICATING, Unauthenticated User

Se1/1 PPP: Sent CHAP LOGIN Request

Se1/1 PPP: Received LOGIN Response PASS

Se1/1 PPP/AAA: Check Attr: Framed-Protocol

Se1/1 PPP/AAA: Check Attr: username

Se1/1 PPP/AAA: Check Attr: challenge

Se1/1 PPP/AAA: Check Attr: id

Se1/1 PPP/AAA: Check Attr: response

Se1/1 PPP/AAA: Check Attr: callback-dialstring

Se1/1 PPP: Phase is FORWARDING, Attempting Forward

Se1/1 PPP: Phase is AUTHENTICATING, Authenticated User

Se1/1 DDR: Remote name for user

Se1/1 DDR: Authenticated host user with no matching dialer map

Se1/1 AAA/AUTHOR/LCP: Process Author

Se1/1 AAA/AUTHOR/LCP: Process Attr: callback-dialstring

0 Se1/1 CHAP: O SUCCESS id 1 len 4

Se1/1 MCB: Initialize

MCB: Flush

Se1/1 MCB: Start

Se1/1 MCB: User user Callback Number - Client ANY

Se1/1 MCB: Newstate 0-INIT -> 2-WAIT_RESPONSE

Se1/1 PPP: O MCB Request(1) id 1 len 9

Se1/1 MCB: O 1 1 0 9 2 5 0 1 0

Se1/1 MCB: O Request Id 1 Callback Type Client-Num delay 0

Se1/1 PPP: Phase is CBCP

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to up

Se1/1 MCB: Timeout in state WAIT_RESPONSE sending new Request 2

Se1/1 PPP: O MCB Request(1) id 2 len 9

Se1/1 MCB: O 1 2 0 9 2 5 0 1 0

Se1/1 MCB: O Request Id 2 Callback Type Client-Num delay 0

Se1/1 MCB: Timeout in state WAIT_RESPONSE sending new Request 3

Se1/1 PPP: O MCB Request(1) id 3 len 9

Se1/1 MCB: O 1 3 0 9 2 5 0 1 0

Se1/1 MCB: O Request Id 3 Callback Type Client-Num delay 0

Se1/1 PPP: I MCB Response(2) id 3 len 12

Se1/1 MCB: I 2 3 0 C 2 8 C 1 31 30 37 0

Se1/1 MCB: Received response

Se1/1 MCB: Response CBK-Client-Num 2 8 12, addr 1-107

Se1/1 PPP: O MCB Ack(3) id 3 len 12

Se1/1 MCB: O 3 3 0 C 2 8 C 1 31 30 37 0

Se1/1 MCB: O Ack Id 3 Callback Type Client-Num delay 12

Se1/1 MCB: Negotiated MCB with peer

Se1/1 MCB: Newstate 2-WAIT_RESPONSE -> 3-WAIT_TERMINATE

Se1/1 LCP: I TERMREQ [Open] id 5 len 16 (0x1CFF7124003CCD7400000000)

Se1/1 LCP: O TERMACK [Open] id 5 len 4

Se1/1 MCB: Peer terminating the link

Se1/1 MCB: Newstate 3-WAIT_TERMINATE -> 5-WAIT_LINKDOWN

Se1/1 PPP: Sending Acct Event[Down] id[5]

Se1/1 MCB: Link terminated by peer, Callback Needed

Se1/1 MCB: Newstate 5-WAIT_LINKDOWN -> 6-CALLING

Se1/1 MCB: Initiate Callback for user at 107 using Async DDR

Se1/1 DDR: PPP callback: Callback server starting to user 107

Se1/1 MCB: Dialer callback started

Se1/1 PPP: Phase is TERMINATING

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to down

Se1/1 LCP: TIMEout: State TERMsent

Se1/1 LCP: State is Closed

Se1/1 PPP: Phase is DOWN

Se1/1 PPP: Phase is ESTABLISHING, Passive Open

Se1/1 LCP: State is Listen

%LINK-5-CHANGED: Interface Serial1/1, changed state to reset

Se1/1 LCP: State is Closed

Se1/1 PPP: Phase is DOWN

%LINK-3-UPDOWN: Interface Serial1/1, changed state to down

Se1/1 DDR: re-enable timeout

DDR: Callback timer expired

Di1 DDR: beginning callback to user 107

Se1/1 DDR: rotor dialout [best] least recent failure is also most recent failure

Se1/1 DDR: rotor dialout [best] trying untried dialout

Se1/1 DDR: rotor dialout [best] also has most recent failure

Se1/1 DDR: rotor dialout [best]

Se1/1 DDR: Attempting to dial 107

CHAT34: Attempting async line dialer script

CHAT34: no matching chat script found for 107

CHAT34: Dialing using Modem script: d0efault-d0ials0cript & System script: none

CHAT34: process started

CHAT34: Asserting DTR

CHAT34: Chat script d0efault-d0ials0cript started

CHAT34: Chat script d0efault-d0ials0cript finished, status = Connection timed out; remote host not responding

Se1/1 DDR: disconnecting call

Se1/1 DDR: re-enable timeout

DDR: Freeing callback to user 107

AAA/AUTHOR: config command authorization not enabled

I notice some error regarding chat script (01:41:22: CHAT34: no matching chat script found for 107) and the authorization problem but still I dont understand why.

I tried 2 configs (S1/0 & S1/1 with int dialer),the S1/1 config taken from 19 June 2003 mailing list with heading: MsCallback betw router and winPC, but it still not working. Could you help me with this please. Thanks.

regards,

hendarto

Hi hendarto,

actually this looks all ok, except for the "remote host not responding", so it looks like the router is dialing back allright, but the PC does not answer?

Is 107 the correct number to dial back to?

Can you try again with "debug chat" enabled (I think you can safely disable the other debugs)?

regards,

Herbert

debug chat:

00:14:22: CHAT34: Attempting async line dialer script

00:14:22: CHAT34: no matching chat script found for 101

00:14:22: CHAT34: Dialing using Modem script: d0efault-d0ials0cript & System scr

ipt: none

00:14:22: CHAT34: process started

00:14:22: CHAT34: Asserting DTR

00:14:22: CHAT34: Chat script d0efault-d0ials0cript started

00:14:22: CHAT34: Sending string: ATZ

00:14:22: CHAT34: Expecting string: OK

00:14:23: CHAT34: Completed match for expect: OK

00:14:23: CHAT34: Sending string: AT

00:14:23: CHAT34: Expecting string: OK

Dallas#

00:14:28: CHAT34: Timeout expecting: OK

00:14:28: CHAT34: Chat script d0efault-d0ials0cript finished, status = Connectio

n timed out; remote host not responding

actually I'm using my own PBX, so the number shouldnt be a problem. At this time I'm using 106 for the router and 101 for the PC.

What happen is that the PC dials into the router, authenticated, and the PC disconnects the router.

The PC then stays in "Waiting for Callback" status.

But the router doesnt even make a call. If the router is dialing back like what you said, then the router's modem will be up to dial-in to the PC's modem, is it right? But the router's modem stays quiet.

Well, the router is trying to call back, it starts its chat, sends ATZ, receives OK, sends AT and then nothing...

What puzzles me is that it sends AT instead of ATDT , I don't see why it is doing so.

Can you reverse telnet to the modem and issue ATZ and AT commands? Does it respond OK on the AT?

Alternatively you can run "start-chat callback 34 101"

I'm also thinking that maybe the ATZ makes the modem unresponsive for a moment, so the AT is never received. This could be solved by inserting a pause right before the ATDT like this:

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "\dATDT \T" TIMEOUT 60 CONNECT \c

hth

Herbert

sir,

I changed the modem and it works.

Thank you for your help.

But it stranges though if one modem can but the others cant.

So what actually should I do with the modem so that the modem configuration is the same(standard) with the others?

thanks,

hendarto

Do you mean you replaced the modem with another modem from a different make? If so, then possibly your modem autoconfigure line was wrong.

Or do you mean you changed the modem script like I suggested, inserting the \d ?

In that case, you can use the same script for other modems as well, it will just take 2 seconds longer to dial back (\d = 2 sec. pause).

regards

Herbert

yes, I replaced the modem from us-robotics courier with hayes. I use us-r for both the PC and the router. As stated in the router config: modem autoconfigure type usr_courier. I believe the modems setting is just not right for the callback but I dont know how to fix the modem problem. I add the \d as you asked but it still does the error.

I tried with NM-16Modem and it do the callback.

So I think the us-r modems need to be tuned for the callback.

regards,

hendarto

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco