Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Callback with Apple Computers

Can anyone help in getting dialup callback working when Macintosh user connect? I've worked my way through "Configuring MS Callback Between a Router and a Windows PC" from the Cisco site and that works fine. When calling via an Apple Mac, after authentication it disconnects (as it should) but the Mac seems to just error and doesn't wait for the pending callback. Debug log indicated "PPP: Callback user did not negotiate LCP Callback". I can't find any documentation regarding the Mac.

I've tryed all the PPP CALLBACK options in the group-async interface config with no luck. I can post debug or config if needed.

Router: Cisco 3620 (running IOS 12)

ISDN PRI interface and NM-12DM (MICA) Modems.

Any help would be good.

1 REPLY
Community Member

Re: Callback with Apple Computers

Current configuration:

!

! Last configuration change at 13:40:39 GMT Tue Mar 16 2004

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname c3620

!

logging buffered 4096 debugging

no logging console

enable secret 5 xxxx

enable password 7 xxxx

!

username test callback-dialstring xxxxxxx password 7 xxxxxxxxx

!

!

!

!

clock timezone GMT 0

modem country mica united-kingdom

no ip subnet-zero

no ip source-route

no ip finger

ip name-server xx.xx.xx.xx

ip name-server xx.xx.xx.xx

!

isdn switch-type primary-net5

isdn voice-call-failure 0

chat-script offhook "" "ATH1" OK

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT60 CONNECT \c

!

!

controller E1 1/0

pri-group timeslots 1-10,16

!

!

!

gateway

!

interface Loopback1

no ip address

no ip directed-broadcast

!

interface FastEthernet1/0

ip address xx.xx.xx.xx 255.255.0.0

no ip directed-broadcast

duplex auto

speed auto

no cdp enable

!

interface Serial1/0:15

no ip address

no ip directed-broadcast

encapsulation ppp

isdn switch-type primary-net5

isdn incoming-voice modem

no fair-queue

no cdp enable

ppp authentication chap

ppp multilink

!

interface Group-Async1

ip unnumbered FastEthernet1/0

no ip directed-broadcast

encapsulation ppp

ip tcp header-compression

dialer in-band

async mode interactive

peer default ip address pool setup_pool

no fair-queue

no cdp enable

ppp callback accept

ppp authentication chap

group-range 1 12

!

ip local pool setup_pool xx.xx.xx.116 xx.xx.xx.125

ip classless

ip route 0.0.0.0 0.0.0.0 xx.xx.xx.xx

no ip http server

!

logging trap debugging

logging facility local6

logging xx.xx.xx.xx

no cdp run

banner exec ^C

*** Wellcome Trust/Cancer Research UK Institute ***

No Unauthorized Access^C

!

line con 0

transport input none

line 1 12

autoselect during-login

autoselect ppp

script modem-off-hook offhook

script callback callback

login local

modem InOut

transport input all

flowcontrol hardware

line aux 0

line vty 0 4

exec-timeout 60 0

password 7 xxxxxxxx

login

!

end

90
Views
0
Helpful
1
Replies
CreatePlease to create content