Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Caller-id on Cisco 803?

I've got a Cisco 803 running IOS version 12.0(7)T3. Everything works fine (DVO @ 128K), with the exception of caller-ID (Australia). I had a look through the Cisco site and found reference to a command called "caller-id alerting ring". This setting can be set to 1 (the default) or 2. The 2 setting is described as follows:

"Use this setting if your telephone service provider specifies it to provide caller ID alerting (display) after the second ring. This setting is used in Australia, where the caller ID information is sent following two short rings (double-pulse ring)."

I suspect this command might be able to fix the caller-ID problem. I tried putting it in my startup-config and it didn't work, but the command history says that the command was integrated into Cisco IOS Release 12.1(3)T. I'm running 12.0(7)T3.

I'm happy to update my IOS to later version, but can anybody tell me whether this will actually fix the problem? That is, does the Cisco 803 support caller ID in Australia? If the answer is yes, then which IOS version should I upgrade to? Can I run 12.3 on a 803? Thanks in advance for your help.

Oh...in case it helps, below is my startup-config:

!

version 12.0(7)T3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname router

!

enable secret ******

!

username ****** password ******

!

dial-peer voice 1 pots

caller-id

caller-id alerting ring 2

no forward-to-unused-port

call-waiting

ring 0

no silent-fax

registered-caller ring 1

port 1

volume 3

destination-pattern 026775xxxx

!

dial-peer voice 2 pots

caller-id

caller-id alerting ring 2

no forward-to-unused-port

call-waiting

ring 0

no silent-fax

registered-caller ring 1

port 2

volume 3

destination-pattern 026775xxxx

!

pots country AU

ip subnet-zero

no ip source-route

!

ip name-server x.x.x.x

ip name-server x.x.x.x

isdn switch-type basic-net3

!

interface Ethernet0

description LAN Interface

ip address 192.168.0.250 255.255.255.0

ip access-group 121 in

no ip proxy-arp

ip nat inside

!

interface BRI0

no ip address

ip nat outside

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

isdn voice-priority 026775xxxx in always

isdn voice-priority 026775xxxx out always

isdn voice-priority 026775xxxx in always

isdn voice-priority 026775xxxx out always

isdn incoming-voice modem

compress mppc

!

interface Dialer1

description ISDN 128k

ip address negotiated

ip access-group 121 in

no ip proxy-arp

ip nat outside

encapsulation ppp

no ip split-horizon

load-interval 30

dialer pool 1

dialer idle-timeout 180

dialer string 0198308888

class DialClass

dialer hold-queue 25

dialer load-threshold 1

either

dialer-group 1

compress mppc

ppp authentication chap pap callin

ppp chap hostname ******

ppp chap password ******

ppp pap sent-username ****** password ******

ppp multilink

!

ip nat inside source list 18 interface Dialer1 overload

ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

map-class dialer DialClass

access-list 10 permit 192.168.0.1

access-list 10 permit 192.168.0.2

access-list 18 permit 192.168.0.0 0.0.0.255

access-list 121 deny udp any eq netbios-dgm any

access-list 121 deny udp any eq netbios-ns any

access-list 121 deny udp any eq netbios-ss any

access-list 121 deny tcp any eq 137 any

access-list 121 deny tcp any eq 138 any

access-list 121 deny tcp any eq 139 any

access-list 121 permit ip any any time-range TIME

dialer-list 1 protocol ip permit

!

line con 0

exec-timeout 120 0

stopbits 1

line vty 0 1

access-class 10 in

exec-timeout 120 0

login local

!

end

1 REPLY
New Member

Re: Caller-id on Cisco 803?

upgrading IOS should help.

91
Views
0
Helpful
1
Replies
CreatePlease to create content