Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Can Bridging and Routing co-exist on the same interface?

--begin ciscomoderator note-- The following post has been edited to remove potentially confidential information. Please refrain from posting confidential information on the site to reduce security risks to your network. -- end ciscomoderator note --

I have 2 2600's connected via a T1 with both interfaces configured for bridging and no ip address.

--moderator edit-- Router1 is routing to the ISP with no problem and bridging to R2 with no ip configuration and working well.

When I put in the ip routing statement and define an ip address on R2, the T1 connection between --moderator edit-- Router1 and R2 drops.

I'm thinking that --moderator edit-- Router1 and R2 bridged interfaces use the BV1 IP so that could conflict???

Following is --moderator edit-- Router1 config:

version 12.2

service timestamps debug uptime

service timestamps log datetime localtime

service password-encryption

!

hostname --moderator edit-- Router1

!

boot system flash c2600-io3-mz.122-12.bin

logging buffered 4096 debugging

no logging rate-limit

logging console warnings

no logging monitor

enable password 7 --moderator edit--

!

clock timezone PST 23

no ip subnet-zero

no ip source-route

ip cef

!

!

ip telnet hidden addresses

ip domain-name xxx.secure.net

ip name-server 192.x.x.x

!

ip audit notify log

ip audit po max-events 100

!

bridge irb

!

!

interface FastEthernet0/0

no ip address

ip broadcast-address 192.168.1.255

ip nat inside

no ip mroute-cache

speed 100

full-duplex

bridge-group 1

!

interface Serial0/0

description To ISP

ip address x.x.x.x 255.255.255.252

ip broadcast-address x.x.x.247

ip nat outside

encapsulation ppp

no ip mroute-cache

!

interface Serial0/1

description Channelized T1-line to R2

no ip address

ip broadcast-address 192.168.100.255

no ip mroute-cache

bridge-group 1

!

interface BVI1

ip address 192.168.1.254 255.255.255.0

ip nat inside

!

ip nat translation timeout 3600

ip nat pool myrouter x.x.x.x x.x.x.40 netmask 255.255.255.224

ip nat inside source list 1 pool myrouter overload

ip nat inside source static 192.168.1.36 x.x.131.41

ip classless

ip route 0.0.0.0 0.0.0.0 12.124.44.245

ip route 0.0.0.0 0.0.0.0 Null0 255

ip route 192.168.1.0 255.255.255.0 192.168.100.2

no ip http server

!

no logging trap

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 12 permit x.133.0.0 0.0.255.255

access-list 12 permit x.191.0.0 0.0.255.255

access-list 51 deny any

access-list 100 deny igmp any any

access-list 100 deny icmp any any redirect

access-list 100 deny icmp any any

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

line aux 0

access-class 51 in

line vty 0 4

access-class 1 in

password 7 --moderator edit--

login

!

end

Following is R2 config:

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname R2

!

boot system flash:c2600-io3-mz.121-5.T.bin

logging rate-limit console 10 except errors

enable secret 5 --moderator edit--

enable password --moderator edit--

!

ip subnet-zero

no ip routing

!

!

no ip finger

!

ip audit notify log

ip audit po max-events 100

!

!

interface Loopback0

ip address 192.168.2.254 255.255.255.0

no ip route-cache

!

interface FastEthernet0/0

no ip address

ip broadcast-address 192.168.1.255

no ip route-cache

no ip mroute-cache

speed 100

full-duplex

bridge-group 1

!

interface Serial0/0

description Link to --moderator edit-- Router1

no ip address

no ip route-cache

no ip mroute-cache

no fair-queue

bridge-group 1

!

interface FastEthernet0/1

no ip address

no ip route-cache

no ip mroute-cache

duplex auto

speed auto

!

ip classless

no ip http server

!

bridge 1 protocol ieee

!

line con 0

transport input none

line aux 0

line vty 0 4

password xxxxxx

login

!

end

1 REPLY
Silver

Re: Can Bridging and Routing co-exist on the same interface?

CRB / IRB enables you to have routing and bridging concurently with routing. You cannot route and bridge the same protocol on the same interface though (e.g. Route IP and Bridge IP). You can route one and bridge another. You can make your Serial 0 a routed port but it would need a unique network and you'd need to readdress your remote router, or you can use the existing network on your BVI and readdress your BVI with something else. Depending on how many things are on the remote site using this address space this might be the easiest approach.

Hope this helps you,

Don

81
Views
0
Helpful
1
Replies
CreatePlease to create content