Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

can not set ethernet port to a specific subnet

Hello,

I have a Cisco 2610 with one ethernet port. I am trying to set an ip address for ethernet0/0 with /25 subnet, but the system returned error. The details are as follow:

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-I-M), Version 11.3(10)T, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-1999 by cisco Systems, Inc.

Compiled Tue 01-Jun-99 17:16 by pwade

Image text-base: 0x80008084, data-base: 0x80566960

ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

System restarted by reload at 13:37:03 utc Mon Dec 8 2003

System image file is "flash:c2600-i-mz.113-10.T", booted via flash

cisco 2610 (MPC860) processor (revision 0x203) with 18432K/6144K bytes of memory

.

Processor board ID JAD03450604 (3853099489)

M860 processor: part number 0, mask 49

Bridging software.

X.25 software, Version 3.0.0.

1 Ethernet/IEEE 802.3 interface(s)

4 Serial(sync/async) network interface(s)

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

hostname(config)#int ethernet0/0

hostname(config-if)#ip address 192.168.100.1 255.255.255.128

Bad mask /25 for address 192.168.100.1

Please let me know how to solve the problem.

Thanks for your help.

thavee

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: can not set ethernet port to a specific subnet

It doesn't allow you to use 192.168.100.1 because it is part of subnet zero (bit 24 is zero). Configure "ip subnet-zero" and it will work.

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
2 REPLIES
Cisco Employee

Re: can not set ethernet port to a specific subnet

It doesn't allow you to use 192.168.100.1 because it is part of subnet zero (bit 24 is zero). Configure "ip subnet-zero" and it will work.

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: can not set ethernet port to a specific subnet

It works. Thank you very much for your help.:-)

thavee

220
Views
0
Helpful
2
Replies
CreatePlease to create content