Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Can't boot C867 from TFTP Server

Hi There,

I have a 867 VAE router that has reported a flash checksum error.

The exact model is reported as C867 VAE K9 256Mb

The  Error message is 

Error : compressed image checksum is incorrect 0x30F65239

        Expected a checksum of 0x30F64E18

I am trying to boot directly to an image stored on my TFTP server to recover the device.  I have read many articles about how to do this and can't see what I'm missing.  When I try and download the image with tftpdnld -r it waits about a minute or so and then reports.

TFTP boot exit: File not found

I have tested my TFTP Server by downloading the file successfully with a tftp client on a windows machine.  Both the router and my TFTP Server are connected to the same LAN segment with straight through cables using a switch not directly connected via a cross over cable.

I have tried both with and without the leading / in the filename.

I have tried the LAN cable connected to GE0 and FE0 with the same result.

I have confirmed that 10.2.2.9 is not in use on my network.

The size of the image file is 35,951,012 bytes

Here is the output of the tftpd command

rommon 18 > tftpdnld -r

IP_ADDRESS: 10.2.2.9
IP_SUBNET_MASK: 255.255.255.0
DEFAULT_GATEWAY: 10.2.2.5
TFTP_SERVER: 10.2.2.66
TFTP_FILE: /c860vae-advsecurityk9-mz.153-3.M9.bin
TFTP_DESTINATION: flash:
DOWNLOAD_PORT: 0 (LAN FE 0..3, LAN GE 4 for ADV K9, WAN GE 5)
TFTP_VERBOSE: Progress

As a background this switch was left switched off on the shelf for a couple of years as it was surplus to requirements.

Now we have a use for it again.  I'm hoping to try and format the flash memory once I get it booted to IOS,  I'll boot from USB if the flash proves unusable.  Any Ideas what I'm doing wrong here?

Thanks in advance

David

Everyone's tags (1)
5 REPLIES
Hall of Fame Super Gold

Error : compressed image

Error : compressed image checksum is incorrect 0x30F65239

        Expected a checksum of 0x30F64E18

Means the IOS file is corrupt.

New Member

Hi Leo,

Hi Leo,

Perhaps I didn't make it clear enough.

The IOS file on my flash is corrupt, I understand that.  That is the problem I'm trying to solve by loading a new image file from a TFTP server.

The file transfer fails with the following message.

TFTP boot exit: File not found.

I can't find anything wrong with the way I'm trying to transfer the file.

Hall of Fame Super Gold

TFTP boot exit: File not

TFTP boot exit: File not found.

The IOS file is NOT found in the TFTP server's directory or the command to upload the file has the incorrect filename.

New Member

Hi Leo,

Hi Leo,

That is a good thought.  I did cut and paste the file name to avoid a typo.

I used the same cut and paste procedure on my windows tftp test client and successfully downloaded the file from the tftp server to the windows workstation.  So the file is definitely  in the root directory on the server and I have the name correct, and it isn't being blocked by a firewall.

I'm wondering what result I would get if the LAN cable on the router is faulty.  I'm not in the same location as the device so it is difficult for me to try doing the transfer with the cable disconnected.  I wonder if I would get Server not found instead of File not found.

David

New Member

For the record,

For the record,

I eventually gave up on the TFTP aproach and copied a system image onto a USB stick. 

Important Safety Tip:  Must be FAT file system. (Not FAT 32)

I booted from the USB stick directly

Saved any files on the internal flash to USB.

Then formatted the internal flash.

Copied the files back again along with the new system image.

Set to boot from the internal flash again.

Reset the system and voompo!  all working again.

I did a verify of my old bin file and it indeed did fail the MD5 test.

I have a hunch the tftp transfer failed because the cable was in FE3 not FE0 but I'm not on site so I can't be sure that changing ports would have solved the problem.

In any case I worked around it and my router is back up again.

Thanks to those who read and commented :)

David

75
Views
0
Helpful
5
Replies
CreatePlease login to create content