Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

can't connect netgateway to isdn

Hi

we have another company trying to connect to us. they use netgateway on aix

This is their config, then follow our config. isdn debug at the end

They dial in and the connection is immediately disconnected.

Any idea

from netgw config

isdn_IMCAM {

DRIVER = ISDN

IPSRC = 192.168.252.1

IPDST = 192.168.100.1

L2 = HDLC

L3 = TRANSPARENT

ENCAPS = "PPP(CHAP,db,noIPA)"

PPP_LOC_ID = "rtsuser"

PPP_LOC_PWD = "******"

KEEPALIVE=30000

SERVICES = eqosports

CALL = "correct number:-)"

LISTEN = "DISABLED"

TIMEOUT = 40

}

to our company imc

Building configuration...

Current configuration:

!

version 11.2

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

no service udp-small-servers

no service tcp-small-servers

!

hostname rasimc

!

enable secret 5

!

username rasuser

username rtsuser password 7 ******

isdn switch-type basic-net3

!

interface Ethernet0

description IMC connection

ip address 192.168.100.1 255.255.255.0

no ip directed-broadcast

!

interface Serial0

no ip address

shutdown

!

interface Serial1

no ip address

shutdown

!

interface BRI0

description Dial in connection

no ip address

no ip directed-broadcast

encapsulation ppp

dialer rotary-group 1

no fair-queue

no cdp enable

!

interface Dialer1

ip unnumbered Ethernet0

no ip directed-broadcast

encapsulation ppp

no ip split-horizon

no peer default ip address

dialer in-band

dialer idle-timeout 3600

dialer caller 206264280

dialer caller 0206264280

dialer caller 4969505034

dialer caller 33144052388

dialer caller 33144052387

dialer caller 33144052386

dialer caller 33144053200

dialer caller 33144056300

dialer caller 0204221999

dialer caller 41417203970

dialer map ip 192.168.100.68 name rtsuser 206264280

dialer map ip 192.168.252.1 name rtsuser 4969505034

dialer map ip 192.168.252.1 name rtsuser 206264280

dialer map ip 172.16.2.254 name rasuser 0204221999

dialer hold-queue 10

dialer load-threshold 10 outbound

dialer-group 1

no fair-queue

no cdp enable

ppp authentication chap pap

!

router eigrp 1

redistribute static

network 192.168.100.0

!

router rip

redistribute static

network 192.168.100.0

!

no ip classless

ip route 172.16.2.0 255.255.255.0 172.16.2.254

ip route 172.16.2.254 255.255.255.255 Dialer1

ip route 192.168.41.0 255.255.255.0 192.168.41.205

ip route 192.168.41.205 255.255.255.255 Dialer1

ip route 192.168.110.0 255.255.255.0 192.168.252.1

ip route 194.99.35.0 255.255.255.0 192.168.252.1

logging buffered warnings

snmp-server community public RO

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

login

!

end

*Mar 15 00:37:52.228 UTC: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up

*Mar 15 00:37:52.664 UTC: BRI0:2: disconnecting call

*Mar 15 00:37:52.668 UTC: ISDN BR0: Event: Hangup call to call id 0x181

*Mar 15 00:37:52.848 UTC: ISDN BR0: received HOST_DISCONNECT_ACK

*Mar 15 00:37:52.856 UTC: %LINK-3-UPDOWN: Interface BRI0:2, changed state to down

*Mar 15 00:37:52.872 UTC: BRI0:2: disconnecting call

*Mar 15 00:37:55.320 UTC: ISDN BR0: Incoming call id = 0x182

*Mar 15 00:37:55.324 UTC: ISDN BR0: received HOST_INCOMING_CALL

*Mar 15 00:37:55.324 UTC: ISDN BR0: Event: Received a call from 206264280 on B1 at 64 Kb/s

*Mar 15 00:37:55.328 UTC: ISDN BR0: Event: Accepting the call

*Mar 15 00:37:55.328 UTC: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

*Mar 15 00:37:55.848 UTC: BRI0:1: disconnecting call

*Mar 15 00:37:55.848 UTC: ISDN BR0: Event: Hangup call to call id 0x182

*Mar 15 00:37:56.048 UTC: ISDN BR0: received HOST_DISCONNECT_ACK

*Mar 15 00:37:56.060 UTC: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

*Mar 15 00:37:56.076 UTC: BRI0:1: disconnecting call

*Mar 15 00:37:58.372 UTC: ISDN BR0: Incoming call id = 0x183

*Mar 15 00:37:58.376 UTC: ISDN BR0: received HOST_INCOMING_CAL

3 REPLIES
Cisco Employee

Re: can't connect netgateway to isdn

We need to see more debug at ppp payer.

so pl. enable following debug on cisco router

debug isdn q931

debug ppp authentication

debug ppp negotiation

debug dialer

term mon

You can post it here or open a tac case via www.cisco.com/tac. Thx..Tejal

New Member

Re: can't connect netgateway to isdn

2d23h: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state to up

2d23h: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 206264280 rts

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 7

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 7

2d23h: BRI0:1: idle timeout

2d23h: BRI0:1: disconnecting call

2d23h: ISDN BR0: Event: Hangup call to call id 0x33

2d23h: %ISDN-6-DISCONNECT: Interface BRI0:1 disconnected from 206264280 rts, call lasted 120 seconds

2d23h: ISDN BR0: TX -> INFOc sapi = 0 tei = 98 ns = 10 nr = 7 i = 0x0801984508028090

2d23h: DISCONNECT pd = 8 callref = 0x98

2d23h: Cause i = 0x8090 - Normal call clearing

2d23h: ISDN BR0: RX <- RRr sapi = 0 tei = 98 nr = 11

2d23h: ISDN BR0: RX <- INFOc sapi = 0 tei = 98 ns = 7 nr = 11 i = 0x0801184D08028090

2d23h: RELEASE pd = 8 callref = 0x18

2d23h: Cause i = 0x8090 - Normal call clearing

2d23h: ISDN BR0: TX -> RRr sapi = 0 tei = 98 nr = 8

2d23h: ISDN BR0: received HOST_DISCONNECT_ACK

2d23h: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

2d23h: BR0:1 IPCP: State is Closed

2d23h: BR0:1 PPP: Phase is TERMINATING

2d23h: BR0:1 LCP: State is Closed

2d23h: BR0:1 PPP: Phase is DOWN

2d23h: BRI0:1: disconnecting call

2d23h: ISDN BR0: TX -> INFOc sapi = 0 tei = 98 ns = 11 nr = 8 i = 0x0801985A

2d23h: RELEASE_COMP pd = 8 callref = 0x98

2d23h: ISDN BR0: RX <- RRr sapi = 0 tei = 98 nr = 12

2d23h: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state to down

2d23h: ISDN BR0: RX <- UI sapi = 0 tei = 127 i = 0x08011905A10402889018018A6C0B2183323036323634323830700AA1323036383933393130

2d23h: SETUP pd = 8 callref = 0x19

2d23h: Sending Complete

2d23h: Bearer Capability i = 0x8890

2d23h: Channel ID i = 0x8A

2d23h: Calling Party Number i = '!', 0x83, '206264280'

2d23h: Called Party Number i = 0xA1, '206893910'

2d23h: ISDN BR0: Incoming call id = 0x34

2d23h: ISDN BR0: received HOST_INCOMING_CALL

2d23h: ISDN BR0: Event: Received a call from 206264280 on B2 at 64 Kb/s

2d23h: ISDN BR0: Event: Accepting the call

2d23h: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up

2d23h: BR0:2 PPP: Treating connection as a callin

2d23h: BR0:2 PPP: Phase is ESTABLISHING, Passive Open

2d23h: BR0:2 LCP: State is Listen

2d23h: ISDN BR0: TX -> INFOc sapi = 0 tei = 98 ns = 12 nr = 8 i = 0x08019907

2d23h: CONNECT pd = 8 callref = 0x99

2d23h: ISDN BR0: RX <- RRr sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: RX <- INFOc sapi = 0 tei = 98 ns = 8 nr = 13 i = 0x0801190F

2d23h: CONNECT_ACK pd = 8 callref = 0x19

2d23h: ISDN BR0: TX -> RRr sapi = 0 tei = 98 nr = 9

2d23h: BR0:2 LCP: I CONFREQ [Listen] id 62 len 12

2d23h: BR0:2 LCP: MRU 2048 (0x01040800)

2d23h: BR0:2 LCP: PFC (0x0702)

2d23h: BR0:2 LCP: ACFC (0x0802)

2d23h: BR0:2 LCP: O CONFREQ [Listen] id 155 len 15

2d23h: BR0:2 LCP: AuthProto CHAP (0x0305C22305)

2d23h: BR0:2 LCP: MagicNumber 0xDF970D32 (0x0506DF970D32)

2d23h: BR0:2 LCP: O CONFACK [Listen] id 62 len 12

2d23h: BR0:2 LCP: MRU 2048 (0x01040800)

2d23h: BR0:2 LCP: PFC (0x0702)

2d23h: BR0:2 LCP: ACFC (0x0802)

2d23h: BR0:2 LCP: I CONFREJ [ACKsent] id 155 len 10

2d23h: BR0:2 LCP: MagicNumber 0xDF970D32 (0x0506DF970D32)

2d23h: BR0:2 LCP: O CONFREQ [ACKsent] id 156 len 9

2d23h: BR0:2 LCP: AuthProto CHAP (0x0305C22305)

2d23h: BR0:2 LCP: I CONFACK [ACKsent] id 156 len 9

2d23h: BR0:2 LCP: AuthProto CHAP (0x0305C22305)

2d23h: BR0:2 LCP: State is Open

2d23h: BR0:2 PPP: Phase is AUTHENTICATING, by this end

2d23h: BR0:2 CHAP: O CHALLENGE id 1 len 32 from "ciscorouter"

2d23h: BR0:2 CHAP: I RESPONSE id 1 len 24 from "rts"

2d23h: BR0:2 CHAP: O SUCCESS id 1 len 4

2d23h: BR0:2 PPP: Phase is UP

2d23h: BR0:2 IPCP: O CONFREQ [Closed] id 35 len 10

2d23h: BR0:2 IPCP: Address 192.168.2.2 (0x0306C0A80202)

2d23h: BR0:2 IPCP: I CONFREQ [REQsent] id 230 len 4

2d23h: BR0:2 IPCP: O CONFACK [REQsent] id 230 len 4

2d23h: BR0:2 IPCP: I CONFREJ [ACKsent] id 35 len 10

2d23h: BR0:2 IPCP: Address 192.168.2.2 (0x0306C0A80202)

2d23h: BR0:2 IPCP: O CONFREQ [ACKsent] id 36 len 4

2d23h: BR0:2 IPCP: I CONFACK [ACKsent] id 36 len 4

2d23h: BR0:2 IPCP: State is Open

2d23h: dialer Protocol up for BR0:2

2d23h: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:2, changed state to up

2d23h: %ISDN-6-CONNECT: Interface BRI0:2 is now connected to 206264280 rts

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: TX -> RRp sapi = 0 tei = 98 nr = 9

2d23h: ISDN BR0: RX <- RRf sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: RX <- RRp sapi = 0 tei = 98 nr = 13

2d23h: ISDN BR0: TX -> RRf sapi = 0 tei = 98 nr = 9

2d23h: BRI0:2: idle timeout

2d23h: BRI0:2: disconnecting call

2d23h: ISDN BR0: Event: Hangup call to call id 0x34

2d23h: %ISDN-6-DISCONNECT: Interface BRI0:2 disconnected from 206264280 rts, call lasted 120 seconds

2d23h: ISDN BR0: TX -> INFOc sapi = 0 tei = 98 ns = 13 nr = 9 i = 0x0801994508028090

2d23h: DISCONNECT pd = 8 callref = 0x99

2d23h: Cause i = 0x8090 - Normal call clearing

2d23h: ISDN BR0: RX <- RRr sapi = 0 tei = 98 nr = 14

2d23h: ISDN BR0: RX <- INFOc sapi = 0 tei = 98 ns = 9 nr = 14 i = 0x0801194D08028090

2d23h: RELEASE pd = 8 callref = 0x19

2d23h: Cause i = 0x8090 - Normal call clearing

2d23h: ISDN BR0: TX -> RRr sapi = 0 tei = 98 nr = 10

2d23h: ISDN BR0: received HOST_DISCONNECT_ACK

Cisco Employee

Re: can't connect netgateway to isdn

The problem is ip address negotiation during IPCP didn't went as it should be. Pl. take a looks here

2d23h: BR0:2 IPCP: O CONFREQ [Closed] id 35 len 10

2d23h: BR0:2 IPCP: Address 192.168.2.2 (0x0306C0A80202)

2d23h: BR0:2 IPCP: I CONFREQ [REQsent] id 230 len 4

2d23h: BR0:2 IPCP: O CONFACK [REQsent] id 230 len 4

2d23h: BR0:2 IPCP: I CONFREJ [ACKsent] id 35 len 10

2d23h: BR0:2 IPCP: Address 192.168.2.2 (0x0306C0A80202)

2d23h: BR0:2 IPCP: O CONFREQ [ACKsent] id 36 len 4

2d23h: BR0:2 IPCP: I CONFACK [ACKsent] id 36 len 4

Cisco router informs the other side about its ip address of bri interface 192.168.2.2 (O CONFREQ)but other side is not informing its ip address(I CONFREQ) and also it rejects the ip of cisco router (I CONFREJ). So i think you need to configure the netgateway router for to perform IPCP.

Now just a thought by looking on the profile on netgateway

IPSRC = 192.168.252.1 <--ip of netwateway ????

IPDST = 192.168.100.1 <--IP of cisco??

If it is then you need IPDEST as 192.168.2.2

199
Views
0
Helpful
3
Replies