Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Can't connect to Win 2000 Domain Controller thru 4006 router via Boot Disk

Our network is segmented by Class C IP regions. We previously had a seperate 2600 series router for each of these regions. We purchased a 4000 series router and set it up to route IPX on all the vlans. We are able to connect to both our Novell server (running IPX) and our 2000 server (running NWlink) using the workstation's Netware and Microsoft clients.

We use Rapid Deploy from Altiris (similar to Ghost) to down load images from our server and multicast them to the other workstations in our microlabs. We use floppy boot disk to connect to the server to start these processes. A DOS level boot up.

The problem is that the boot disks worked fine connecting to the server through the old 2600 series router, but do not connect to the server through the 4006 router.

Our NetWare server is running 4.11. All our servers our in one IP region and our labs are in a couple of other regions.

Any help would be appreciated. Thanks

15 REPLIES
New Member

Re: Can't connect to Win 2000 Domain Controller thru 4006 router

I need some more information.

Are the servers reachable via IPX? and not via IP?

Are the 2600 still in the networks?

Does the floppy use IPX or IP?

New Member

Re: Can't connect to Win 2000 Domain Controller thru 4006 router

They are reachable by both IP and IPX via the Microsoft Client and the Newtware Client on a Windows machine. I can't connect at the DOS level using a floppy diskette.

We purchased the 4006 to replace the 2600's. We have 24 class C IP regions and each region uses one of the 2600. We moved one of these regions to the 4006 and was testing it.

I am using IPX because of another problem we have had with IP. When we tried using IP the Client would request an IP from the DHCP server. The DHCP server would process the request and reply to the client, but the client didn't appear to recognize the reply from the DHCP server, therefore never getting an IP. We still haven't figured that problem yet. We use a Linux OS for the DHCP server at the time and it and the DHCP was an older version. We installed the latest version of DHCP and Linux, but that didn't help.

Back to this problem. As I said we use IPX and it was getting through the 2600s just fine. I can connect to both the Netware and 2000 server via IPX using the floppies when the servers are in the same IP region or when going through the 2600s from a different IP region, but not through the 4006. When we enabled IPX on the 4006 we had to set up three IPX networks on the 4006. We have three networks set up on the NetWare server as well. One for 802.2, 802.3 and Ethernet II. The 4006 is set up with 802.2 as the primary network and 803.3 and Ethernt II as secondary. The NICs in the client workstations that we are testing are Intel Pro 100 VE and 802.2.

Hope this helps.

New Member

Re: Can't connect to Win 2000 Domain Controller thru 4006 router

I have a hard time getting a clear picture of your problem.

With the information I have, I think there is something in the floppy disk which does not deal with IP very well. I suspect there is something wrong with the IPX configuration because Windows and Novell client work and the floppy doesn't. The windows and netware client do not rely on IPX for their connection the floppy seems to need it.

Can you tell me what kind of floppy you are using, is it just a DOS floopy with an IPX/ODI netware client? which connects to a "share"?

Or is it something else.

New Member

Re: Can't connect to Win 2000 Domain Controller thru 4006 router

I use a product from Altiris called Rapid Deploy. This product comes with a network boot disk creator. It has you gather the necessary NIC and DOS files and then uses a wizard to create the disk. Below is a copy of the Autoexec.bat and Startnet.bat files that the wizard created. As a test I entered each of the commands one at a time until I received an error message. It got all the way to the 9th line of the Startnet.bat file before I got the error “Invalid drive specification”. I am assuming that line 8 didn’t complete properly, although it didn’t give me an error, or there was some kind of disconnect immediately after line 8 completed.

Autoexec.bat:

@echo off

set PATH=A:\;A:\dos;A:\net;F:\bootwiz\dos

REM Autoexec.bat file for Bootworks and Network Boot

call startnet.bat

rem ibmaster.exe -mcast:ipx

Startnet.bat:

cd A:\net

A:\net\net initialize

A:\net\nwlink.exe

A:\net\netbind.com

A:\aname.exe

if exist A:\net\connect.dat del A:\net\connect.dat > NUL

A:\bwlogin BootWork

A:\net\net use F: \\W2kdc01\Lab_Imaging /yes

F:

Below is the Pro100ve.bat file I use to connect to the NetWare server. It is strickly IPX/ODI and I get the same results with it when I use it to try to connect though the 4006 router. It gets to line seven and won’t return an F: drive. It pauses for a moment and comes back with the A: prompt with no error messages. The remaining lines display “Bad command” error messages.

cd\pro100VE

lh lsl

lh e100bodi

lh ipxodi

vlm /ps=DENEB

cd \

F:

login .admin.owu

map r M:=USR:USERS\djhender

Map r P:=IMG:pcmaint

As I said both of these boot floppies work fine through the 2600 series router. They just don’t work with the 4006.

New Member

Re: Can't connect to Win 2000 Domain Controller thru 4006 router

There must be a configuration flaw in IPX on the 4006.

Have you copied the IPX config from the 2600 to the 4006?

That does not always mean it works though..Can you post the IPX configuration of both routers?

You can also mail it, if you do not want this information publicly available.

Regards,

Pim

New Member

Re: Can't connect to Win 2000 Domain Controller thru 4006 router

I sent the configuration files from both the 2600 and 4006 to you. With the 2600 we were able to use a bridge group to bridge all protocols. With the 4006 when we tried this it returned the "Unrecognizable Command" error.

Thanks.

Dave

New Member

Re: Can't connect to Win 2000 Domain Controller thru 4006 router

Hi !

Did you configure ip helper address in your vlans ?

New Member

Re: Can't connect to Win 2000 Domain Controller thru 4006 router

Yes we have ip helper addresses set up.

New Member

Re: Can't connect to Win 2000 Domain Controller thru 4006 router

The catalyst 4006 does not support bridge groups.

Because switches are more than bridges. It would be weird, to create a brigde-group on a router inside a switch.

New Member

Re: Can't connect to Win 2000 Domain Controller thru 4006 router

OK I admit it right from the beginning - I guessing. Could this be a frame type issue? I have no more guesses right now - I think I'll get some coffee.

New Member

Re: Can't connect to Win 2000 Domain Controller thru 4006 router

I know this seems to simplistic, but I had a similar problem with the 4006 and trying to use a boot disk over the network. For me though, it was a simple "set port host" on the port of the machines I was attempting to boot. Just thought I would share...

New Member

Re: Can't connect to Win 2000 Domain Controller thru 4006 router

Actually, the "set port host" could be very helpful to you.

It will alow packet forwarding to start much faster,since the port will not go through the spanning tree blocking, listen, learning, forwarding steps. Some hosts boot fast enough that the port is still in the spannng tree listening or learning stage while the client is trying to make a network connection. I think I remember that IPX will become disabled or something like that if the port is not forwarding when it is trying to load.

As far as the bridge group command goes, each port in the same vlan is part of the same bridge. You would have to try and add a bridge group at the L3 layer if you wanted to bridge two different vlans. I am sure there are instances when this is needed, but it would have to be the 4908-L3 model to support bridge groups on the VLAN interfaces.

HTH

New Member

Re: Can't connect to Win 2000 Domain Controller thru 4006 router

We disabled the Spanning Tree function and it didn't help.

New Member

Re: Can't connect to Win 2000 Domain Controller thru 4006 router

Which routing module do you have installed in the 4006?

Can you post a sanatized config from the 4006 switch and the 4006 routing module?

New Member

Re: Can't connect to Win 2000 Domain Controller thru 4006 router

We have Supervisor Engine III installed which combines the switch and rounting functions. The servers reside in the 192.68.223 region and I am trying to boot to a server from the 198.30.44 region. Here is a sanitized copy of our config file:

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

service compress-config

!

hostname ecampus

!

boot system bootflash:cat4000-is-mz.121-12c.EW1.bin

no logging console

enable secret (password removed)

!

vtp domain ecamp

vtp mode transparent

ip subnet-zero

!

ipx routing 000a.b734.7500

!

!

vlan 10

name cc

!

vlan 20

name internet

!

vlan 31

name stew1

!

vlan 32

name stew2

!

vlan 33

name stew3

!

vlan 34

name stew4

!

vlan 35

name stew5

!

vlan 80

name dialup

!

interface GigabitEthernet1/1

switchport access vlan 10

no snmp trap link-status

!

interface GigabitEthernet1/2

switchport access vlan 20

no snmp trap link-status

!

interface GigabitEthernet2/1

switchport access vlan 31

no snmp trap link-status

!

interface GigabitEthernet2/2

no snmp trap link-status

!

interface GigabitEthernet2/3

switchport access vlan 33

no snmp trap link-status

!

interface GigabitEthernet2/4

switchport access vlan 34

no snmp trap link-status

!

interface GigabitEthernet2/5

switchport access vlan 33

no snmp trap link-status

!

interface GigabitEthernet2/6

no snmp trap link-status

!

interface GigabitEthernet3/1

no snmp trap link-status

!

interface GigabitEthernet3/2

no snmp trap link-status

!

interface GigabitEthernet3/3

no snmp trap link-status

!

interface GigabitEthernet3/4

no snmp trap link-status

!

interface GigabitEthernet3/5

no snmp trap link-status

!

interface GigabitEthernet3/6

no snmp trap link-status

!

interface FastEthernet6/1

switchport access vlan 20

no snmp trap link-status

!

interface FastEthernet6/2

switchport access vlan 10

no snmp trap link-status

!

interface FastEthernet6/3

switchport access vlan 31

no snmp trap link-status

!

interface FastEthernet6/4

switchport access vlan 80

no snmp trap link-status

!

interface FastEthernet6/5

no snmp trap link-status

!

interface FastEthernet6/6

switchport access vlan 32

no snmp trap link-status

!

interface FastEthernet6/7

no snmp trap link-status

!

interface FastEthernet6/8

no snmp trap link-status

!

interface FastEthernet6/9

no snmp trap link-status

!

interface FastEthernet6/10

no snmp trap link-status

!

interface FastEthernet6/11

no snmp trap link-status

!

interface FastEthernet6/12

no snmp trap link-status

!

interface FastEthernet6/13

no snmp trap link-status

!

interface FastEthernet6/14

no snmp trap link-status

!

interface FastEthernet6/15

no snmp trap link-status

!

interface FastEthernet6/16

no snmp trap link-status

!

interface FastEthernet6/17

no snmp trap link-status

!

interface FastEthernet6/18

no snmp trap link-status

!

interface FastEthernet6/19

no snmp trap link-status

!

interface FastEthernet6/20

no snmp trap link-status

!

interface FastEthernet6/21

no snmp trap link-status

!

interface FastEthernet6/22

no snmp trap link-status

!

interface FastEthernet6/23

no snmp trap link-status

!

interface FastEthernet6/24

no snmp trap link-status

!

interface FastEthernet6/25

no snmp trap link-status

!

interface FastEthernet6/26

no snmp trap link-status

!

interface FastEthernet6/27

no snmp trap link-status

!

interface FastEthernet6/28

no snmp trap link-status

!

interface FastEthernet6/29

no snmp trap link-status

!

interface FastEthernet6/30

no snmp trap link-status

!

interface FastEthernet6/31

no snmp trap link-status

!

interface FastEthernet6/32

no snmp trap link-status

!

interface FastEthernet6/33

no snmp trap link-status

!

interface FastEthernet6/34

no snmp trap link-status

!

interface FastEthernet6/35

no snmp trap link-status

!

interface FastEthernet6/36

no snmp trap link-status

!

interface FastEthernet6/37

no snmp trap link-status

!

interface FastEthernet6/38

switchport access vlan 10

no snmp trap link-status

!

interface FastEthernet6/39

switchport access vlan 10

no snmp trap link-status

!

interface FastEthernet6/40

switchport access vlan 10

no snmp trap link-status

!

interface FastEthernet6/41

switchport access vlan 10

no snmp trap link-status

!

interface FastEthernet6/42

switchport access vlan 10

no snmp trap link-status

!

interface FastEthernet6/43

switchport access vlan 10

no snmp trap link-status

!

interface FastEthernet6/44

switchport access vlan 10

no snmp trap link-status

!

interface FastEthernet6/45

switchport access vlan 10

no snmp trap link-status

!

interface FastEthernet6/46

switchport access vlan 10

no snmp trap link-status

!

interface FastEthernet6/47

switchport access vlan 10

no snmp trap link-status

!

interface FastEthernet6/48

switchport access vlan 10

no snmp trap link-status

!

interface Vlan1

no ip address

shutdown

!

interface Vlan10

ip address 192.68.223.2 255.255.255.0

ip broadcast-address 192.68.223.255

ip access-group 109 out

ipx network 11E encapsulation SAP

ipx network 11D encapsulation ARPA secondary

ipx network 11F encapsulation NOVELL-ETHER secondary

!

interface Vlan20

ip address 199.18.105.226 255.255.255.248

ip broadcast-address 199.18.105.231

ip access-group 101 in

!

interface Vlan31

ip address 198.30.41.2 255.255.255.0

ip broadcast-address 198.30.41.255

ip helper-address 192.68.223.10

ip helper-address 192.68.223.11

ipx network C61E2900 encapsulation SAP

ipx network C61E2901 encapsulation NOVELL-ETHER secondary

ipx network C61E2902 encapsulation ARPA secondary

!

interface Vlan32

ip address 198.30.42.2 255.255.255.0

ip broadcast-address 198.30.42.255

ip helper-address 192.68.223.10

ip helper-address 192.68.223.11

ipx network C61E2A00 encapsulation SAP

ipx network C61E2A01 encapsulation NOVELL-ETHER secondary

ipx network C61E2A02 encapsulation ARPA secondary

!

interface Vlan33

ip address 198.30.43.2 255.255.255.0

ip broadcast-address 198.30.43.255

ip helper-address 192.68.223.10

ip helper-address 192.68.223.11

ipx network C61E2B00 encapsulation SAP

ipx network C61E2B01 encapsulation NOVELL-ETHER secondary

ipx network C61E2B02 encapsulation ARPA secondary

!

interface Vlan34

ip address 198.30.44.2 255.255.255.0

ip broadcast-address 198.30.44.255

ip helper-address 192.68.223.10

ip helper-address 192.68.223.11

ipx network C61E2C00 encapsulation SAP

ipx network C61E2C01 encapsulation NOVELL-ETHER secondary

ipx network C61E2C02 encapsulation ARPA secondary

!

interface Vlan80

ip address 198.30.46.2 255.255.255.0

ip broadcast-address 198.30.46.255

ip helper-address 192.68.223.10

ip helper-address 192.68.223.11

!

router rip

redistribute connected

network 192.68.223.0

network 198.30.41.0

network 198.30.42.0

network 198.30.43.0

network 198.30.46.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 199.18.105.225

ip route 140.141.130.0 255.255.255.0 192.68.223.227

no ip http server

!

access-list 101 deny ip 192.68.223.0 0.0.0.255 any

access-list 101 deny ip 198.30.7.0 0.0.0.255 any

access-list 101 deny ip 198.30.38.0 0.0.0.255 any

access-list 101 deny ip 198.30.39.0 0.0.0.255 any

access-list 101 deny ip 198.30.40.0 0.0.0.255 any

access-list 101 deny ip 198.30.41.0 0.0.0.255 any

access-list 101 deny ip 198.30.42.0 0.0.0.255 any

access-list 101 deny ip 198.30.43.0 0.0.0.255 any

access-list 101 deny ip 198.30.44.0 0.0.0.255 any

access-list 101 deny ip 198.30.45.0 0.0.0.255 any

access-list 101 deny ip 198.30.46.0 0.0.0.255 any

access-list 101 deny ip 198.30.47.0 0.0.0.255 any

access-list 101 deny ip 205.133.242.0 0.0.0.255 any

access-list 101 deny ip 206.21.64.0 0.0.0.255 any

access-list 101 deny ip 206.21.65.0 0.0.0.255 any

access-list 101 deny ip 206.21.95.0 0.0.0.255 any

access-list 101 deny ip 206.21.96.0 0.0.0.255 any

access-list 101 deny ip 206.21.97.0 0.0.0.255 any

access-list 101 deny ip 206.21.114.0 0.0.0.255 any

access-list 101 deny ip 206.21.205.0 0.0.0.255 any

access-list 101 deny ip 206.21.206.0 0.0.0.255 any

access-list 101 deny ip 206.21.207.0 0.0.0.255 any

access-list 101 deny ip 206.21.208.0 0.0.0.255 any

access-list 101 deny ip 206.21.209.0 0.0.0.255 any

access-list 101 deny ip any host 192.68.223.3

access-list 101 deny ip any host 192.68.223.5

access-list 101 permit ip any any

access-list 102 deny ip 192.68.223.0 0.0.0.255 any

access-list 102 deny ip 198.30.7.0 0.0.0.255 any

access-list 102 deny ip 198.30.38.0 0.0.0.255 any

access-list 102 deny ip 198.30.39.0 0.0.0.255 any

access-list 102 deny ip 198.30.40.0 0.0.0.255 any

access-list 102 deny ip 198.30.41.0 0.0.0.255 any

access-list 102 deny ip 198.30.42.0 0.0.0.255 any

access-list 102 deny ip 198.30.43.0 0.0.0.255 any

access-list 102 deny ip 198.30.44.0 0.0.0.255 any

access-list 102 deny ip 198.30.45.0 0.0.0.255 any

access-list 102 deny ip 198.30.46.0 0.0.0.255 any

access-list 102 deny ip 198.30.47.0 0.0.0.255 any

access-list 102 deny ip 205.133.242.0 0.0.0.255 any

access-list 102 deny ip 206.21.64.0 0.0.0.255 any

access-list 102 deny ip 206.21.65.0 0.0.0.255 any

access-list 102 deny ip 206.21.95.0 0.0.0.255 any

access-list 102 deny ip 206.21.96.0 0.0.0.255 any

access-list 102 deny ip 206.21.97.0 0.0.0.255 any

access-list 102 deny ip 206.21.114.0 0.0.0.255 any

access-list 102 deny ip 206.21.205.0 0.0.0.255 any

access-list 102 deny ip 206.21.206.0 0.0.0.255 any

access-list 102 deny ip 206.21.207.0 0.0.0.255 any

access-list 102 deny ip 206.21.208.0 0.0.0.255 any

access-list 102 deny ip 206.21.209.0 0.0.0.255 any

access-list 102 deny ip any host 192.68.223.3

access-list 102 permit ip any any

access-list 108 deny ip host 24.95.56.161 any

access-list 108 deny ip host 24.95.58.186 any

access-list 108 permit ip any any

access-list 109 deny ip host 24.95.56.161 any

access-list 109 deny ip host 24.95.58.186 any

access-list 109 deny ip host 131.183.242.13 any

access-list 109 permit ip any any

!

!

!

!

line con 0

stopbits 1

line vty 0 4

password (password removed)

login

!

end

146
Views
0
Helpful
15
Replies
CreatePlease to create content