Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Can't establish serial to serial link when 2516's set to DCE mode.

I have successfully connected other platforms in DCE mode via ppp over x.21 to my 2516's in DTE mode, but can't get the line protocol up when the 2516's are DCE-TERMINAL-TIMING-ENABLE, DCE-cabled (the link flaps). Debug s0 shows DCE cable disconnected msg, and ppp NACK'ing. IOS is 11.2. I have tried various clock rates etc to no avail. I am beginning to suspect LCP, but don't know how to get any further :-(

4 REPLIES
Silver

Re: Can't establish serial to serial link when 2516's set to DCE

paste in a sh interface from both sides

New Member

Re: Can't establish serial to serial link when 2516's set to DCE

Thanks! - herewith:

sh int s1

Serial1 is up, line protocol is down

Hardware is HD64570

Internet address is 25.78.128.2/30

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255

Encapsulation PPP, loopback not set, keepalive set (10 sec)

LCP Listen

Closed: ipcp, cdp

Last input never, output 00:00:04, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0 (size/max/drops); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/64/0 (size/threshold/drops)

Conversations 0/1 (active/max active)

Reserved Conversations 0/0 (allocated/max allocated)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

472 packets output, 6608 bytes, 0 underruns

0 output errors, 0 collisions, 145 interface resets

0 output buffer failures, 0 output buffers swapped out

88 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

sh int s1/1

Serial1/1 is up, line protocol is down

Hardware is M4T

Internet address is 25.78.128.1/30

MTU 1500 bytes, BW 2048 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, crc 16, loopback not set

Keepalive set (10 sec)

LCP ACKsent

Closed: IPCP, CDPCP

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 00:51:00

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

491 packets input, 6874 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

6 input errors, 6 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

992 packets output, 13888 bytes, 0 underruns

0 output errors, 0 collisions, 45 interface resets

0 output buffer failures, 0 output buffers swapped out

286 carrier transitions DCD=up DSR=up DTR=up RTS=up CTS=up

Silver

Re: Can't establish serial to serial link when 2516's set to DCE

what about a sh config and a sh controllers

New Member

Re: Can't establish serial to serial link when 2516's set to DCE

Andy asked me to post this for you.

We are connecting serial 1/1 on a 3640 to serial 1 on the 2516 with the 2516 as DCE.

3640 Config

Current configuration:

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname xxxxx

!

enable secret xxxxxxxx

!

!

!

!

!

ip subnet-zero

no ip domain-lookup

!

cns event-service server

!

!

!

!

!

!

!

interface Ethernet0/0

ip address 10.9.51.38 255.255.255.0

shutdown

!

interface Ethernet0/1

no ip address

shutdown

!

interface Serial1/0

description UNICOM DCE

ip address 10.79.128.1 255.255.255.252

encapsulation ppp

dce-terminal-timing-enable

shutdown

!

interface Serial1/1

ip address 10.78.128.1 255.255.255.252

encapsulation ppp

!

interface Serial1/2

no ip address

shutdown

!

interface Serial1/3

no ip address

shutdown

!

!

ip classless

!

!

!

snmp-server engineID local 00000009010000A1194E8F08

snmp-server community xxxxx RO

snmp-server community xxxxx RW

!

line con 0

password xxxxx

transport input none

line aux 0

line vty 0 4

password xxxxx

login

!

end

sh controllers se1/1

M4T: show controller:

PAS unit 1, subunit 1, f/w version 1-45, rev ID 0x2800001, version 3

idb = 0x62037A0C, ds = 0x62039594, ssb=0x62039864

Clock mux=0x0, ucmd_ctrl=0xC, port_status=0x73

Serial config=0x8, line config=0x200

maxdgram=1608, bufpool=48Kb, 31 particles

DCD=up DSR=up DTR=up RTS=up CTS=up

line state: up

cable type : V.11 (X.21) DTE cable, received clockrate 9615

base0 registers=0x3C800000, base1 registers=0x3C802000

mxt_ds=0x6249418C, rx ring entries=40, tx ring entries=128

rxring=0x3D72A60, rxr shadow=0x6203F600, rx_head=7

txring=0x3D72BE0, txr shadow=0x6203F80C, tx_head=15, tx_tail=15, tx_count=0

throttled=0, enabled=0

rx_no_eop_err=0, rx_no_stp_err=0, rx_no_eop_stp_err=0

rx_no_buf=0, rx_soft_overrun_err=0, dump_err= 0, bogus=0, mxt_flags=0x20

tx_underrun_err=0, tx_soft_underrun_err=0, tx_limited=1(2)

tx_fullring=0, tx_started=32821

2516 Config

Current configuration:

!

version 11.1

service udp-small-servers

service tcp-small-servers

!

hostname yyyyy

!

enable secret yyyyyyyy

!

no ip domain-lookup

!

hub ether 0 1

link-test

auto-polarity

!

hub ether 0 2

link-test

auto-polarity

!

hub ether 0 3

link-test

auto-polarity

!

hub ether 0 4

link-test

auto-polarity

!

hub ether 0 5

link-test

auto-polarity

!

hub ether 0 6

link-test

auto-polarity

!

hub ether 0 7

link-test

auto-polarity

!

hub ether 0 8

link-test

auto-polarity

!

hub ether 0 9

link-test

auto-polarity

!

hub ether 0 10

link-test

auto-polarity

!

hub ether 0 11

link-test

auto-polarity

!

hub ether 0 12

link-test

auto-polarity

!

hub ether 0 13

link-test

auto-polarity

!

hub ether 0 14

link-test

auto-polarity

!

interface Ethernet0

ip address 10.9.138.8 255.255.254.0

!

interface Serial0

ip address 10.79.128.2 255.255.255.252

encapsulation ppp

!

interface Serial1

ip address 10.78.128.2 255.255.255.252

encapsulation ppp

clockrate 9600

dce-terminal-timing-enable

!

interface BRI0

no ip address

shutdown

!

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.9.138.1

snmp-server community yyyyy RO

snmp-server community yyyyy RW

snmp-server host yyyyy

!

line con 0

password yyyyy

login

line aux 0

line vty 0 4

password yyyyy

login

!

end

sh control serial 1

HD unit 1, idb = 0xADAA8, driver structure at 0xB1DF0

buffer size 1524 HD unit 1, X.21 DCE cable, clockrate 9600

cpb = 0x23, eda = 0x2140, cda = 0x2000

RX ring with 16 entries at 0x232000

00 bd_ptr=0x2000 pak=0x0B46E8 ds=0x23C468 status=80 pak_size=0

01 bd_ptr=0x2014 pak=0x0B4538 ds=0x23BDB0 status=80 pak_size=0

02 bd_ptr=0x2028 pak=0x0B4388 ds=0x23B6F8 status=80 pak_size=0

03 bd_ptr=0x203C pak=0x0B41D8 ds=0x23B040 status=80 pak_size=0

04 bd_ptr=0x2050 pak=0x0B4028 ds=0x23A988 status=80 pak_size=0

05 bd_ptr=0x2064 pak=0x0B3E78 ds=0x23A2D0 status=80 pak_size=0

06 bd_ptr=0x2078 pak=0x0B3CC8 ds=0x239C18 status=80 pak_size=0

07 bd_ptr=0x208C pak=0x0B3B18 ds=0x239560 status=80 pak_size=0

08 bd_ptr=0x20A0 pak=0x0B3968 ds=0x238EA8 status=80 pak_size=0

09 bd_ptr=0x20B4 pak=0x0B37B8 ds=0x2387F0 status=80 pak_size=0

10 bd_ptr=0x20C8 pak=0x0B3608 ds=0x238138 status=80 pak_size=0

11 bd_ptr=0x20DC pak=0x0B3458 ds=0x237A80 status=80 pak_size=0

12 bd_ptr=0x20F0 pak=0x0B32A8 ds=0x2373C8 status=80 pak_size=0

13 bd_ptr=0x2104 pak=0x0B30F8 ds=0x236D10 status=80 pak_size=0

14 bd_ptr=0x2118 pak=0x0B2F48 ds=0x236658 status=80 pak_size=0

15 bd_ptr=0x212C pak=0x0B2D98 ds=0x235FA0 status=80 pak_size=0

16 bd_ptr=0x2140 pak=0x0B2BE8 ds=0x2358E8 status=80 pak_size=0

cpb = 0x23, eda = 0x2800, cda = 0x2800

TX ring with 2 entries at 0x232800

00 bd_ptr=0x2800 pak=0x000000 ds=0x000000 status=80 pak_size=0

01 bd_ptr=0x2814 pak=0x000000 ds=0x000000 status=80 pak_size=0

02 bd_ptr=0x2828 pak=0x000000 ds=0x000000 status=80 pak_size=0

0 missed datagrams, 0 overruns

0 bad datagram encapsulations, 0 memory errors

0 transmitter underruns

0 residual bit errors

Regards

Zac

100
Views
0
Helpful
4
Replies
CreatePlease login to create content