Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

can't ping from different vlan

Dear Netpro.

I've 2 vlans which is VLAN 10 and VLAN 20.

VLAN 10 (10.10.10.1)and VLAN 20 (20.20.20.1). From Vlan 10 i can ping to Vlan 20, but from Vlan 20 cant ping to Vlan 10. routing is all routed.

does anyone got any idea ?

Regards,

Jack

  • Other Network Infrastructure Subjects
10 REPLIES
Hall of Fame Super Silver

Re: can't ping from different vlan

Jack

When you talk about being able to ping and not being able to ping are you talking about pinging from the router or from end stations connected in each vlan? And are you pinging to the address of the router interfaces or to addresses of end stations.

Most of the time when I see symptoms like you describe I find that it is misconfiguration, most often on some end stations. I suggest that you check both the router interfaces (make sure that each interface has a correct address and a correct subnet mask) and the interfaces on the end stations (check that they have correct address, have correct subnet mask, and most importantly make sure that the default gateway configured in the router interface of the correct vlan). Probably the most common mistake that I find is an incorrect default gateway on the end station. And the next most common mistake is a subnet mask on the end station that does not match the router mask.

Let us know what you find. And if the problem is not solved yet then let us know a bit more about your situation.

HTH

Rick

New Member

Re: can't ping from different vlan

Hi Rick,

i agreed with you, most of the time is the subnet mask and default gateway key in wrongly, but i have checked and confirmed no problem at all. the funniest thing is within the range (10.10.10.1 - .254) some of the ip can ping to vlan 20 (20.20.20.x).

Regards,

Jack

Hall of Fame Super Silver

Re: can't ping from different vlan

Jack

Can you confirm that you are doing the ping from end stations in the 10.10.10.x network? And can you help me understand whether the ping destination is end stations in the 20.20.20.x network or is the router interfaces in the VLANs?

If some of the addresses in 10.10.10.x can successfully ping to VLAN20, then I think it is not likely to be a problem on the router/switch configuration. But it might be helpful if you would post the configuration of the VLAN interfaces so that we can see them.

HTH

Rick

Purple

Re: can't ping from different vlan

Hi Jack,

Can you confirm that there aren't any access-lists applied on your VLAN interfaces ?

Paresh

New Member

Re: can't ping from different vlan

Hi Paresh,

Yes, i am confirm i didnt put any access-list.

Hi Rick,

the configuration as below.

interface Vlan10

description vlan10

ip address 10.10.10.252 255.255.255.0

ip helper-address x.x.x.x

ip helper-address y.y.y.y

ip helper-address z.z.z.z

no ip redirects

no ip proxy-arp

ip pim query-interval 3

ip pim sparse-mode

no ip route-cache cef

ip igmp query-interval 30

ip cgmp

standby 10 ip 10.10.10.254

standby 10 priority 105

standby 10 authentication yahoo

end

interface Vlan20

description vlan20

ip address 20.20.20.252 255.255.255.0

ip helper-address x.x.x.x

ip helper-address y.y.y.y

ip helper-address z.z.z.z

no ip redirects

no ip proxy-arp

ip pim query-interval 3

ip pim sparse-mode

no ip route-cache cef

ip igmp query-interval 30

ip cgmp

standby 10 ip 20.20.20.254

standby 10 priority 105

standby 10 authentication yahoo

end

Regards,

Jack

Re: can't ping from different vlan

Jack,

Check some local firewalls on the systeml like symantec firewall and also the windows XP's internal firewall.

It seems to be a simple config and should work fine. If you are able to ping some hosts in that Vlan and you are sure about the ip/netmask and could be the local firewall issue.

regards,

-amit singh

New Member

Re: can't ping from different vlan

Hi Amit ,

Thanks for reply. yes i have checked all before i sent to netpro.no firewall, no access-list , subnet mask and default gateway are correct.

Regards,

Jack

Purple

Re: can't ping from different vlan

Hi Jack,

You might want to try and enable 'ip proxy-arp' on these interfaces in case there is an issue with the subnet masks you've configured on your hosts... this is not a long-term fix but it may work in the short term ...

Paresh

New Member

Re: can't ping from different vlan

Hi Paresh,

i agreed with what u said, but i just curious about currently i am using "no ip proxy-arp" on these interfaces. and some of the ip is working but some of them is not. for instance :vlan10 - 10.10.10.15 (Static ip address). can ping to vlan20 (20.20.20.10), but from the vlan20 can't ping to this static ip address.

Regards,

Jack

966
Views
0
Helpful
10
Replies
This widget could not be displayed.