Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Can't ping from router to router, please help !

Hello. I have two 2500 series routers. I can't ping either router. Here is what I know...

On both routers, all ethernet and serial ports are up, and all protocols show up. I can view each router in the show CDP neighbors. I have set clock rates on DCEs, done the no shuts, set the bandwidth, everything shows as ok but I cannot ping from router to router. Please help.

  • Other Network Infrastructure Subjects
8 REPLIES
New Member

Re: Can't ping from router to router, please help !

Did you turn on IP routing by using the "ip routing" command on both routers?

Re: Can't ping from router to router, please help !

Can you paste your configs

Silver

Re: Can't ping from router to router, please help !

make sure they are on the same subnet .

router a

s0 10.1.1.1 255.255.255.252

router b

s0 10.1.1.2 255.255.255.252

New Member

Re: Can't ping from router to router, please help !

* Yes, I did enable ip routing on both routers

* Below is a copy of both (Show CDP neighbors) and (Show Interfaces)

Router1>SHOW CDP NEIGHBORS DETAIL

-------------------------

Device ID: Router2

Entry address(es):

IP address: 60.0.0.1

Platform: cisco 2507, Capabilities: Router

Interface: Serial0, Port ID (outgoing port): Serial0

Holdtime : 152 sec

Version :

Cisco Internetwork Operating System Software

IOS (tm) 2500 Software (C2500-JK8OS-L), Version 12.2(1d), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Sun 03-Feb-02 22:01 by srani

advertisement version: 2

-------------------------

Device ID: Sol

Entry address(es):

IP address: 60.0.0.1

Platform: cisco 2507, Capabilities: Router

Interface: Serial0, Port ID (outgoing port): Serial0

Holdtime : 92 sec

Version :

Cisco Internetwork Operating System Software

IOS (tm) 2500 Software (C2500-JK8OS-L), Version 12.2(1d), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Sun 03-Feb-02 22:01 by srani

advertisement version: 2

************************************************************************************************************************************************

Router1#sh int

Ethernet0 is up, line protocol is up , using hub 0

Hardware is Lance, address is 00e0.1e68.a755 (bia 00e0.1e68.a755)

Internet address is 10.0.0.1/8

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 00:00:03, output hang never

Last clearing of "show interface" counters never

Queueing strategy: fifo

Output queue 0/40, 0 drops; input queue 0/75, 0 drops

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

486 packets output, 42756 bytes, 0 underruns(0/0/0)

0 output errors, 0 collisions, 16 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

Serial0 is up, line protocol is up

Hardware is HD64570

Internet address is 20.0.0.1/8

MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input 00:00:04, output 00:00:05, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 48 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

481 packets input, 27992 bytes, 0 no buffer

Received 481 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

483 packets output, 28118 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 output buffer failures, 0 output buffers swapped out

13 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

Serial1 is up, line protocol is up

Hardware is HD64570

Internet address is 30.0.0.1/8

MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input 00:00:06, output 00:00:07, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 48 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

13 packets input, 1476 bytes, 0 no buffer

Received 13 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

10 packets output, 624 bytes, 0 underruns

0 output errors, 0 collisions, 5 interface resets

0 output buffer failures, 0 output buffers swapped out

1 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

Router1#

Silver

Re: Can't ping from router to router, please help !

your serial interfaces are on different subnets , they need to be on the same subnet to ping each other

New Member

Re: Can't ping from router to router, please help !

--begin ciscomoderator note-- The following post has been edited to remove potentially confidential information. Please refrain from posting confidential information on the site to reduce security risks to your network. -- end ciscomoderator note --

I have assigned all interfaces on both routers with the same subnet mask. I use the ip addresses 50.0.0.1, x.x.0.1, and x.x.0.1 on the other router interfaces but the same subnet mask. Below is a copy of the show run. I don't understand what I'm doing wrong.

Router1#show run

Building configuration...

Current configuration : 1774 bytes

!

version 12.2

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router1

!

logging rate-limit console 10 except errors

enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxx

enable password xxxxxxxxxxxxxxxxxxxxxxxx

!

ip subnet-zero

no ip finger

!

no ip dhcp-client network-discovery

!

!

!

!

--More--

hub ether 0 1

link-test

auto-polarity

source-address 0010.0000.0000

interface Ethernet0

ip address 10.0.0.1 255.0.0.0

no ip mroute-cache

no mop enabled

!

interface Serial0

bandwidth 64

ip address x.x.0.1 255.0.0.0

no ip mroute-cache

!

interface Serial1

bandwidth 64

ip address x.x.0.1 255.0.0.0

no ip mroute-cache

clockrate 9600

dce-terminal-timing-enable

!

router rip

network 10.0.0.0

network x.x.0.0

network x.x.0.0

!

ip kerberos source-interface any

ip classless

ip http server

!

!

snmp-server community xxxxxxxxxxxxxx RO

!

line con 0

transport input none

line aux 0

line vty 0 4

password xxxxxxxxxxxx

login

--More--

!

end

Router1#

Silver

Re: Can't ping from router to router, please help !

--begin ciscomoderator note-- The following post has been edited to remove potentially confidential information. Please refrain from posting confidential information on the site to reduce security risks to your network. -- end ciscomoderator note --

router 1

serial 0

ip address x.x.0.1 255.0.0.0

according to the cdp output above the s0 of router 2 connects to this interface, in order to ping , serial 0 of router 2 must be on the same network currently the ip address of s0 of router 2 is x.x.0.1 . change the ip address on serial 0 of router 2 to x.x.0.2 255.0.0.0, then you will be able to ping , this needs to be done on serial 1 of both routers also

New Member

Re: Can't ping from router to router, please help !

Thank you for the help, it works to have both Serial Interfaces on the same network number. I'm still confused because originally I had (network x.x.0.1 on Router1 Serial 1) ping (Router2 network x.x.0.1 on Serial 1) and it was working just fine. The only reason that it doesn't work currently is because someone erased and reloaded router2, I couldn't get the configurations the same.

780
Views
0
Helpful
8
Replies
This widget could not be displayed.