Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Can't ping to T1 Wic

Hi am a newbie to Cisco.

I have a Cisco 2621xm with two ethernet port and 1 T1 WIC. I have Ip set on Ethernet0 10.5.x.x 255.255.255.0 and on T1 to 10.1.X.X 255.255.255.0.

Does anyone know why I can't ping to the T1 ip from the router itself.

Any help would be greatly appreciated.

16 REPLIES
Silver

Re: Can't ping to T1 Wic

in order to ping the interfaces they must be up up can you paste in a sh int e0 and sh int serial x

New Member

Re: Can't ping to T1 Wic

Hi deilert, thanks for the response. Here's it is.

VIRCIS20.2#show interface fastethernet0/0

FastEthernet0/0 is up, line protocol is up

Hardware is AmdFE, address is 000c.31eb.e5c0 (bia 000c.31eb.e5c0)

Internet address is 10.5.20.2/16

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Half-duplex, 100Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 14:51:32

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 3000 bits/sec, 5 packets/sec

5 minute output rate 1000 bits/sec, 3 packets/sec

100130 packets input, 11498890 bytes

Received 88510 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

14620 packets output, 1574266 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

66 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

VIRCIS20.2#

VIRCIS20.2#show interface serial0/0

Serial0/0 is up, line protocol is up

Hardware is PQUICC with Fractional T1 CSU/DSU

Internet address is 10.1.11.1/24

MTU 1524 bytes, BW 1536 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive not set

Last input 00:00:02, output 00:00:56, output hang never

Last clearing of "show interface" counters 14:52:34

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

12136 packets input, 497484 bytes, 0 no buffer

Received 12136 broadcasts, 0 runts, 2 giants, 0 throttles

940 input errors, 234 CRC, 481 frame, 0 overrun, 0 ignored, 223 abort

1118 packets output, 320577 bytes, 0 underruns

0 output errors, 0 collisions, 5 interface resets

0 output buffer failures, 0 output buffers swapped out

4 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

Silver

Re: Can't ping to T1 Wic

you have no keep configured on serial 0/0 ,with this configured line protocol will never drop , This maike line protocol look up but it really is not . what does the config for the interface on the other side of this line look like ? does it have keepalives configured ? if not you should configure keepalives on both sides 'keep 10' then see if line protocol comes up .

Silver

Re: Can't ping to T1 Wic

can you also paste in a sh run

New Member

Re: Can't ping to T1 Wic

Hi Deilert,

I turned on Keepalive and sure enough the line protocol went down. At the remote end I have a Larscom CSU\DSU, am not sure what the config for keepalive is set for, I have to go over and get the config. In the meantime here's the running config for the Cisco2621. Thanks again.

VIRCIS20.2#show running-config

Building configuration...

Current configuration : 885 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname VIRCIS20.2

!

boot system flash c2600-i-mz.122-8.T10.bin

enable secret xxxxxxxxxx

enable password XXXXX

!

ip subnet-zero

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.5.20.2 255.255.0.0

ip ospf authentication

no ip mroute-cache

speed auto

half-duplex

!

interface Serial0/0

mtu 1524

ip address 10.1.11.1 255.255.255.0

no ip mroute-cache

delay 10

no keepalive

autodetect encapsulation ppp

roles

role default

no fair-queue

service-module t1 clock source internal

!

interface FastEthernet0/1

no ip address

no ip mroute-cache

shutdown

duplex auto

speed auto

!

ip classless

ip route profile

ip http server

ip ospf name-lookup

ip pim bidir-enable

!

!

!

line con 0

line aux 0

line vty 0 4

password XXXXXXX

!

!

end

Silver

Re: Can't ping to T1 Wic

On serial 0/0 you have clock-source internal configured , make sure that the router on the other side is configured for clock source external or network , I am not sure of the exact syntax. Also the keepalive on that serial interface must be 10 seconds if it is not already , the keepalived and encap must match on both routers

New Member

Re: Can't ping to T1 Wic

Hey deilert,

Guess what before I went over to the remote site, I Changed the encapsulation to PPP instead of HDLC on the serial port, guess what the line protocol came up. I can ping the remote router, also I could ping the T1 WIC interface from my workstation. But I still can't ping the T1 WIC from the router itself, is this normal?

Silver

Re: Can't ping to T1 Wic

are you pinging like this

router > ping 10.1.11.1

.....

router>

When you ping your own interface the pings travel to the serial interface at the remote end then comes back . If you can ping the remote serial interface you should be able to ping your own serial interface .

New Member

Re: Can't ping to T1 Wic

Hey Deilert,

Could it possibly be bacause I have the two ip address set in the same subnet.

The serial interface on my end is set for 10.1.11.1/24

The serial interface on the remote end is set for 10.1.11.2/16.

Could this possibly be the problem

Thanks again

Silver

Re: Can't ping to T1 Wic

yes

this needs to be corrected , I am suprised you can ping the remote end , make both end /24 this should hook you up .

New Member

Re: Can't ping to T1 Wic

Hi,

I have both end set to 24 and still can't ping to the T1 interface.

Silver

Re: Can't ping to T1 Wic

can you paste in a sh ip route 10.1.11.1 & 10.1.11.2 on both routers

New Member

Re: Can't ping to T1 Wic

Hi, Here it is, Note: 10.1.11.2 is a 3com router.

IP Route on 10.1.11.1

10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks

C 10.1.11.0/24 is directly connected, Serial0/0

C 10.1.11.2/32 is directly connected, Serial0/0

C 10.5.0.0/16 is directly connected, FastEthernet0/0

192.168.0.0/26 is subnetted, 1 subnets

S 192.168.0.0 [1/0] via 10.1.11.2

IP Routing Table for 10.1.11.2 - 3Com Router

-------------------------------IP Routing Table--------------------------------

Total Routes = 3, Total Direct Networks = 2

Destination Mask Gateway Metric Status TTL Source

10.1.11.0 255.255.255.0 10.1.11.2 0 Up -- Connected

192.168.0.0 255.255.255.0 192.168.0.49 0 Up -- Connected

192.168.141.0 255.255.255.0 !4 1 -- -- Static

Silver

Re: Can't ping to T1 Wic

Ok now it is a little clearer , You have a cisco connected to a 3com , If this is true you must use PPP , hdlc is vendor specific, try this and see what happens

New Member

Re: Can't ping to T1 Wic

Hi,

I am using PPP, intial it was set to HDLC, when I switched it to PPP, that made the line come up. But it does not explain why I can't ping the internal T1 WIC, yet I could ping the remote router.

Thanks again deilert.

Bronze

Re: Can't ping to T1 Wic

I know on frame-relay you cannot ping the local serial interface without adding a frame-relay map statement for the local serial interface itself. I know you're not running frame-relay here but just an FYI.

If you plug a loopback plug into the WIC-1T you should be able to ping the local serial interface from the local router CLI.

What you are seeing regarding not being able to ping the local serial interface from the local router CLI shouldn't be an issue.

If it is bothering you though, try doing an extended ping on the local router and specify the ethernet IP for the source IP and see if that works. Also, you should be able to ping the serial IPs from hosts on your LAN.

-HTH

810
Views
0
Helpful
16
Replies
CreatePlease to create content