Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Can't upgrade ROMMON on 2811 router

I'm trying to upgrade the  ROMMON on three 2811 routers to support USB booting. The routers were cleared of any  config to begin with.

On two of them the upgrade went smoothly, just as documented, by doing:

upgrade rom-monitor file flash:c2800nm_rm2.srec.124-13r.t11

The routers flashed the NV-RAM, rebooted, and hey-presto loaded the new ROMMON version.

On  the third router (actually the first I tried, of course, causing a lot  of wasted time) it does not work. Everything looks good until the router  reloads, then it says:

System Bootstrap, Version 12.4(1r) [hqluong 1r], RELEASE SOFTWARE (fc1)
Copyright (c) 2005 by cisco Systems, Inc.

Initializing memory for ECC
..

Upgrade ROMMON programming not complete.
Falling to ReadOnly ROMMON

...etc.

No  new ROMMon. I tried selecting the NV-RAM with the "upgrade rom-monitor  preference" command to be told that there was no programmed upgrade to  select.

Is there any setting I'm missing that might be preventing the upgrade?

I'm concerned that it might be faulty NV-RAM.

Rick.

4 REPLIES
Hall of Fame Super Gold

Re: Can't upgrade ROMMON on 2811 router

I've never seen an error message like that.

Sent from Cisco Technical Support Nintendo App

New Member

Can't upgrade ROMMON on 2811 router

lol, me neither until today!

I've been working on this for hours and can't get anywhere. I've even pulled the WIC cards out so it's just a bare unit effectively factory fresh. It was configured identically to one of the other two routers initially; same IOS version etc. and that one upgraded without issues.

Where exactly is the upgraded ROMMON file stored when it is programmed? I had assumed NV-RAM but I guess that is wrong and there is a seperate flash chip on the motherboard for it. Is there a way to test that flash? I did a "test memory" on the NV-RAM which passed.

Hall of Fame Super Gold

Can't upgrade ROMMON on 2811 router

I believe the bootstrap is located in the "bs:".

New Member

Can't upgrade ROMMON on 2811 router

The router doesn't seem to have a bs: filesystem. It has a system: filesystem which seems to contain (I guess) symbolic links to other places,

I think it's probably irelevent anyway. I've tried so many times now to update the ROMMION on this particular router that I can only conclude it has a hardware fault.

595
Views
0
Helpful
4
Replies
CreatePlease to create content