Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Cannot attach to Domain DFM

dear experts,

i have a question about CiscoWorks2000 LMS/Device Fault Manager. first i click administration console, then in the popup windows, i click attach domain manager, and enter the broker address and port 9002, click browse, see domain DFM, click ok, click apply, but get the message:

Cannot attach to Domain DFM!

Domain DFM not registered with broker.

what should i do?

and another question, can i install ciscoworks LMS and VMS buddles in the same server?

thank you for your time!

yours sincerely

tunnal tang

7 REPLIES

Re: Cannot attach to Domain DFM

Hi,

is it a new installation or has it been working before?

I'd check first if all DFM processes are running, second try to look to the log files.

Have you defined the hosts allowed to acces DFM server during the installation or are you allowing anybody?

Which DFM version are you running?

What happens when you try to start the Monitoring Console?

To your second question:

It's even not recommended to install all VMS components on one server:

"For deployments in your production network and optimal performance, we recommend that you install Security Monitor on a server separate from the one running your Management Centers." See http://cco-rtp-1.cisco.com/en/US/customer/products/sw/cscowork/ps2330/products_quick_start09186a00800e6d1d.html

and if I remember corretcly it's also recommended to install Real Time Monitor to a different machine than other LMS components.

But it always depends on your network size and load.

Regards,

Milan

Community Member

Re: Cannot attach to Domain DFM

hi milan,

thank you for your tips. i have sent you a mail containing the relative info. i think the big problem is i cannot execute the following command in dos mode.

# NMSROOT\bin\pdcmd.exe -r DfmBroker -e NMSROOT\objects\smarts\bin\brstart.exe -f "--output --port=9002 --accept=lucy,ethel --restore=NMSROOT\objects\smarts\conf\broker.rps"

i input it like this:

c:\Program Files\CSCOpx\bin>pdcmd.exe -r DfmBroker -e C:\Program Files\CSCOpx\objects\smarts\bin\brstart.exe -f "--output --port=9002 --accept=10.116.1.100 --restore=C:\Program Files\CSCOpx\objects\smarts\conf\broker.rps"

is it right?

best regards,

tunnal

Re: Cannot attach to Domain DFM

Hi Tunnal,

I remember following problem in the past:

I was not able to delete my shortcuts via Home -> My Shortcuts -> Delete Shortcut. I was receiving an error message "Insufficient user rights".

The problem disappeared after reinstalling my CW to D:\cw2000\CSCOpx directory instead of the default C:\Program Files\CSCOpx.

So the problem was the directory length of Program Files (exceeded the DOS limit 8 characters). I've found CSCds53413 bug on CCO with "Unreproducible" status.

But regarding to your error message "ERROR: cmd failed. Server reason: The path or filename given to the daemon manager in an application registration is invalid." this might be the same case.

BTW: If this really helps, it's a pretty stupid mistake from Cisco programmers.

Regards,

Milan

Community Member

Re: Cannot attach to Domain DFM

Hi Milan,

You are right. I followed your advise and installed LMS on D:\CW2000\CSCOpx. Now I can finish the registerations successfully. But this haven't solved the original problem.

I click administration console, then I click attach domain manager, and enter the broker address and port 9002, click browse, see domain DFM, in available domains, I see this:

Domain: DFM

Host: cw2000.XXX.gov.cn

Port: 2725

Connection: Detached

Status: Running

Process ID: 1668

click ok, click apply, but get the message:

Cannot attach to Domain DFM!

Domain DFM not registered with broker.

Why are the connection shows detached while the status shows running.

Do you have any suggestions?

Best regards,

Tunnal

Re: Cannot attach to Domain DFM

I remember you mentioned some problem with DNS during installation.

Have you tried to use the IP address instead of the cw2000.XXX.gov.cn?

Regards,

Milan

Community Member

Re: Cannot attach to Domain DFM

Yes, I was really worried about my DNS registration yesterday. So I used IP address instead of computer name all the time. But today, I found even if I register DfmBroker and DfmServer using IP address, I got full computer name in Administrator Monitor's attach dialog. So I thought maybe I should use computer name in the registration process. Then I unregistered and registered again. But as you can see, it doesn't work. I still get the detached notification.

By the way, although the installation say dns is a problem, I think my dns works well. I get echo reply from 'ping cw2000', 'ping cw2000.xxx.gov.cn' and of course 'ping 10.116.1.100'. My PC's IP address is 10.116.2.144. And most of the time I'm working on the very computer where CiscoWorks LMS is installed, cannot it recognize its own computer name and ip address? Maybe there are still some other problems. Need your help.

Best regards,

Tunnal

Re: Cannot attach to Domain DFM

Hi,

I really don't know what else to try.

I've just got a feeling there might be some problem with passwords or something like that.

You might find something useful in http://www.cisco.com/univercd/cc/td/doc/product/rtrmgmt/cw2000/dfm/dfm123cd/u_gd/admin.pdf

Just for sure:

check your browser settings, IDUs and patches installed on your server.

Good luck,

Milan

204
Views
0
Helpful
7
Replies
CreatePlease to create content