Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cannot flash IOS on 3640 only!

I have a number of routers (1700, 2600, 3640) that I manage in remote locations connected by Frame Relay links. I have no problem downloading or uploading either configs or images to any of my routers but the 3640's. I have tried using defferent tftp servers, connecting to different interfaces (LAN or WAN), changing the config register, but I still cannot upload a new image to the 3640's. I can however download the image currently on them and the configs. Any ideas? I really do not want to travel to the site and use xmodem just to do this.

Thanks.

3 REPLIES
Bronze

Re: Cannot flash IOS on 3640 only!

If you have not already tried it, you could try shutting down all the interfaces except the one you are tftping over. Some of the very early code had a problem with tftp and this was the workaround.

Bronze

Re: Cannot flash IOS on 3640 only!

How is it failing? do you have enough flash?

One issue I've seen is when the interface of the router that faces the TFTP server (indirectly) is on a non advertised network. Then the tftp server cant find it for the tftp. In other words, if you telnet to the lan side ip address of the router can you ping the tftp server? The ping will use the serial side address just like the tftp. If it fails then you need to add that serial network to your routing process.

New Member

Re: Cannot flash IOS on 3640 only!

I've done this once for a remote location (across the WAN) and localy (from the LAN) both failed. Plenty or flash available. The upload starts and then times out after 4KB.

I finally got the image uploaded but had to use ftp. If it were a routing issue I would think that the ftp upload would have failed also.

ChrisV

93
Views
0
Helpful
3
Replies
CreatePlease to create content