Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

cannot get protocol up on S0 - Full t point-to-point

have messed with the configuration so much not sure where I am any more. I was told by several people everthing I had was right but hte telco comes in and loops up and says "hey, its your equipment man".

NAtoFOX#sho int s0

Serial0 is down, line protocol is down

Hardware is QUICC Serial (with FT1 CSU/DSU WIC)

Description: connected to NAtoFOX

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 252/255, load 1/255

Encapsulation HDLC, loopback not set, keepalive set (10 sec)

Last input never, output 00:04:36, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0 (size/max/drops); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

1057 input errors, 1 CRC, 348 frame, 0 overrun, 0 ignored, 708 abort

1 packets output, 22 bytes, 0 underruns

0 output errors, 0 collisions, 32 interface resets

0 output buffer failures, 0 output buffers swapped out

2 carrier transitions

DCD=down DSR=up DTR=up RTS=up CTS=down

NAtoFOX#sho running-config

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname NAtoFOX

!

enable password 7 01114724410E1456

!

ip subnet-zero

no ip domain-lookup

!

!

!

interface Ethernet0

description Connected to NA LAN

ip address 172.16.1.5 255.255.255.0

no ip directed-broadcast

!

interface Ethernet1

no ip address

no ip directed-broadcast

shutdown

!

interface Serial0

description connected to NAtoFOX

bandwidth 1544

no ip address

no ip directed-broadcast

!

router rip

version 2

network 172.16.0.0

no auto-summary

!

ip classless

!

!

line con 0

password 7 14151E0A160138

transport input none

line vty 0 4

password 7 0823404F131C17

login

!

end

NAtoFOX#

with Manual Loopback on WIC

Loopback in progress

00:12:29: %LINK-3-UPDOWN: Interface Serial0, changed state to up

00:12:30: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state

to up

NAtoFOX#sho int s0

Serial0 is up, line protocol is up (looped)

Hardware is QUICC Serial (with FT1 CSU/DSU WIC)

Description: connected to NAtoFOX

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255

Encapsulation HDLC, loopback set, keepalive set (10 sec)

Last input 00:00:02, output 00:00:02, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0 (size/max/drops); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

7 packets input, 1186 bytes, 0 no buffer

Received 7 broadcasts, 0 runts, 0 giants, 0 throttles

1057 input errors, 1 CRC, 348 frame, 0 overrun, 0 ignored, 708 abort

8 packets output, 1208 bytes, 0 underruns

0 output errors, 0 collisions, 36 interface resets

0 output buffer failures, 0 output buffers swapped out

3 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

I have tried it with numbered and unnumbered WAN addresses

This is down to barebones and the protocol just will not come up. It has to be something so obvious I have missed it.

Thanks

9 REPLIES
New Member

Re: cannot get protocol up on S0 - Full t point-to-point

PS When not in loopback the LED's on the WIC show

LP = OFF

AL= Yellow - remote station has alarm condition according to documentation

CD = Green

Bronze

Re: cannot get protocol up on S0 - Full t point-to-point

It looks like you have internal csus. You need to configure the service module. Check out the docs on that keyword. I'll see what I can find.

Bronze

Re: cannot get protocol up on S0 - Full t point-to-point

There are multiple commands related to the internal t1 csus. They all start "service module t1". Here's a link to the config guide.

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/finter_c/icfserin.htm#1015573

New Member

Re: cannot get protocol up on S0 - Full t point-to-point

This is nothing to do with the service module commands as the default configuration should work.

When you are giving a mannual loopback on your WIC its looping there itself and hence the interface comes up.

Did you try giving loopback from your end to the service provider end or ask the service provider to give loop from his/her end to your end.

It could be a cable problem or might be a service proivder problem with the equipment.

-Deepu

New Member

Re: cannot get protocol up on S0 - Full t point-to-point

I have set the service module in every possible configuration but the default settings should pretty much do it. When you do a "show running-config" the default service-module command settings are not displayed.

I did have verizon test do the router on hte other side and they were able to put it into loop back (so they say. It appeared to me to be working.)

I alos had them test through my cable to the dmark just to make sure that the cables I am using are okay. (I replace them first.)

Maybe these are the wrong type of WIC's? I bought them off the web from a refurbish and surplus house which I have had good luck with. Are there different models for Europe? I thought E and T were pretty much the same except for the number of channels. The bandwidth parameters only accept upto 1544kb so these appear to be for a T.

Verison has been out twice and tested. Yesterday we were there together and the guy was pretty thorough.

Silver

Re: cannot get protocol up on S0 - Full t point-to-point

Brian

you need to get the LEC on the line and test with them. These are the steps you need to follow to isolate the faulty portion

1. assign an ip address to your serial 0

2. have the LEC give you a loop from there closest test point when they do this ou should see your interface go up up (looped) , make sure the command 'down wnen looped' is not configured .

When your interface goes up up (looped) then ping the ip address you assigned to s0 with 1000 pings , If you drop ping then this is the portion with a problem if pings are not dropped then have the LEC move back to there next test point and do the same thing , when you drop pings this is where the problem exists.

If the Lec runs this test and no pings are dropped after loops are given at all the test points then go to the other side and do the same test .

Also if this is point to point the LEC usually does not provide clock on a point to point , verify who is providing clock , if they say that they are not then you need to configure one CSU to provide clock(internal) , and the other CSU to Rx clock (network).

By working with the LEC using loops you should be able to narrow down the faulty portion rather quickly.

Bronze

Re: cannot get protocol up on S0 - Full t point-to-point

Its not a matter of "the defaults should pretty much do it", they have to match the vendor's specifications. When I used these modules and external csus I had to set the clock internal with one carrier but not the rest. Most used b8zs but one used ami. Have you verified these things and the rest with the carrier?

BTW: The Cisco docs say these settings are required.

New Member

Re: cannot get protocol up on S0 - Full t point-to-point

Yes, I have verified these settings. I am providing the clocking on one side. It is b8zs which is the default. Cisco says you do not need an IP for Point to Point but I have tried it both ways. I always use one on the WAN anyways for troubleshooting and tracking. A point to point is pretty straight forward or should be. No DLCI's, it is full T so no time slots, bandwidth is full 1544kb.

I agree the settings are required but many are also defaulted. From everything I have read and experienced in the latter rev operating systems when values are at their default they do not show when you do a "sho running-config". When you do a "sho int s0" you can see the settings. It can drive you nuts if you keep putting in the setting and then it does not show.

These are new T1 cards. I just yanked a "known working" T1 WIC from another router to try.

New Member

Re: cannot get protocol up on S0 - Full t point-to-point

Sho Controller results-

QUICC Serial (with FT1 CSU/DSU WIC) unit 0

idb at 0x2508038, driver data structure at 0x25098A4

SCC Registers:

General [GSMR]=0x2:0x00000030, Protocol-specific [PSMR]=0x0

Events [SCCE]=0x0300, Mask [SCCM]=0x001F, Status [SCCS]=0x0003

Transmit on Demand [TODR]=0x0, Data Sync [DSR]=0x7E7E

Interrupt Registers:

Config [CICR]=0x00368461, Pending [CIPR]=0x01804600

Mask [CIMR]=0x50000850, In-srv [CISR]=0x00000000

Command register [CR]=0x680

Port A [PADIR]=0x0000, [PAPAR]=0xFCF3

[PAODR]=0x0000, [PADAT]=0x279E

Port B [PBDIR]=0x00F13E, [PBPAR]=0x0010CE

[PBODR]=0x000000, [PBDAT]=0x024ACD

Port C [PCDIR]=0x0087, [PCPAR]=0x0008

[PCSO]=0x0E30, [PCDAT]=0x0300, [PCINT]=0x0000

SCC GENERAL PARAMETER RAM (at 0xFF00E00)

Rx BD Base [RBASE]=0x500, Fn Code [RFCR]=0x18

Tx BD Base [TBASE]=0x540, Fn Code [TFCR]=0x18

Max Rx Buff Len [MRBLR]=1528

Rx State [RSTATE]=0x0, BD Ptr [RBPTR]=0x500

Tx State [TSTATE]=0x0, BD Ptr [TBPTR]=0x540

SCC HDLC PARAMETER RAM (at 0xFF00E38)

CRC Preset [C_PRES]=0xFFFF, Mask [C_MASK]=0xF0B8

Errors: CRC [CRCEC]=0, Aborts [ABTSC]=0, Discards [DISFC]=0

Nonmatch Addr Cntr [NMARC]=0

Retry Count [RETRC]=0

Max Frame Length [MFLR]=1526

Rx Int Threshold [RFTHR]=0, Frame Cnt [RFCNT]=65484

User-defined Address 0000/0000/0000/0000

User-defined Address Mask 0x0000

buffer size 1524

BRGC1=101B0, BRGC2=0, BRGC3=0, BRGC4=0

modem_signal_addr FF01566

MASK: DSR=40, DTR=80,RTS=4.CTS=100,DCD=200

txbrgc=FF015F8, rxbrgc=FF015F8

BRG [DTE]: rx_sicr_clk=5, tx_sicr_clk=4

BRG [DCE]: rx_sicr_clk=5, tx_sicr_clk=2

CLK SRC: sync=4000, async=4000

RX ring with 8 entries at 0xFF00500, Buffer size 1524

Rxhead = 0xFF00500 (0), Rxp = 0x25098C0 (0)

00 pak=0x25A998C buf=0x261DA60 status=9000 pak_size=0

01 pak=0x25A9788 buf=0x261D3A4 status=9000 pak_size=0

02 pak=0x25A9584 buf=0x261CCE8 status=9000 pak_size=0

03 pak=0x25A191C buf=0x263A4A4 status=9000 pak_size=0

04 pak=0x25A212C buf=0x263AB60 status=9000 pak_size=0

05 pak=0x25A2330 buf=0x263B21C status=9000 pak_size=0

06 pak=0x25A1310 buf=0x2639070 status=9000 pak_size=0

07 pak=0x25A0F08 buf=0x261E11C status=B000 pak_size=0

TX ring with 2 entries at 0xFF00540, tx_count = 0

tx_head = 0xFF00540 (0), head_txp = 0x250991C (0)

tx_tail = 0xFF00540 (0), tail_txp = 0x250991C (0)

00 pak=0x0000000 buf=0x0000000 status=0000 pak_size=0

01 pak=0x0000000 buf=0x0000000 status=2000 pak_size=0

QUICC SCC specific errors:

721 input aborts on receiving flag sequence

0 throttles, 0 enables

0 overruns

0 transmitter underruns

0 transmitter CTS losts

113
Views
0
Helpful
9
Replies
CreatePlease login to create content