Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cant ping serial ?

I have 2 directly connected 2501 routers hooked up via back-to-back DCE/DTE cable. I have configuerd my Serial Interfaces with; No shut, ip addresses 20.0.0.1 and 20.0.0.2, clock rate, and bandwidth. I have also enabled "router rip network 20.0.0.0".

"Serial0 is up, line protocol is up" on both router serials, however I cannot ping the interfaces from either router ? Please help.

-Yami

12 REPLIES
New Member

Re: Cant ping serial ?

By way of troubleshooting, try to check if there is any other protocol running prior to rip protocol and you have not done redistribution.

Again, try to reboot the two routers b/c memory problem could cause such.

New Member

Re: Cant ping serial ?

Make sure your ethernet interfaces are up.

ICMP echo and echo-replies require an ethernet address.

Serial interfaces do not have a hardware address assigned and must use one from an ethernet interface that is up/up.

New Member

Re: Cant ping serial ?

What subnet mask do you use

Silver

Re: Cant ping serial ?

Routing protocols have nothing to do with pinging directly connected . Can you paste in the config of both interfaces as well as a sh int serial x from both

New Member

Re: Cant ping serial ?

Hi Yami,

Do a debug ip packet and do the ping command again. This will give some visibility as to what is happening.

cheers

Victor

Network Engineer

Directfirst Computing Solutions Ltd

New Member

Re: Cant ping serial ?

Thanks to everyones help. I now have the serial interfaces pinging from router to directly connected router. It seems that I could not cable Serial 0 (R1) to Serial 1 (R2). Instead I had to go Serial 0 (R1) to Serial 0 (R2) and Serial 1 (R1) to Serial 1 (R2). At least that gave me "direct" ping, however I still have a big problem. I have added another router into my lab and now I realize that I cannot ping to routers that are not directly connected. ie R1 cannot ping R3. This is the config I currently have on the three routers;

hostname R1

!

enable secret xxxxx.

!

ip subnet-zero

!

!

!

!

interface Ethernet0

bandwidth 64

ip address 10.0.0.1 255.0.0.0

!

interface Serial0

bandwidth 64

ip address x.x.x.1 255.0.0.0

clockrate 64000

dce-terminal-timing-enable

!

interface Serial1

ip address x.x.x.1 255.0.0.0

clockrate 64000

!

router rip

network 10.0.0.0

network 20.0.0.0

network 30.0.0.0

!

ip http server

ip classless

!

!

!

!

line con 0

password xxxx

login

line aux 0

password xxxx

login

line vty 0 4

password xxxx

login

!

!

end

------------------------------------

hostname R2

!

enable secret xxxxxx!

ip subnet-zero

!

!

!

!

interface Ethernet0

bandwidth 64

ip address 10.0.0.2 255.0.0.0

!

interface Serial0

bandwidth 64

ip address x.x.x.2 255.0.0.0

no fair-queue

!

interface Serial1

bandwidth 64

ip address x.x.x.2 255.0.0.0

clockrate 64000

dce-terminal-timing-enable

!

router rip

network 10.0.0.0

network 20.0.0.0

network 30.0.0.0

!

ip http server

ip classless

!

!

!

!

line con 0

password xxxx

login

line aux 0

password xxxx

login

line vty 0 4

password cisco

login

!

!

end

--------------------------------

hostname R3

!

enable secret xxxxx

!

ip subnet-zero

!

!

!

!

interface Ethernet0

bandwidth 64

ip address 10.0.0.3 255.0.0.0

!

interface Serial0

bandwidth 64

ip address x.x.x.3 255.0.0.0

clockrate 64000

dce-terminal-timing-enable

!

interface Serial1

bandwidth 64

ip address x.x.x.3 255.0.0.0

!

router rip

network 10.0.0.0

network 20.0.0.0

network 30.0.0.0

!

no ip http server

ip classless

!

!

!

!

line con 0

line aux 0

line vty 0 4

password xxxx

login

!

!

end

Silver

Re: Cant ping serial ?

your serial 0 and 1 on one of the routers has to be up down . from what I have figured out you should be able to ping the 10 network from any router. Can you verify your topology

New Member

Re: Cant ping serial ?

Yes your correct, one Serial1 and Serial0 is connected to nothing. Right now Im just dealing with the serial connections so network 10.0.0.0 is out of the picture. Im dealing with

20.0.0.1 and 30.0.0.1 (R1)

-------I---------------------

20.0.0.2 and 30.0.0.2 (R2)

------------------------I----

20.0.0.3 and 30.0.0.3 (R3)

So

I can ping/telnet from 20.0.0.1 to 20.0.0.2

I can ping/telnet from 30.0.0.2 to 30.0.0.3

I can not ping/telnet from 20.0.0.1 to 30.0.0.2

I can not ping/telnet from 30.0.0.2 to 20.0.0.3

Silver

Re: Cant ping serial ?

I beleive that the interface 20.0.0.3 should be up/down or it is connected to an interface 30.0.0.1 that is on a different subnet , and this is the reason you can not ping .

you should be able to ping from 20.0.0.1 to 30.0.0.2 , can you paste in a sh ip route from both routers

New Member

Re: Cant ping serial ?

This is what I have for the "Sh ip ro";

R1

---

Gateway of last resort is not set

C 20.0.0.0/8 is directly connected, Serial0

R 10.0.0.0/8 [120/3] via 20.0.0.2, 00:00:05, Serial0

R 30.0.0.0/8 [120/1] via 20.0.0.2, 00:00:05, Serial0

R2

----

Gateway of last resort is not set

C 20.0.0.0/8 is directly connected, Serial0

R 10.0.0.0/8 [120/2] via 30.0.0.3, 00:00:19, Serial1

C 30.0.0.0/8 is directly connected, Serial1

R3

----

Gateway of last resort is not set

C 20.0.0.0/8 is directly connected, Serial0

R 10.0.0.0/8 [120/1] via 20.0.0.4, 00:00:07, Serial0

C 30.0.0.0/8 is directly connected, Serial1

RIP dose work on Ethernet "and" Serial links right ?

Silver

Re: Cant ping serial ?

Try this , on all interfaces that are not in use are are not up up admin them down. i.e the ethernet segment and , I beleive the s0 of the router 3 should be up down , it does not appear to be connected to anything, and if it is the only available interface is s1 of router 1 and that is on a different network .

New Member

Re: Cant ping serial ?

RIP does work on Ethernet and Serial links.

Could you please paste the results of a "show cdp neighbor"

207
Views
0
Helpful
12
Replies