Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cat 2950 not switching between ports

I have a Cat2950 series switch we have configured only three ports to be up the others having all been shut down.

We are having problems with these three ports the devices cannot see each other.

Devices connecting to the switch are 2 routers and a firewall. The link lights are green and are blinking intermittently.

I have not configured and IP (shouldn’t need to because this is a layer two device) but its bugging me that I have not done so and I some how think this is the problem. Is this the problem? Or is there something else that I am over looking?

  • Other Network Infrastructure Subjects
12 REPLIES
New Member

Re: Cat 2950 not switching between ports

Can you post the configuration of the three ports then we all can take a look at how its configured. You should not have to put an ip address on the ports of the switch but should have one to manage the switch from. Be sure all the ports are on the same VLAN. (i'll assume you've already done that)

New Member

Re: Cat 2950 not switching between ports

I dont want to administer this switch via telnet so no ip is requred we have a console cable for that. all int are in the native vlan (vlan1) vlan 1 is up.

below is the run config:

Current configuration : 1936 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname IntecSwitch

!

enable secret 5

enable password 7

!

ip subnet-zero

vtp mode transparent

!

spanning-tree extend system-id

!

!

interface FastEthernet0/1

description Connection to Netscreen

no ip address

!

interface FastEthernet0/2

description Connection to UUNET

no ip address

!

interface FastEthernet0/3

description Connection to IS

no ip address

!

interface FastEthernet0/4

no ip address

shutdown

!

interface FastEthernet0/5

no ip address

shutdown

!

interface FastEthernet0/6

no ip address

shutdown

!

interface FastEthernet0/7

no ip address

shutdown

!

interface FastEthernet0/8

no ip address

shutdown

!

interface FastEthernet0/9

no ip address

shutdown

!

interface FastEthernet0/10

no ip address

shutdown

!

interface FastEthernet0/11

no ip address

shutdown

!

interface FastEthernet0/12

no ip address

shutdown

!

interface FastEthernet0/13

no ip address

shutdown

!

interface FastEthernet0/14

no ip address

shutdown

!

interface FastEthernet0/15

no ip address

shutdown

!

interface FastEthernet0/16

no ip address

shutdown

!

interface FastEthernet0/17

no ip address

shutdown

!

interface FastEthernet0/18

no ip address

shutdown

!

interface FastEthernet0/19

no ip address

shutdown

!

interface FastEthernet0/20

no ip address

shutdown

!

interface FastEthernet0/21

no ip address

shutdown

!

interface FastEthernet0/22

no ip address

shutdown

!

interface FastEthernet0/23

no ip address

shutdown

!

interface FastEthernet0/24

no ip address

shutdown

interface FastEthernet0/24

no ip address

shutdown

!

interface Vlan1

no ip address

no ip route-cache

!

ip http server

!

banner motd ^C

This is a secure Switch no Unautorised access is allowed! If you are unsure plea

se disconnect.^C

!

line con 0

password 7

line vty 0 4

login

line vty 5 15

login

!

end

Re: Cat 2950 not switching between ports

Did you configure anything on the switch?

eg

Cat2950(config)#int range fa0/1 - 4

Cat2950(config-if-range)#switchport access vlan 10

I also assume the 3 devices are on the same subnet. Can you post the config? What does show int f0/1 show (ie up/up)? Are there errors on the interfaces (ie speed/duplex issue)? You would give the switch an IP if you want to be able to telnet to it (a good idea) for management, and a gateway if you want to be able to access the switch from other vlans.

Steve

New Member

Re: Cat 2950 not switching between ports

have left them all in vlan 1, because I did know if it was the vlan causing the problem, the idea will be to move them into there own vlan but I have to get it working first. all interfaces show up up speed and duplex have not been configured until we have it running currently they are set to auto.

New Member

Re: Cat 2950 not switching between ports

Under each of the 3 ports you need to place them in VLAN 1 by using the switchport access vlan 1 command, this should get you going.

-d

New Member

Re: Cat 2950 not switching between ports

by default all ports are in this vlan, I can confirm this by doing a show vlan,

which gives me this:

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4

Fa0/5, Fa0/6, Fa0/7, Fa0/8

Fa0/9, Fa0/10, Fa0/11, Fa0/12

Fa0/13, Fa0/14, Fa0/15, Fa0/16

Fa0/17, Fa0/18, Fa0/19, Fa0/20

Fa0/21, Fa0/22, Fa0/23, Fa0/24

1002 fddi-default active

1003 token-ring-default active

1004 fddinet-default active

1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1 enet 100001 1500 - - - - - 0 0

1002 fddi 101002 1500 - - - - - 0 0

1003 tr 101003 1500 - - - - - 0 0

1004 fdnet 101004 1500 - - - ieee - 0 0

1005 trnet 101005 1500 - - - ibm - 0 0

as you can see the ports are in vlan 1 already

New Member

Re: Cat 2950 not switching between ports

Ok.....so what are the IP addresses of the routers and the netscreen?

New Member

Re: Cat 2950 not switching between ports

The IP addresses I cant really disclose but we have confirmed that they are in the same subnet /27 and are from in the same range.

I have removed the switch and added two clients with ip 10.2.5.7 and 10.2.5.8 on /24 network and connected themt o the switch and they cannot see each other either. its as if the switching method (cut trough or store and forward) is disabled. or not currently running.

is this possible and can I change that?

New Member

Re: Cat 2950 not switching between ports

Help needed urgently

ok I have been playing around and I have noticed that loopback was not set on the vlan so tried it out and now I am getting traffic across the switch but very intermittenly and at about 1000 ms latency. which is strange if you have two clietns directly connected to the switch.

any other ideas

97
Views
0
Helpful
12
Replies