Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

cat 3550 with strange 'show running-config' message

I don't see no message when 'sh run' command

but when 'sh config' appear normal.

Image Problem? or not? (12.1.11EA1)

Could you please let me know how to resolve this problem?

'sh run'

===================================================

KS3550C_DMZ1#sh run

Building configuration...

Current configuration : 120 bytes

!

! No configuration change since last restart

! NVRAM config last updated at 05:57:15 kst Sun Apr 20 2003

!

!

!

!

end

====================================================

'sh config'

=======================================================

KS3550C_DMZ1#sh config

Using 4392 out of 393216 bytes

!

! No configuration change since last restart

! NVRAM config last updated at 05:57:15 kst Sun Apr 20 2003

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log datetime localtime

service password-encryption

!

hostname KS3550C_DMZ1

!

enable secret xxxxx

!

clock timezone kst -9

ip subnet-zero

ip routing

ip name-server xxx.xxx.5.15

!

!

spanning-tree extend system-id

!

!

define interface-range name GigabitEthernet0/1 - 12

!

interface Port-channel3

switchport access vlan 3

switchport mode access

no ip address

!

interface GigabitEthernet0/1

description ======= DMZ F/W #1 =======

switchport access vlan 4

switchport mode access

no ip address

!

interface GigabitEthernet0/2

description ======= DMZ F/W #2 =======

switchport access vlan 4

switchport mode access

no ip address

!

interface GigabitEthernet0/3

switchport mode access

no ip address

shutdown

!

interface GigabitEthernet0/4

switchport mode access

no ip address

shutdown

!

interface GigabitEthernet0/5

switchport mode access

no ip address

shutdown

!

interface GigabitEthernet0/6

switchport mode access

no ip address

shutdown

!

interface GigabitEthernet0/7

switchport mode access

no ip address

shutdown

!

interface GigabitEthernet0/8

switchport mode access

no ip address

shutdown

!

interface GigabitEthernet0/9

description ======= BDKS3550D Channel =======

switchport access vlan 3

switchport mode access

no ip address

channel-group 3 mode on

!

interface GigabitEthernet0/10

description ======= BDKS3550D Channel =======

switchport access vlan 3

switchport mode access

no ip address

channel-group 3 mode on

!

interface GigabitEthernet0/11

description ======= Screen Router =======

switchport access vlan 11

switchport mode access

no ip address

duplex full

speed 100

!

interface GigabitEthernet0/12

switchport mode access

no ip address

shutdown

!

interface Vlan1

no ip address

shutdown

!

interface Vlan3

ip address xxx.xxx.17.229 255.255.255.252

!

interface Vlan4

ip address xxx.xx.17.130 255.255.255.240

no ip redirects

standby 40 ip 10.0.17.129

standby 40 priority 120

standby 40 preempt

!

interface Vlan11

ip address xxx.xxx.136.33 255.255.255.240

!

router eigrp 200

redistribute static

passive-interface Vlan4

network 10.0.0.0

network 156.147.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 156.147.136.34

ip route 10.0.17.0 255.255.255.248 10.0.17.132

ip route 10.0.17.8 255.255.255.248 10.0.17.132

ip route 10.0.17.144 255.255.255.240 10.0.17.132

ip route 10.0.17.232 255.255.255.252 10.0.17.132

ip route 10.10.10.0 255.255.255.0 10.0.17.132

ip route 10.10.20.0 255.255.255.0 10.0.17.132

ip route 100.100.100.0 255.255.255.0 10.0.17.132

ip route 156.147.32.224 255.255.255.240 10.0.17.132

ip route 156.147.54.0 255.255.255.0 10.0.17.132

ip route 156.147.135.0 255.255.255.0 10.0.17.132

ip route 156.147.216.128 255.255.255.224 10.0.17.132

ip route 165.243.115.0 255.255.255.128 10.0.17.132

ip route 165.244.60.0 255.255.255.0 10.0.17.132

no ip http server

!

!

!

logging trap debugging

logging 156.147.54.46

access-list 10 permit 156.147.54.63

access-list 10 permit 156.147.54.51

access-list 10 permit 156.147.54.41

access-list 10 permit 156.147.54.40

access-list 10 permit 156.147.54.45

access-list 10 permit 156.147.54.47

access-list 10 permit 156.147.54.33

access-list 10 permit 156.147.54.35

access-list 10 permit 156.147.54.38

access-list 10 permit 156.147.54.107

access-list 10 permit 156.147.54.179

access-list 10 permit 156.147.54.169

access-list 10 permit 156.147.54.170

access-list 10 permit 156.147.54.234

access-list 10 deny any

snmp-server engineID local xxxxx

snmp-server community xxxx

banner motd ^C

* Unauthorized aCCess will be proseCuted by all means!!

^C

privilege exec level 10 telnet

privilege exec level 10 traceroute

privilege exec level 10 ping

privilege exec level 10 show running-config

privilege exec level 10 show configuration

privilege exec level 10 show clear ip accounting

!

line con 0

line vty 0 1

access-class 10 in

privilege level 10

password xxx

login

line vty 2 4

access-class 10 in

exec-timeout 15 0

privilege level 10

password xxxx

login

line vty 5

access-class 10 in

privilege level 10

password xxxx

login

line vty 6 15

password xxxx

login

!

end

==============================================

2 REPLIES
New Member

Re: cat 3550 with strange 'show running-config' message

Hi lee,

this is a normal beheviour of IOS

When configuring access to the router by privilege levels, a common issue is that the show running or write terminal command is configured at or below the user's privilege level. But, when the user executes the command, the configuration appears to be blank. This is actually by design, as explained below.

The write terminal / show running-config command shows a blank configuration. This command displays all of the commands that the current user is able to modify (in other words, all the commands at or below the user's current privilege level). The command should not display commands above the user's current privilege level because of security considerations. If it did, commands like snmp-server community could be used to modify the current configuration of the router and gain complete access to the router.

The show config / show start-up config command displays a full configuration but does not truly show the actual configuration. Instead, the command simply prints out the contents of NVRAM, which happens to be the configuration of the router at the time the user does a write memory.

this link is useful for you

http://www.cisco.com/en/US/tech/tk583/tk642/technologies_tech_note09186a00800949d5.shtml

New Member

Re: cat 3550 with strange 'show running-config' message

try to connect enable password

256
Views
0
Helpful
2
Replies
CreatePlease login to create content