Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cat 3750, IP Phones, and voice vlan's

We have a 3750-48 Port Inline Power Switch that has been in production for about 3 months. There are about 20 Cisco phones on there. Lately, when we plug in a brand new phone (never been on our network) it tries to use the data vlan information and never boots up (due to no TFTP option, voice router in data vlan). Any configuration thoughts why? If I change the port to "switchport access vlan 10" it works fine. Then changing the access vlan back to the data vlan the phone still boots fine.

Any suggestions appreciated!

interface FastEthernet1/0/x

description Data-Voice Connection

switchport access vlan 26

switchport voice vlan 10

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust device cisco-phone

mls qos trust cos

macro description PHONES

auto qos voip cisco-phone

no mdix auto

spanning-tree portfast

spanning-tree bpduguard enable

interface Vlan10

description Voice VLAN

ip address 10.x.x.1 255.255.255.0

ip helper-address 10.x.x.245 (Phone DHCP Server)

!

interface Vlan26

description Data VLAN

ip address 172.x.x.2 255.255.0.0

standby 26 ip 172.x.x.1

standby 26 priority 90

standby 26 preempt

7 REPLIES

Re: Cat 3750, IP Phones, and voice vlan's

Did you verify that the phone had its configuration (previous) erased? Even though the phone is brand new, I have seen a lot of brand new phones out of the box having an IP address, DHCP server, TFTP etc already in there. (Probably Cisco tests every phone before they ship it out ?)

THoughts...

Re: Cat 3750, IP Phones, and voice vlan's

I would check that your DHCP server isn't configured for Superscopes with both your Voice & Data VLAN's - it's possible the IP Phone is re-requesting a previously leased IP address and the DHCP server is happy to supply it due to Superscopes. Also check on the IP Phones what the Operational VLAN Id is (verify CDP is working correctly between the Phone and the Switchport).

Other than that are you giving the phones enough time to boot? I have seen phones take about 3-4 minutes to boot and register if they have been moved between VLAN's.

HTH

Andy

VIP Purple

Re: Cat 3750, IP Phones, and voice vlan's

Hello,

in addition to the other posts (and I might be off here), I wonder if this problem has to do with bpduguard enabled on the interface, which might somehow mess with the 802.1Q trunk formed with the phone. Do the other (working) ports have that feature enabled as well ? I might be worth giving it a try and turn it off...

Regards,

GP

Re: Cat 3750, IP Phones, and voice vlan's

I am voting the same as my appreciated colleague Georg. I have seen some rather odd behaviour on ports where bpduguard is active. This feature is not absolutely necessary unless you are paranoid about users "patching in the wild". This is merely a matter of discipline. (a pity you cannot hunt them as if they were in the wild! ;-)

I would try to switch bpduguard off and repeat the test, that is, if this is still possible. As you have noticed yourself, the phones tend to remember their previous settings so this one now may keep on working despite your changes.

Regards,

Leo

Re: Cat 3750, IP Phones, and voice vlan's

I have had a problem with BPDU Guard with IOS 12.2(25)x on Catalyst 3550's and 3750's. The switch error disables the port and shuts it down, but only whilst the switch is still booting. It seems when the switch has booted a certain amount it allows inline power to be given to ports, the problem is as soon as the port becomes active it 'sees' a BPDU and error disables the port. I assume the code isn't fully initialised and the BPDU is the switches own being bounced back as the phone initially starts up.

Once the switch is up and running these problems stop. I have enabled error disable recovery for BPDU guard and it's a fair workaround for the problem. I still haven't seen this listed as a bug yet though?

I doubt this is your problem though as you state you have inline powered switches so you would be dealing with 'dead' ports that were shutdown due to them being error disabled. You describe your problem with the ports being active (inline power to your IP Phones).

HTH

Andy

New Member

Re: Cat 3750, IP Phones, and voice vlan's

Here is a response to everyone's suggestions (by the way, thanks):

How do you erase the config of the phone so no existing network info exist?

I am not using Superscope DHCP and I always give the phone 5-10 minutes for initial boot

All of our switchports have bpduguard enabled. This doesn't just happen on this port (or switch for that matter). I have seen happen randomly on other switches (3524's, 3550's, and 3750's), but all have bpduguard enabled. Therefore, as soon as this happens again I will remove this setting and then see what happens (and will respond promptly thereafter).

Re: Cat 3750, IP Phones, and voice vlan's

To answer the question on erasing ph. config -

Hit the settings button,

option 3

option 33

you should see a lock on the top right hand side of the text Network Configuration. You need to unlock this.

To unlock press **#

THe lock unlocks

a "Yes" softkey shows up and you should be able to rease the configuration now.

HTH

PS: Please remember to rate helpful replies!

212
Views
0
Helpful
7
Replies
CreatePlease to create content