Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cat 4006 Packet loss

Hi,

We are having a CAT 4006 (IOS ver.) Switch with two VALN's(Data and Voice) and we are getting packet loss without QoS configured and no packet loss with QoS configured.

If you look into interface you won't see anything out of the ordinary, but if you

try : Cat> sh int fast2/23 summ

you will see the Packet Drops from Output Queue OQD=26900 and we kind of wondering what is causing these.

We went to do some search on Cisco.com and at this point we couldn't get an answer to this issue.

I am wondering if someone has this issue and what was the fix?

Cat 4006 has SUP 2+ , no spanning tree and IOS:

cat4000-i9k91s-mz.122-25.EWA5.bin

cat>qos dbl exceed-action ecn

qos dbl

qos map dscp 0 to tx-queue 2

qos map cos 5 to dscp 46

qos

............

class-map match-all VOICE-VLAN

match access-group name VOICE-VLAN

!

!

policy-map BUFF

class class-default

dbl

policy-map IPPHONE

class VOICE-VLAN

set dscp ef

class class-default

set dscp default

........

!

interface GigabitEthernet1/1

description Uplink to Core_SW 4/9

switchport access vlan 100

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,100,200,210 switchport mode trunk service-policy output BUFF qos trust dscp tx-queue 1

bandwidth percent 5

tx-queue 2

bandwidth percent 25

tx-queue 3

bandwidth percent 30

priority high

shape percent 30

tx-queue 4

bandwidth percent 40

no cdp enable

..................

interface FastEthernet2/23

description 2C119-2 004

switchport access vlan 100

switchport voice vlan 210

service-policy output BUFF

qos trust dscp

tx-queue 3

priority high

shape percent 30

no cdp enable

..............

ip access-list extended VOICE-VLAN

permit ip X.Y.Z.V any dscp ef

....................

CAT>sh int fa2/23 sum

*: interface is up

IHQ: pkts in input hold queue IQD: pkts dropped from input queue

OHQ: pkts in output hold queue OQD: pkts dropped from output queue

RXBS: rx rate (bits/sec) RXPS: rx rate (pkts/sec)

TXBS: tx rate (bits/sec) TXPS: tx rate (pkts/sec)

TRTL: throttle count

Interface IHQ IQD OHQ OQD RXBS RXPS TXBS TXPS TRTL

------------------------------------------------------------------------

* FastEthernet3/10 0 0 0 26900 0 0 61000 67 0

NOTE:No separate counters are maintained for subinterfaces

Hence Details of subinterface are not shown

CAT>sh int fa3/23 count

Port InBytes InUcastPkts InMcastPkts InBcastPkts

Fa3/10 79664016 352391 863 4760

Port OutBytes OutUcastPkts OutMcastPkts OutBcastPkts

Fa3/10 1165018481 472486 487050 8605889

C46-1-2A213>sh int fa2/23 count err

Port CrcAlign-Err Dropped-Bad-Pkts Collisions Symbol-Err

Fa3/10 0 0 0 0

Port Undersize Oversize Fragments Jabbers

Fa3/10 0 0 0 0

Port Single-Col Multi-Col Late-Col Excess-Col

Fa3/10 0 0 0 0

Port Deferred-Col False-Car Carri-Sen Sequence-Err

Fa3/10 0 0 0 0

2 REPLIES
Bronze

Re: Cat 4006 Packet loss

Could you check whether rate limiting is enabled in the switch ,if it is enabled then the functionality will be same as QOS.

Rate limiting is the same thing as Qos policing in cat4000 it mark frames/packets going through the switch as confirming and non-confirming.Non-confirming frames/packets will be drop.

New Member

Re: Cat 4006 Packet loss

Hi,

We do not have rate limiting configured into CAT 4006.

Also I am wondering way the packet loss shows up only in "sh int fast2/22 summ" and not into "sh int fast 2/22 count err" . At this point is still a puzzle to me. If someone has seeing this in the past please let me know what was the fix?

Best,

Mike

202
Views
0
Helpful
2
Replies