Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cat-4506-IOS and VoIP config

I currently have a Cat-3750 with a phone and a PC plugged into a port and connected to a 28xx router. This is all configured up and working with QOS and voice and data vlans.

I need to replace the 28xx router with a Cat-4506 but am running into problems.

Here are parts of the config of the 28xx router for the interface that feeds the 3750 switch:

interface FastEthernet0/0

ip route-cache flow

duplex full

speed 100

!

interface FastEthernet0/0.10

description data vlan

encapsulation dot1Q 10

ip address 164.7x.54.1 255.255.255.128

ip helper-address 164.7x.54.30

!

interface FastEthernet0/0.910

description Voice vlan

encapsulation dot1Q 910

ip address 172.2x.54.1 255.255.255.128

ip helper-address 164.7x.54.30

Here are parts of the Cat-3750 switch that feed the port where the phone and PC are plugged in to and the port that connects to the 28xx router:

interface FastEthernet1/0/11

description Phone and PC w/o trunk

switchport access vlan 10

switchport mode access

switchport voice vlan 910

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust dscp

auto qos voip trust

spanning-tree portfast

interface FastEthernet1/0/24

description link to 2811 F0/0

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,10,910

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust dscp

auto qos voip trust

spanning-tree portfast

I need to replace the 28xx router with a Cat-4506 running IOS ver. 12.2(31).SG.bin

and the 3750 access switch plugged into a port on a WS-X4506-GB-T blade. Routing is turned on and I wanted to make the 4506 port a routed port (just like the 28xx port).

However I'm am now running into problems. It seems I cannot create sub-interfaces on the WS-X4506-GB-T ports, or it is done differently then on the 28xx router.

So some questions:

1. Is it true the WS-X4506-GB-T will not allow subinterfaces config'd on its ports?

2. If so is there a 4506 gig blade that does allow subinterfaces?

3. If not what is the best way to config the 4506 to allow for the voice and data vlan on the 3750 to work?

4. Will the 4506 allow me to config LLQ service policies?

2 REPLIES
Silver

Re: Cat-4506-IOS and VoIP config

The module won't allow subinterfaces to be configured on it.The 4506 allwos to config llq service policies.

New Member

Re: Cat-4506-IOS and VoIP config

I tried to create an LLQ policy but could not. Here is what I tried:

class-map match-all Voice

match ip dscp ef

TSC-RS4506-A(config)#policy-map QOS_classes

TSC-RS4506-A(config-pmap)# class Voice

TSC-RS4506-A(config-pmap-c)#priority

^

% Invalid input detected at '^' marker.

There is no provision for the LLQ 'priority' command.

This is all that is allowed:

TSC-RS4506-A(config)#policy-map QOS_classes

TSC-RS4506-A(config-pmap)# class Voice

TSC-RS4506-A(config-pmap-c)#?

QoS policy-map class configuration commands:

dbl Dynamic buffer limiting

exit Exit from QoS class action configuration mode

netflow-sampler NetFlow action

no Negate or set default values of a command

police Police traffic matching current class

service-policy Configure QoS Service Policy

set Set QoS values

trust Set trust value for the class

Is there another way to set up priority queueing with the 4506 Sup V-10GE?

819
Views
0
Helpful
2
Replies
CreatePlease login to create content